summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2005-09-02 21:41:34 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2005-09-02 21:41:34 +0000
commitc52ec93654680b4b663c2176c2fc812316ca0178 (patch)
tree9270bc79f2f64b05c583108b6f451452ff0f4056 /media-video/vls
parentFixed an ifc bug, tidied up and added ifc support on amd64. (diff)
downloadhistorical-c52ec93654680b4b663c2176c2fc812316ca0178.tar.gz
historical-c52ec93654680b4b663c2176c2fc812316ca0178.tar.bz2
historical-c52ec93654680b4b663c2176c2fc812316ca0178.zip
added include path for newer libdvb ebuild
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'media-video/vls')
-rw-r--r--media-video/vls/ChangeLog6
-rw-r--r--media-video/vls/vls-0.5.6-r1.ebuild8
-rw-r--r--media-video/vls/vls-0.5.6-r2.ebuild8
3 files changed, 17 insertions, 5 deletions
diff --git a/media-video/vls/ChangeLog b/media-video/vls/ChangeLog
index 35c0410a5e2d..cc0a59a64331 100644
--- a/media-video/vls/ChangeLog
+++ b/media-video/vls/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/vls
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vls/ChangeLog,v 1.18 2005/06/19 19:27:08 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vls/ChangeLog,v 1.19 2005/09/02 21:41:34 zzam Exp $
+
+ 02 Sep 2005; Matthias Schwarzott <zzam@gentoo.org> vls-0.5.6-r1.ebuild,
+ vls-0.5.6-r2.ebuild:
+ added include path for newer libdvb ebuild
19 Jun 2005; Jason Wever <weeve@gentoo.org> vls-0.5.6-r2.ebuild:
Changed -sparc keyword to ~sparc.
diff --git a/media-video/vls/vls-0.5.6-r1.ebuild b/media-video/vls/vls-0.5.6-r1.ebuild
index ce4adeae58c5..01892353f2ab 100644
--- a/media-video/vls/vls-0.5.6-r1.ebuild
+++ b/media-video/vls/vls-0.5.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vls/vls-0.5.6-r1.ebuild,v 1.5 2005/01/29 00:27:08 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vls/vls-0.5.6-r1.ebuild,v 1.6 2005/09/02 21:41:34 zzam Exp $
IUSE="debug dvd dvb"
@@ -23,7 +23,11 @@ src_compile() {
use dvd || myconf="${myconf} --disable-dvd"
- use dvb && myconf="${myconf} --enable-dvb"
+ if use dvb; then
+ export CCFLAGS="-I/usr/include/libdvb"
+ export CPPFLAGS="${CPPFLAGS} -I/usr/include/libdvb"
+ myconf="${myconf} --enable-dvb --with-libdvb=/usr/lib/"
+ fi
econf ${myconf} || die "econf failed"
diff --git a/media-video/vls/vls-0.5.6-r2.ebuild b/media-video/vls/vls-0.5.6-r2.ebuild
index 2968e84d7a37..8d5a8bdd287d 100644
--- a/media-video/vls/vls-0.5.6-r2.ebuild
+++ b/media-video/vls/vls-0.5.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vls/vls-0.5.6-r2.ebuild,v 1.5 2005/06/19 19:27:08 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vls/vls-0.5.6-r2.ebuild,v 1.6 2005/09/02 21:41:34 zzam Exp $
inherit eutils
@@ -30,7 +30,11 @@ src_compile() {
local myconf
use debug || myconf="--disable-debug"
- use dvb && myconf="${myconf} --enable-dvb --with-libdvb=/usr/lib/"
+ if use dvb; then
+ export CCFLAGS="-I/usr/include/libdvb"
+ export CPPFLAGS="${CPPFLAGS} -I/usr/include/libdvb"
+ myconf="${myconf} --enable-dvb --with-libdvb=/usr/lib/"
+ fi
econf $(use_enable dvd) \
${myconf} || die "econf failed"