summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-06 21:20:03 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-06 21:20:03 +0000
commit3b7d89ddf65d7b836e4968c9f2fdff9166b3fe46 (patch)
tree39fac2b4a0303f8c00fc06a641bd7ab920233b7f /media-video/xine-ui/xine-ui-0.9.10-r1.ebuild
parentresurrected ppc compatible xine-lib (diff)
downloadhistorical-3b7d89ddf65d7b836e4968c9f2fdff9166b3fe46.tar.gz
historical-3b7d89ddf65d7b836e4968c9f2fdff9166b3fe46.tar.bz2
historical-3b7d89ddf65d7b836e4968c9f2fdff9166b3fe46.zip
resurrected xine-ui-0.9.10-r1 for ppc people
Diffstat (limited to 'media-video/xine-ui/xine-ui-0.9.10-r1.ebuild')
-rw-r--r--media-video/xine-ui/xine-ui-0.9.10-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-video/xine-ui/xine-ui-0.9.10-r1.ebuild b/media-video/xine-ui/xine-ui-0.9.10-r1.ebuild
new file mode 100644
index 000000000000..d237b39bba63
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.9.10-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.10-r1.ebuild,v 1.5 2002/08/06 21:20:03 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
+HOMEPAGE="http://xine.sourceforge.net/"
+SRC_URI="http://xine.sourceforge.net/files/${P}.tar.gz"
+
+DEPEND="media-libs/libpng
+ >=media-libs/xine-lib-${PV}
+ X? ( virtual/x11 )
+ directfb? ( >=dev-libs/DirectFB-0.9.9 )
+ gnome? ( gnome-base/ORBit )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ use directfb || ( \
+ sed -e "s:dfb::" src/Makefile.in \
+ > src/Makefile.in.hacked
+ mv src/Makefile.in.hacked src/Makefile.in
+ )
+
+ sed -e "s:LDFLAGS =:LDFLAGS = -L/lib:" src/xitk/Makefile.in \
+ > src/xitk/Makefile.in.hacked
+ mv src/xitk/Makefile.in.hacked src/xitk/Makefile.in
+
+}
+
+src_compile() {
+
+ # Most of these are not working currently, but are here for completeness
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}