summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-12-10 17:51:34 +0000
committerJeroen Roovers <jer@gentoo.org>2009-12-10 17:51:34 +0000
commitd96cbe16c17d7ca6f76f3a16a836dd04c60390a1 (patch)
tree5b2c96fde377cdda49c45ee4982422ea2282ad39 /net-analyzer/arping/arping-2.08-r1.ebuild
parentamd64 stable wrt #296420 (diff)
downloadhistorical-d96cbe16c17d7ca6f76f3a16a836dd04c60390a1.tar.gz
historical-d96cbe16c17d7ca6f76f3a16a836dd04c60390a1.tar.bz2
historical-d96cbe16c17d7ca6f76f3a16a836dd04c60390a1.zip
Fix executable name in man page and example script, and fix example script name (bug #257864). Use PN instead of hardcoding package name.
Package-Manager: portage-2.2_rc57/cvs/Linux i686
Diffstat (limited to 'net-analyzer/arping/arping-2.08-r1.ebuild')
-rw-r--r--net-analyzer/arping/arping-2.08-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/arping/arping-2.08-r1.ebuild b/net-analyzer/arping/arping-2.08-r1.ebuild
new file mode 100644
index 000000000000..01d70f00c305
--- /dev/null
+++ b/net-analyzer/arping/arping-2.08-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/arping/arping-2.08-r1.ebuild,v 1.1 2009/12/10 17:51:34 jer Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A utility to see if a specific IP address is taken and what MAC address owns it"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=arping"
+SRC_URI="ftp://ftp.habets.pp.se/pub/synscan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap
+ >=net-libs/libnet-1.1.0-r3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f Makefile
+ # since we install as arping2, use arping2 in the man page
+ sed -i -e "s|\(${PN}\)|\12|g" ${PN}.8 || die "sed ${PN}.8 failed"
+ sed -i -e "s|\(${PN}\) |\12 |g" ${PN}-scan-net.sh || \
+ die "sed ${PN}-scan-net.sh failed"
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ LDLIBS="-lpcap -lnet" \
+ arping-2/arping \
+ || die
+}
+
+src_test() {
+ einfo "Selftest only works as root"
+ #make SUDO= HOST=`hostname` MAC=`ifconfig -a | fgrep HWaddr | sed 's/.*HWaddr //g'` test
+}
+
+src_install() {
+ newsbin ${PN}-2/${PN} ${PN}2 || die
+ newman ${PN}.8 ${PN}2.8
+ dodoc README
+ newdoc ${PN}{,2}-scan-net.sh
+}