summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-12 15:08:42 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-12 15:08:42 +0000
commit1a7f3ff69be0ed9843c8a1ca23f38e95e1991c1a (patch)
tree98e8ae746913c770d3d586ce274d4b22925b34c8 /net-analyzer/libnasl
parentVersion bump (diff)
downloadhistorical-1a7f3ff69be0ed9843c8a1ca23f38e95e1991c1a.tar.gz
historical-1a7f3ff69be0ed9843c8a1ca23f38e95e1991c1a.tar.bz2
historical-1a7f3ff69be0ed9843c8a1ca23f38e95e1991c1a.zip
Fix for #10521.
Diffstat (limited to 'net-analyzer/libnasl')
-rw-r--r--net-analyzer/libnasl/ChangeLog8
-rw-r--r--net-analyzer/libnasl/libnasl-1.2.4.ebuild18
-rw-r--r--net-analyzer/libnasl/libnasl-1.2.6.ebuild22
3 files changed, 29 insertions, 19 deletions
diff --git a/net-analyzer/libnasl/ChangeLog b/net-analyzer/libnasl/ChangeLog
index cada9dc3d023..39bdd536c61d 100644
--- a/net-analyzer/libnasl/ChangeLog
+++ b/net-analyzer/libnasl/ChangeLog
@@ -1,14 +1,20 @@
# ChangeLog for net-analyzer/libnasl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/ChangeLog,v 1.3 2002/11/05 19:29:05 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/ChangeLog,v 1.4 2002/11/12 15:08:42 aliz Exp $
*libnasl-1.2.6 (05 Nov 2002)
+ 12 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> libnasl-1.2.6.ebuild :
+ Fixed #10521.
+
05 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> :
Version bump.
*libnasl-1.2.4 (22 Aug 2002)
+ 12 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> libnasl-1.2.4.ebuild :
+ Fixed #10521.
+
22 Aug 2002; Nick Hadaway <raker@gentoo.org>
libnasl-1.2.4.ebuild, files/digest-libnasl-1.2.4 :
Version bump.
diff --git a/net-analyzer/libnasl/libnasl-1.2.4.ebuild b/net-analyzer/libnasl/libnasl-1.2.4.ebuild
index 70f80c5c056c..c9f010fd092b 100644
--- a/net-analyzer/libnasl/libnasl-1.2.4.ebuild
+++ b/net-analyzer/libnasl/libnasl-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/libnasl-1.2.4.ebuild,v 1.3 2002/10/20 18:50:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/libnasl-1.2.4.ebuild,v 1.4 2002/11/12 15:08:42 aliz Exp $
S=${WORKDIR}/${PN}
@@ -15,23 +15,26 @@ LICENSE="GPL-2"
KEYWORDS="x86 ppc -sparc -sparc64"
src_unpack() {
-
unpack ${A}
cd ${S}
patch -p1 < ${FILESDIR}/nasl.diff
-
}
src_compile() {
-
- econf || die "configuration failed"
+ if [ ! -z ${DEBUG} ]; then
+ OLD_DEBUG=${DEBUG}
+ unset DEBUG
+ econf || die "configuration failed"
+ DEBUG=${OLD_DEBUG}
+ unset OLD_DEBUG
+ else
+ econf || die "configuration failed"
+ fi
emake || die "emake failed"
-
}
src_install() {
-
make \
prefix=${D}/usr \
sysconfdir=${D}/etc \
@@ -42,5 +45,4 @@ src_install() {
cd ${S}
docinto libnasl
dodoc COPYING TODO
-
}
diff --git a/net-analyzer/libnasl/libnasl-1.2.6.ebuild b/net-analyzer/libnasl/libnasl-1.2.6.ebuild
index 7d1b173679fa..8bc02b4b7f4c 100644
--- a/net-analyzer/libnasl/libnasl-1.2.6.ebuild
+++ b/net-analyzer/libnasl/libnasl-1.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/libnasl-1.2.6.ebuild,v 1.1 2002/11/05 19:29:05 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/libnasl-1.2.6.ebuild,v 1.2 2002/11/12 15:08:42 aliz Exp $
S=${WORKDIR}/${PN}
@@ -15,23 +15,26 @@ LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc -sparc -sparc64"
src_unpack() {
-
unpack ${A}
cd ${S}
patch -p1 < ${FILESDIR}/nasl.diff
-
}
src_compile() {
-
- econf || die "configuration failed"
-
- emake || die "emake failed"
-
+ if [ ! -z ${DEBUG} ]; then
+ OLD_DEBUG=${DEBUG}
+ unset DEBUG
+ econf || die "configuration failed"
+ DEBUG=${OLD_DEBUG}
+ unset OLD_DEBUG
+ else
+ econf || die "configuration failed"
+ fi
+
+ emake || die "emake failed"
}
src_install() {
-
make \
prefix=${D}/usr \
sysconfdir=${D}/etc \
@@ -42,5 +45,4 @@ src_install() {
cd ${S}
docinto libnasl
dodoc COPYING TODO
-
}