summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-03-01 00:25:39 +0000
committerDean Bailey <alron@gentoo.org>2003-03-01 00:25:39 +0000
commit0bfb62a339b9416b8dc9b1e270dd1a527e2e0213 (patch)
tree897b9f258c2f380344bb56791650365b8f228f0f /net-analyzer/nagios-plugins
parentscr_install() rewritted and added support for $CFLAGS in scr_compile(). Confi... (diff)
downloadhistorical-0bfb62a339b9416b8dc9b1e270dd1a527e2e0213.tar.gz
historical-0bfb62a339b9416b8dc9b1e270dd1a527e2e0213.tar.bz2
historical-0bfb62a339b9416b8dc9b1e270dd1a527e2e0213.zip
version bump to beta3
Diffstat (limited to 'net-analyzer/nagios-plugins')
-rw-r--r--net-analyzer/nagios-plugins/ChangeLog6
-rw-r--r--net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.0_beta31
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.3.0_beta3.ebuild50
3 files changed, 56 insertions, 1 deletions
diff --git a/net-analyzer/nagios-plugins/ChangeLog b/net-analyzer/nagios-plugins/ChangeLog
index 2187705bc5e0..7f6ab547a771 100644
--- a/net-analyzer/nagios-plugins/ChangeLog
+++ b/net-analyzer/nagios-plugins/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nagios-plugins
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.7 2003/02/12 07:47:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.8 2003/03/01 00:25:39 alron Exp $
+
+*nagios-plugins-1.3.0_beta3
+ 28 Feb 2003; Dean Bailey <alron@gentoo.org> nagios-plugins-1.3.0_beta3 :
+ Version bump to beta3.
*nagios-plugins-1.3.0_beta2-r1
30 Jan 2003; Dean Bailey <alron@gentoo.org> nagios-plugins-1.3.0_beta2-r1 :
diff --git a/net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.0_beta3 b/net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.0_beta3
new file mode 100644
index 000000000000..57d28ee1b7f0
--- /dev/null
+++ b/net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.0_beta3
@@ -0,0 +1 @@
+MD5 fde17123732d7e31b5ab2cc5062a1c22 nagios-plugins-1.3.0-beta3.tar.gz 475928
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.3.0_beta3.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.3.0_beta3.ebuild
new file mode 100644
index 000000000000..f98d76fb98f9
--- /dev/null
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.3.0_beta3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.3.0_beta3.ebuild,v 1.1 2003/03/01 00:25:39 alron Exp $
+DESCRIPTION="Nagios $PV plugins - Pack of plugins to make Nagios work properly"
+HOMEPAGE="http://www.nagios.org/"
+SRC_URI="mirror://sourceforge/nagiosplug/nagios-plugins-1.3.0-beta3.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE=""
+DEPEND=">=bind-tools-9.2.2_rc1
+ >=openssl-0.9.6g
+ >=perl-5.6.1-r7
+ >=fping-2.4_beta2-r1
+ >=ntp-4.1.1a
+ >=Net-SNMP-4.0.1-r1
+ >=net-snmp-5.0.6
+ samba? ( >=samba-2.2.5-r1 )
+ >=openssh-3.5_p1
+ mysql? ( >=mysql-3.23.52-r1 )
+ >=autoconf-2.53a
+ >=qstat-25
+ postgre? ( >=postgresql-7.2 )"
+
+S="${WORKDIR}/nagios-plugins-1.3.0-beta3"
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr/nagios \
+ --with-nagios-user=nagios \
+ --sysconfdir=/etc/nagios \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ make || die
+}
+
+src_install() {
+ dodoc AUTHORS CODING COPYING ChangeLog FAQ INSTALL LEGALNEWS README REQUIREMENTS ROADMAP Requirements
+ make DESTDIR=${D} install || die
+}
+pkg_preinst() {
+ userdel nagios 2> /dev/null
+ if ! groupmod nagios; then
+ groupadd -g 75 nagios 2> /dev/null || \
+ die "Failed to create nagios group"
+ fi
+ useradd -u 75 -g nagios -s /dev/null -d /var/empty -c "nagios" nagios || \
+ die "Failed to create nagios user"
+ chown -R nagios:nagios ${D}/usr/nagios/libexec || die "Failed Chown of ${D}/usr/nagios/libexec"
+}