summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-03-16 18:41:38 +0000
committerDean Bailey <alron@gentoo.org>2003-03-16 18:41:38 +0000
commitbb52185fcab1ca8909610e394912b47e6d0bd4b2 (patch)
treef64b7249b46edfb7222fb4a48c6e8a33873390c5 /net-analyzer/nagios-plugins
parentfixed keywords (diff)
downloadhistorical-bb52185fcab1ca8909610e394912b47e6d0bd4b2.tar.gz
historical-bb52185fcab1ca8909610e394912b47e6d0bd4b2.tar.bz2
historical-bb52185fcab1ca8909610e394912b47e6d0bd4b2.zip
fixed a bug that caused nagios-plugins install to fail if it was installed before nagios-core.
Diffstat (limited to 'net-analyzer/nagios-plugins')
-rw-r--r--net-analyzer/nagios-plugins/ChangeLog7
-rw-r--r--net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.0_beta3-r11
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.3.0_beta3-r1.ebuild51
3 files changed, 58 insertions, 1 deletions
diff --git a/net-analyzer/nagios-plugins/ChangeLog b/net-analyzer/nagios-plugins/ChangeLog
index 1e66d2f2ab1c..7fe7deed5873 100644
--- a/net-analyzer/nagios-plugins/ChangeLog
+++ b/net-analyzer/nagios-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nagios-plugins
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.9 2003/03/01 01:16:23 alron Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.10 2003/03/16 18:41:38 alron Exp $
+
+*nagios-plugins-1.3.0_beta3-r1
+ 16 Mar 2003; Dean Bailey <alron@gentoo.org> nagios-plugins-1.3.0_beta3-r1 :
+ Fixed a problem where nagios-plugins was being installed before
+ nagios-core. This should fix bugs 16090 and 17127.
*nagios-plugins-1.3.0_beta3
28 Feb 2003; Dean Bailey <alron@gentoo.org> nagios-plugins-1.3.0_beta3 :
diff --git a/net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.0_beta3-r1 b/net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.0_beta3-r1
new file mode 100644
index 000000000000..57d28ee1b7f0
--- /dev/null
+++ b/net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.0_beta3-r1
@@ -0,0 +1 @@
+MD5 fde17123732d7e31b5ab2cc5062a1c22 nagios-plugins-1.3.0-beta3.tar.gz 475928
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.3.0_beta3-r1.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.3.0_beta3-r1.ebuild
new file mode 100644
index 000000000000..5a3720de636e
--- /dev/null
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.3.0_beta3-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.3.0_beta3-r1.ebuild,v 1.1 2003/03/16 18:41:38 alron Exp $
+DESCRIPTION="Nagios $PV plugins - Pack of plugins to make Nagios work properly"
+HOMEPAGE="http://www.nagios.org/"
+SRC_URI="mirror://sourceforge/nagiosplug/nagios-plugins-1.3.0-beta3.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~sparc ~ppc"
+IUSE=""
+DEPEND=">=bind-tools-9.2.2_rc1
+ >=openssl-0.9.6g
+ >=perl-5.6.1-r7
+ >=fping-2.4_beta2-r1
+ >=ntp-4.1.1a
+ >=Net-SNMP-4.0.1-r1
+ >=net-snmp-5.0.6
+ samba? ( >=samba-2.2.5-r1 )
+ >=openssh-3.5_p1
+ mysql? ( >=mysql-3.23.52-r1 )
+ >=autoconf-2.53a
+ >=qstat-25
+ postgres? ( >=postgresql-7.2 )"
+
+RDEPEND=">=nagios-core-1.0"
+S="${WORKDIR}/nagios-plugins-1.3.0-beta3"
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr/nagios \
+ --with-nagios-user=nagios \
+ --sysconfdir=/etc/nagios \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ make || die
+}
+
+src_install() {
+ dodoc AUTHORS CODING COPYING ChangeLog FAQ INSTALL LEGALNEWS README REQUIREMENTS ROADMAP Requirements
+ make DESTDIR=${D} install || die
+}
+pkg_preinst() {
+ userdel nagios 2> /dev/null
+ if ! groupmod nagios; then
+ groupadd -g 75 nagios 2> /dev/null || \
+ die "Failed to create nagios group"
+ fi
+ useradd -u 75 -g nagios -s /dev/null -d /var/empty -c "nagios" nagios || \
+ die "Failed to create nagios user"
+ chown -R nagios:nagios ${D}/usr/nagios/libexec || die "Failed Chown of ${D}/usr/nagios/libexec"
+}