summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-02-08 12:23:11 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-02-08 12:23:11 +0000
commit0fdb14ae23e01a5ede5124631c29ce8cd11a844d (patch)
tree2561acc88f6e61e4516b6f43463ce975ce3c578f /net-analyzer/nbaudit/files
parentMarked stable on x86. (diff)
downloadhistorical-0fdb14ae23e01a5ede5124631c29ce8cd11a844d.tar.gz
historical-0fdb14ae23e01a5ede5124631c29ce8cd11a844d.tar.bz2
historical-0fdb14ae23e01a5ede5124631c29ce8cd11a844d.zip
Cleaned up ebuild; Added a patch with some gcc-3.4 fixes as well replacing all occurrences of 'nat' with 'nbaudit' in the manual page.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'net-analyzer/nbaudit/files')
-rw-r--r--net-analyzer/nbaudit/files/nbaudit-1.0-gentoo.diff66
1 files changed, 66 insertions, 0 deletions
diff --git a/net-analyzer/nbaudit/files/nbaudit-1.0-gentoo.diff b/net-analyzer/nbaudit/files/nbaudit-1.0-gentoo.diff
new file mode 100644
index 000000000000..00e9f7586e79
--- /dev/null
+++ b/net-analyzer/nbaudit/files/nbaudit-1.0-gentoo.diff
@@ -0,0 +1,66 @@
+diff -urN nat10.orig/Makefile nat10/Makefile
+--- nat10.orig/Makefile 2005-02-07 21:47:47.324382272 -0500
++++ nat10/Makefile 2005-02-07 22:41:44.381274824 -0500
+@@ -70,8 +70,8 @@
+ # contributed by Andrew.Tridgell@anu.edu.au
+ # add -DLINUX_BIGCRYPT is you have shadow passwords but don't have the
+ # right libraries and includes
+-# FLAGSM = -DLINUX -DSHADOW_PWD
+-# LIBSM = -lshadow
++FLAGSM = -DLINUX -DSHADOW_PWD -DNO_ASMSIGNALH -trigraphs
++LIBSM = -lshadow -L/usr/X11R6/lib/modules
+
+ # Use this for Linux without shadow passwords
+ # contributed by Andrew.Tridgell@anu.edu.au
+diff -urN nat10.orig/nat.1 nat10/nat.1
+--- nat10.orig/nat.1 2005-02-07 21:47:47.325382120 -0500
++++ nat10/nat.1 2005-02-07 22:43:52.645775656 -0500
+@@ -1,12 +1,12 @@
+-.TH NAT 1
++.TH nbaudit 1
+ .SH NAME
+-nat - NetBIOS Auditing Tool
++nbaudit - NetBIOS Auditing Tool
+ .SH SYNOPSIS
+-nat [-o <\fBoutput\fP>] [-u <\fBuserlist\fP>] [-p <\fBpasslist\fP>] \fB<address>\fP
++nbaudit [-o <\fBoutput\fP>] [-u <\fBuserlist\fP>] [-p <\fBpasslist\fP>] \fB<address>\fP
+ .SH DESCRIPTION
+ .PP
+-\fBnat\fP is a tool written to perform various security checks on systems
+-offering the NetBIOS file sharing service. \fBnat\fP will attempt to retrieve
++\fBnbaudit\fP is a tool written to perform various security checks on systems
++offering the NetBIOS file sharing service. \fBnbaudit\fP will attempt to retrieve
+ all information availible from the remote server, and attempt to access any
+ services provided by the server.
+ .SH OPTIONS
+@@ -54,10 +54,10 @@
+ and usernames, as the time required increases exponentially with the size of
+ these lists.
+ .SH SUPPORTED PLATFORMS
+-This version of \fBnat\fP has been tested against Windows NT 4.0 and various
++This version of \fBnbaudit\fP has been tested against Windows NT 4.0 and various
+ versions of the Samba server written by Andrew Tridgell.
+ .PP
+-This version of \fBnat\fP has been tested and compiled on the following
++This version of \fBnbaudit\fP has been tested and compiled on the following
+ operating systems:
+ \fBSolaris\fP 2.5,
+ \fBLinux\fP 2.0,
+@@ -68,4 +68,4 @@
+ \fBWindows 95\fP
+
+ .SH FILES
+-\fBnat\fP, \fBuserlist.txt\fP, \fBpasslist.txt\fP
++\fBnbaudit\fP, \fBuserlist.txt\fP, \fBpasslist.txt\fP
+diff -urN nat10.orig/nmb.c nat10/nmb.c
+--- nat10.orig/nmb.c 2005-02-07 21:47:47.325382120 -0500
++++ nat10/nmb.c 2005-02-07 22:42:05.182112616 -0500
+@@ -40,7 +40,7 @@
+ #endif /* SCANNER */
+
+ int Debug1(char *, ...);
+-int Debug1();
++/*int Debug1();*/
+
+ int num_good_sends=0;
+ int num_good_receives=0;