summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-05-14 16:59:46 +0000
committerAlin Năstac <mrness@gentoo.org>2006-05-14 16:59:46 +0000
commit2f7fe7d022bdb1b8cd2adf428d35c3f64d62e790 (patch)
tree801faa1503a7279ffd27537be58aa492a8c40c7e /net-dialup/speedtouch
parentppc stable, bug #133204 (diff)
downloadhistorical-2f7fe7d022bdb1b8cd2adf428d35c3f64d62e790.tar.gz
historical-2f7fe7d022bdb1b8cd2adf428d35c3f64d62e790.tar.bz2
historical-2f7fe7d022bdb1b8cd2adf428d35c3f64d62e790.zip
quote vars that could contain whitespaces
Package-Manager: portage-2203-svn
Diffstat (limited to 'net-dialup/speedtouch')
-rw-r--r--net-dialup/speedtouch/Manifest8
-rw-r--r--net-dialup/speedtouch/speedtouch-1.3.1-r3.ebuild34
2 files changed, 21 insertions, 21 deletions
diff --git a/net-dialup/speedtouch/Manifest b/net-dialup/speedtouch/Manifest
index 8b07fc3413cf..602ade9c60c1 100644
--- a/net-dialup/speedtouch/Manifest
+++ b/net-dialup/speedtouch/Manifest
@@ -12,11 +12,11 @@ MD5 dbd6e2122fdf47b478bfba023762c105 files/speedtouch.initd 1809
MD5 aa0803fb7b3133521df4ee07d7ff141a files/speedtouch.rc7 1655
MD5 ec2f84816306825d125d0c01bd86758d metadata.xml 163
MD5 c4bdf842c691f9985ecb1c882b90b8d7 speedtouch-1.3.1-r2.ebuild 3269
-MD5 9a64a15259786735ca73902becf74471 speedtouch-1.3.1-r3.ebuild 3231
+MD5 000da66f46a998ced3b57812e8c734e2 speedtouch-1.3.1-r3.ebuild 3285
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
-iD8DBQFEHGyZjG8pv1lIUX4RAq5zAJ0TpoDqZDxowNePSK3+XW+9WgZ9YgCfd8uj
-MMPnl1Kd3lVhNSTmfAKS5fo=
-=/j7z
+iD8DBQFEZ2IPjG8pv1lIUX4RAvgiAKDTZSCJGWAQd0ikQHgl+exwl15DjgCaAtxs
+Ze0K2ZlTGbtI/vXg9LLv4yk=
+=VEWc
-----END PGP SIGNATURE-----
diff --git a/net-dialup/speedtouch/speedtouch-1.3.1-r3.ebuild b/net-dialup/speedtouch/speedtouch-1.3.1-r3.ebuild
index 3969119db606..357da67e0835 100644
--- a/net-dialup/speedtouch/speedtouch-1.3.1-r3.ebuild
+++ b/net-dialup/speedtouch/speedtouch-1.3.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/speedtouch/speedtouch-1.3.1-r3.ebuild,v 1.5 2006/03/18 20:24:40 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/speedtouch/speedtouch-1.3.1-r3.ebuild,v 1.6 2006/05/14 16:59:46 mrness Exp $
inherit flag-o-matic eutils
@@ -18,17 +18,17 @@ IUSE="static debug"
RDEPEND=">=net-dialup/ppp-2.4.1
!net-dialup/speedtouch-usb"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
src_unpack() {
unpack ${A}
# Patch to fix gcc-4.* compile error (bug #99759)
- epatch ${FILESDIR}/${P}-gcc4.patch
+ epatch "${FILESDIR}/${P}-gcc4.patch"
#Increase minlevel of reports in atm.c
#At least one of the reports could affect performance due to call frequency
- sed -i -e 's/report(0/report(1/' ${S}/src/atm.c
+ sed -i -e 's/report(0/report(1/' "${S}/src/atm.c"
}
src_compile() {
@@ -45,29 +45,29 @@ src_compile() {
}
src_install() {
- einstall || die
+ einstall || die "make install failed"
# twp 2003-12-25 install *.html correctly
- find ${D}/usr/share/doc/speedtouch/ -type f -name '*.html' | xargs dohtml
- find ${D}/usr/share/doc/speedtouch/ -type f -name '*.html' | xargs rm
- echo $(find ${D}/usr/share/doc/speedtouch/ -type f) | xargs dodoc
- rm -rf ${D}/usr/share/doc/speedtouch/
+ find "${D}/usr/share/doc/speedtouch/" -type f -name '*.html' | xargs dohtml
+ find "${D}/usr/share/doc/speedtouch/" -type f -name '*.html' | xargs rm
+ echo $(find "${D}/usr/share/doc/speedtouch/" -type f) | xargs dodoc
+ rm -rf "${D}/usr/share/doc/speedtouch/"
dodoc AUTHORS ChangeLog TODO VERSION
- rm -rf ${D}/usr/bin
- rm -rf ${D}/usr/share/man/man1
+ rm -rf "${D}/usr/bin"
+ rm -rf "${D}/usr/share/man/man1"
- newinitd ${FILESDIR}/speedtouch.initd speedtouch
- newconfd ${FILESDIR}/speedtouch.confd speedtouch
+ newinitd "${FILESDIR}/speedtouch.initd" speedtouch
+ newconfd "${FILESDIR}/speedtouch.confd" speedtouch
- insopts -m 600 ; insinto /etc/ppp/peers ; doins ${FILESDIR}/adsl.sample
+ insopts -m 600 ; insinto /etc/ppp/peers ; doins "${FILESDIR}/adsl.sample"
dosbin doc-linux/adsl-conf-pppd
#allows hotplug to modprobe the speedtch module automatically
- mv ${D}/etc/hotplug/usb/speedtouch.usermap ${D}/etc/hotplug/usb/speedtch.usermap
- exeinto /etc/hotplug/usb ; newexe ${FILESDIR}/speedtch-hotplug speedtch
- rm ${D}/etc/hotplug/usb/speedtouch
+ mv "${D}"/etc/hotplug/usb/speedtouch.usermap "${D}"/etc/hotplug/usb/speedtch.usermap
+ exeinto /etc/hotplug/usb ; newexe "${FILESDIR}/speedtch-hotplug" speedtch
+ rm "${D}"/etc/hotplug/usb/speedtouch
}
pkg_postinst() {