summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-08 16:35:24 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-08 16:35:24 +0000
commitcc1ec80aa917738ea01e06cb5d33e8fa0c7bd705 (patch)
tree09ebf528c07e076983b101a11c5b00db45c24fd0 /net-dialup
parent*** empty log message *** (diff)
downloadhistorical-cc1ec80aa917738ea01e06cb5d33e8fa0c7bd705.tar.gz
historical-cc1ec80aa917738ea01e06cb5d33e8fa0c7bd705.tar.bz2
historical-cc1ec80aa917738ea01e06cb5d33e8fa0c7bd705.zip
*** empty log message ***
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/isdn4k-utils/files/digest1
-rw-r--r--net-dialup/isdn4k-utils/isdn4k-utils.v3.1p1-r1.ebuild35
-rw-r--r--net-dialup/ppp/files/digest2
-rw-r--r--net-dialup/ppp/ppp-2.4.0-r1.ebuild59
-rw-r--r--net-dialup/pppoed/files/digest1
-rw-r--r--net-dialup/pppoed/pppoed-0.47-r1.ebuild37
-rw-r--r--net-dialup/wvdial/files/digest1
-rw-r--r--net-dialup/wvdial/wvdial-1.41-r1.ebuild37
8 files changed, 173 insertions, 0 deletions
diff --git a/net-dialup/isdn4k-utils/files/digest b/net-dialup/isdn4k-utils/files/digest
new file mode 100644
index 000000000000..0bc66779df5f
--- /dev/null
+++ b/net-dialup/isdn4k-utils/files/digest
@@ -0,0 +1 @@
+MD5 0cf8322d50f6775e64bbd465aec4a8b2 isdn4k-utils.v3.1pre1.tar.gz
diff --git a/net-dialup/isdn4k-utils/isdn4k-utils.v3.1p1-r1.ebuild b/net-dialup/isdn4k-utils/isdn4k-utils.v3.1p1-r1.ebuild
new file mode 100644
index 000000000000..465de85ffbab
--- /dev/null
+++ b/net-dialup/isdn4k-utils/isdn4k-utils.v3.1p1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/isdn4k-utils/isdn4k-utils.v3.1p1-r1.ebuild,v 1.1 2000/08/08 16:35:24 achim Exp $
+
+P=isdn4k-utils.v3.1p1
+A=isdn4k-utils.v3.1pre1.tar.gz
+S=${WORKDIR}/isdn4k-utils
+CATEGORY="net-dialup"
+DESCRIPTION="ISDN-4-Linux Utils"
+SRC_URI="ftp://ftp.isdn4linux.de/pub/isdn4linux/utils/"${A}
+HOMEPAGE="http://www.isdn4linux.de/"
+
+src_compile() {
+ cd ${S}
+ sed -e "s:CONFIG_KERNELDIR=.*:CONFIG_KERNELDIR='${WORKDIR}/../../../sys-kernel/linux-UP-2\.2\.17p13/work/linux':" ${O}/files/${P}.config > .config
+ make subconfig
+ make
+}
+
+src_install() {
+ cd ${S}
+ dodir /dev
+ dodir /usr/sbin
+ dodir /usr/bin
+ make install DESTDIR=${D}
+ dodir /usr/doc/${P}
+ mv ${D}/usr/doc/vbox ${D}/usr/doc/${P}
+ dodoc COPYING NEWS README Mini-FAQ/isdn-faq.txt
+
+}
+
+
+
+
diff --git a/net-dialup/ppp/files/digest b/net-dialup/ppp/files/digest
new file mode 100644
index 000000000000..ec52b3709f6d
--- /dev/null
+++ b/net-dialup/ppp/files/digest
@@ -0,0 +1,2 @@
+MD5 19a66712b5ed6b752d467da919c29e50 ppp-2.4.0.tar.gz
+MD5 9542214a4fa3bc2e446c1bb41f01e45c pppoed0.47.tgz
diff --git a/net-dialup/ppp/ppp-2.4.0-r1.ebuild b/net-dialup/ppp/ppp-2.4.0-r1.ebuild
new file mode 100644
index 000000000000..077bdf26c52f
--- /dev/null
+++ b/net-dialup/ppp/ppp-2.4.0-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ppp-2.4.0-r1.ebuild,v 1.1 2000/08/08 16:35:24 achim Exp $
+
+P="ppp-2.4.0"
+A="${P}.tar.gz"
+S=${WORKDIR}/${P}
+CATEGORY="net-dialup"
+DESCRIPTION="Point-to-point protocol - used for communicating with your ISP"
+SRC_URI="ftp://ftp.linuxcare.com.au/pub/ppp/${A}"
+src_unpack() {
+
+ unpack ppp-2.4.0.tar.gz
+ cd ${S}
+
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --prefix=/usr
+ #fix Makefiles to compile optimized
+ cd ${S}
+ cd pppd
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS = -O2 -pipe -Wall -g:COPTS = ${CFLAGS}:" -e "s/LIBS =/LIBS = -lcrypt/" Makefile.orig > Makefile
+ cd ../pppstats
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS = -O:COPTS = ${CFLAGS}:" Makefile.orig > Makefile
+ cd ../chat
+ mv Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+ cd ../pppdump
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS= -O:CFLAGS= ${CFLAGS}:" Makefile.orig > Makefile
+ cd ..
+ export CC=gcc
+ make
+}
+
+src_install() {
+ into /usr
+ for y in chat pppd pppdump pppstats
+ do
+ doman ${y}/${y}.8
+ dosbin ${y}/${y}
+ done
+ chmod u+s-w ${D}/usr/sbin/pppd
+ chown root:daemon ${D}/usr/sbin/pppstats
+ dodir /etc/ppp
+ insinto /etc/ppp
+ insopts -m0600
+ doins etc.ppp/pap-secrets etc.ppp/chap-secrets
+ insopts -m0644
+ doins etc.ppp/options
+ dodoc PLUGINS README* SETUP Changes-2.3 FAQ
+}
+
+
diff --git a/net-dialup/pppoed/files/digest b/net-dialup/pppoed/files/digest
new file mode 100644
index 000000000000..fc7303a48702
--- /dev/null
+++ b/net-dialup/pppoed/files/digest
@@ -0,0 +1 @@
+MD5 9542214a4fa3bc2e446c1bb41f01e45c pppoed0.47.tgz
diff --git a/net-dialup/pppoed/pppoed-0.47-r1.ebuild b/net-dialup/pppoed/pppoed-0.47-r1.ebuild
new file mode 100644
index 000000000000..cb276cda1464
--- /dev/null
+++ b/net-dialup/pppoed/pppoed-0.47-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/pppoed/pppoed-0.47-r1.ebuild,v 1.1 2000/08/08 16:35:24 achim Exp $
+
+P=pppoed-0.47
+A=pppoed0.47.tgz
+S=${WORKDIR}/${P}/pppoed
+CATEGORY="net-dialup"
+DESCRIPTION="PPP over Ethernet"
+SRC_URI=" http://www.davin.ottawa.on.ca/pppoe/pppoed0.47.tgz"
+HOMEPAGE="http://www.davin.ottawa.on.ca/pppoe/"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc/ppp/pppoed
+ make
+}
+
+src_install() {
+ cd ${S}
+ make DESTDIR=${D} install
+ prepman
+ dodoc AUTHORS ChangeLog COPYING NEWS README*
+ cd ..
+ docinto docs
+ dodoc docs/*
+ docinto contrib
+ dodoc contribs/*
+}
+
+
+
diff --git a/net-dialup/wvdial/files/digest b/net-dialup/wvdial/files/digest
new file mode 100644
index 000000000000..37e0192a0917
--- /dev/null
+++ b/net-dialup/wvdial/files/digest
@@ -0,0 +1 @@
+MD5 753312352281f0d8c8579f2ffbffeae2 wvdial-1.41.tar.gz
diff --git a/net-dialup/wvdial/wvdial-1.41-r1.ebuild b/net-dialup/wvdial/wvdial-1.41-r1.ebuild
new file mode 100644
index 000000000000..129223722332
--- /dev/null
+++ b/net-dialup/wvdial/wvdial-1.41-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/wvdial-1.41-r1.ebuild,v 1.1 2000/08/08 16:35:24 achim Exp $
+
+P=wvdial-1.41
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Excellent program which automatically configures your PPP session"
+CATEGORY=net-dialup
+SRC_URI="http://www.worldvisions.ca/wvdial/wvdial-1.41.tar.gz"
+HOMEPAGE="http://www.worldvisions.ca/wvdial/"
+
+src_compile() {
+ make
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp rules.mk rules.mk.orig
+ sed -e "s/-g//g" -e "s/-O6/${CFLAGS}/" rules.mk.orig > rules.mk
+ cp Makefile Makefile.orig
+ sed -e "s:PREFIX=/usr/local:PREFIX=/usr:" Makefile.orig > Makefile
+}
+
+src_install() {
+ into /usr
+ dobin wvdial/wvdial wvdial/wvdialconf
+ doman *.1
+ insinto /etc/ppp/peers
+ doins ppp.provider
+ dodoc ANNOUNCE CHANGES COPYING.LIB README
+ dodoc debian/changelog debian/copyright
+}
+
+