summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-28 14:32:32 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-28 14:32:32 +0000
commit288e93c75bc91741cc20b36388c556050d5f3c6a (patch)
tree92447c91889f884635248fd9b31b9262ebbd5dcb /net-fs
parentDependencie fixes (diff)
downloadhistorical-288e93c75bc91741cc20b36388c556050d5f3c6a.tar.gz
historical-288e93c75bc91741cc20b36388c556050d5f3c6a.tar.bz2
historical-288e93c75bc91741cc20b36388c556050d5f3c6a.zip
dependencie fixes for rc5
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba-winbind/samba-winbind-20010329.ebuild16
-rw-r--r--net-fs/samba/samba-2.0.9.ebuild3
-rw-r--r--net-fs/samba/samba-2.2.0-r1.ebuild4
3 files changed, 15 insertions, 8 deletions
diff --git a/net-fs/samba-winbind/samba-winbind-20010329.ebuild b/net-fs/samba-winbind/samba-winbind-20010329.ebuild
index 96ddb385b6f2..d114bb151f7b 100644
--- a/net-fs/samba-winbind/samba-winbind-20010329.ebuild
+++ b/net-fs/samba-winbind/samba-winbind-20010329.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba-winbind/samba-winbind-20010329.ebuild,v 1.2 2001/04/21 03:09:30 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba-winbind/samba-winbind-20010329.ebuild,v 1.3 2001/05/28 14:32:32 achim Exp $
A=samba-tng-cvs-${PV}.tbz2
S=${WORKDIR}/tng
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/distributions/gentoo/gentoo-sources/${A
HOMEPAGE="http://www.samba-tng.org"
DEPEND="virtual/glibc
- >=sys-libs/pam-0.72"
+ pam? ( >=sys-libs/pam-0.72 )"
src_unpack() {
unpack ${A}
@@ -20,14 +20,22 @@ src_unpack() {
src_compile() {
+ local myconf
+ if [ "`use pam`" ]
+ then
+ myconf="--with-pam"
+ else
+ myconf="--without-pam"
+ fi
+
cd ${S}/source
# We want static versions of winbind and pam_winbind
try ./configure --prefix=/usr --host=${CHOST} --enable-static=yes --enable-shared=no \
--sysconfdir=/etc/smb --localstatedir=/var/log --libdir=/etc/smb --sbindir=/usr/sbin \
--without-automount \
- --with-privatedir=/etc/smb/private --with-lockdir=/var/lock
+ --with-privatedir=/etc/smb/private --with-lockdir=/var/lock $myconf
try make
- try make nsswitch nsswitch/pam_winbind.so
+ try make nsswitch nsswitch/pam_winbind.so
}
diff --git a/net-fs/samba/samba-2.0.9.ebuild b/net-fs/samba/samba-2.0.9.ebuild
index 12d44cafb20d..89c0b2bb61a0 100644
--- a/net-fs/samba/samba-2.0.9.ebuild
+++ b/net-fs/samba/samba-2.0.9.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-2.0.9.ebuild,v 1.1 2001/05/10 01:49:14 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-2.0.9.ebuild,v 1.2 2001/05/28 14:32:32 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,7 +10,6 @@ SRC_URI="http://us1.samba.org/samba/ftp/${A}"
HOMEPAGE="http://www.samba.org"
DEPEND="virtual/glibc
- >=sys-apps/gawk-3.0.6
>=sys-libs/pam-0.72"
#ssl support removed -- it doesn't work...
diff --git a/net-fs/samba/samba-2.2.0-r1.ebuild b/net-fs/samba/samba-2.2.0-r1.ebuild
index 8ac558dcad5c..620af221acb9 100644
--- a/net-fs/samba/samba-2.2.0-r1.ebuild
+++ b/net-fs/samba/samba-2.2.0-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-2.2.0-r1.ebuild,v 1.1 2001/05/24 22:12:34 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-2.2.0-r1.ebuild,v 1.2 2001/05/28 14:32:32 achim Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Samba :)"
@@ -28,7 +28,7 @@ src_compile() {
# Disabled automout support, because it failed
# Added -lncurses for readline detection
- try LDFLAGS="-lncurses" ./configure --prefix=/usr \
+ try ./configure --prefix=/usr \
--sysconfdir=/etc/smb --localstatedir=/var/log --libdir=/etc/smb --sbindir=/usr/sbin \
--without-automount --with-utmp --without-sambabook --with-netatalk --with-smbmount \
--with-privatedir=/etc/smb/private --with-msdfs --with-vfs --with-spinlocks --with-lockdir=/var/run/smb --with-swatdir=/usr/share/swat \