summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-05-18 01:59:16 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-05-18 01:59:16 +0000
commitd8dec1b769d8718cf749e43488a4d0d80467ed32 (patch)
tree0954fbefd1f049279db9996a27e00a78339b4239 /net-ftp
parentremoved --disable-backspace-key, so that backspace actually works now. (diff)
downloadhistorical-d8dec1b769d8718cf749e43488a4d0d80467ed32.tar.gz
historical-d8dec1b769d8718cf749e43488a4d0d80467ed32.tar.bz2
historical-d8dec1b769d8718cf749e43488a4d0d80467ed32.zip
new version. The older version sigsegv'd on me when using gotmail.
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/curl/ChangeLog8
-rw-r--r--net-ftp/curl/curl-7.9.7.ebuild33
-rw-r--r--net-ftp/curl/files/digest-curl-7.9.71
3 files changed, 41 insertions, 1 deletions
diff --git a/net-ftp/curl/ChangeLog b/net-ftp/curl/ChangeLog
index cdd8cdfef744..945221c2f9ea 100644
--- a/net-ftp/curl/ChangeLog
+++ b/net-ftp/curl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-ftp/curl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/curl/ChangeLog,v 1.1 2002/02/01 21:53:32 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/curl/ChangeLog,v 1.2 2002/05/18 01:59:16 g2boojum Exp $
+
+*curl-7.9.7 (17 May 2002)
+
+ 17 May 2002; Grant Goodyear <g2boojum@gentoo.org> :
+
+ Version bump. Seems to work better when compiled w/ gcc 3.0.4.
*curl-7.9.3 (1 Feb 2002)
diff --git a/net-ftp/curl/curl-7.9.7.ebuild b/net-ftp/curl/curl-7.9.7.ebuild
new file mode 100644
index 000000000000..35f15e5b822d
--- /dev/null
+++ b/net-ftp/curl/curl-7.9.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/curl/curl-7.9.7.ebuild,v 1.1 2002/05/18 01:59:16 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A Client that groks URLs"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.gz"
+HOMEPAGE="http://curl.haxx.se"
+
+DEPEND=">=sys-libs/glibc-2.1.3 >=sys-libs/pam-0.75 ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+src_compile() {
+ local myconf
+ if [ "`use ssl`" ]
+ then
+ myconf="--with-ssl"
+ else
+ myconf="--without-ssl"
+ fi
+ cd ${S}
+ ./configure --prefix=/usr --mandir=/usr/share/man $myconf || die
+ emake || die
+
+}
+
+src_install () {
+ cd ${S}
+ make install DESTDIR=${D} || die
+ dodoc LEGAL CHANGES README
+ dodoc docs/FEATURES docs/INSTALL docs/INTERNALS docs/LIBCURL
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+}
diff --git a/net-ftp/curl/files/digest-curl-7.9.7 b/net-ftp/curl/files/digest-curl-7.9.7
new file mode 100644
index 000000000000..1ddb8afd72e9
--- /dev/null
+++ b/net-ftp/curl/files/digest-curl-7.9.7
@@ -0,0 +1 @@
+MD5 5be31a5884560726cbd23808378937ee curl-7.9.7.tar.gz 717489