summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2004-01-24 01:47:39 +0000
committerGustavo Felisberto <humpback@gentoo.org>2004-01-24 01:47:39 +0000
commit1898bd643a34420d3ff5535ae990bfc70d3041e3 (patch)
tree6993e4a844045d7f3ca33645b6f630239ca390f2 /net-im/aim-transport
parentFixed use.defaults so values in use.mask don't exist here as well. (diff)
downloadhistorical-1898bd643a34420d3ff5535ae990bfc70d3041e3.tar.gz
historical-1898bd643a34420d3ff5535ae990bfc70d3041e3.tar.bz2
historical-1898bd643a34420d3ff5535ae990bfc70d3041e3.zip
Initial import
Diffstat (limited to 'net-im/aim-transport')
-rw-r--r--net-im/aim-transport/ChangeLog11
-rw-r--r--net-im/aim-transport/Manifest5
-rw-r--r--net-im/aim-transport/aim-transport-20030314.ebuild47
-rw-r--r--net-im/aim-transport/files/README.Gentoo43
-rw-r--r--net-im/aim-transport/files/aimtrans.xml25
-rw-r--r--net-im/aim-transport/metadata.xml10
6 files changed, 141 insertions, 0 deletions
diff --git a/net-im/aim-transport/ChangeLog b/net-im/aim-transport/ChangeLog
new file mode 100644
index 000000000000..8b057c060426
--- /dev/null
+++ b/net-im/aim-transport/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-im/aim-transport
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/aim-transport/ChangeLog,v 1.1 2004/01/24 01:47:14 humpback Exp $
+
+*aim-transport-20030314 (24 Jan 2004)
+
+ 24 Jan 2004; Gustavo Felisberto <humpback@gentoo.org>;
+ aim-transport-20030314.ebuild, metadata.xml, files/README.Gentoo,
+ files/aimtrans.xml:
+ Initial import. Helps close bug 37316
+
diff --git a/net-im/aim-transport/Manifest b/net-im/aim-transport/Manifest
new file mode 100644
index 000000000000..d5beceab60bf
--- /dev/null
+++ b/net-im/aim-transport/Manifest
@@ -0,0 +1,5 @@
+MD5 6816c17429d2b0f735ff6f1e5872b2a1 metadata.xml 333
+MD5 2a2102682cb728a240701b9b35cc9e86 ChangeLog 451
+MD5 c1dcfc8eec6081c232ab94e6b26f2db5 aim-transport-20030314.ebuild 1024
+MD5 0efa23fb795fdfb0821780e240e70dcd files/aimtrans.xml 562
+MD5 fc71050bb7266ee2b89046dd30db8815 files/README.Gentoo 1460
diff --git a/net-im/aim-transport/aim-transport-20030314.ebuild b/net-im/aim-transport/aim-transport-20030314.ebuild
new file mode 100644
index 000000000000..84fc76d61e8a
--- /dev/null
+++ b/net-im/aim-transport/aim-transport-20030314.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/aim-transport/aim-transport-20030314.ebuild,v 1.1 2004/01/24 01:47:14 humpback Exp $
+
+MY_PN="${PN}-stable"
+S="${WORKDIR}/${MY_PN}-${PV}"
+DESCRIPTION="AOL Instant Messaging transport for jabberd"
+
+HOMEPAGE="http://aim-transport.jabberstudio.org/"
+
+SRC_URI="http://aim-transport.jabberstudio.org/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=">=net-im/jabberd-1.4.3"
+
+
+
+src_compile() {
+ einfo
+ einfo "Please ignore any errors"
+ einfo
+ ./configure --with-jabberd=/usr/include/jabberd || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ dodir /etc/jabber /usr/lib/jabberd
+ insinto /usr/lib/jabberd
+ doins src/aimtrans.so
+ insinto /etc/jabber
+ doins ${FILESDIR}/aimtrans.xml
+ dodoc README ${FILESDIR}/README.Gentoo TODO aim.xml
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read /usr/share/doc/${P}/README.Gentoo.gz"
+ einfo
+}
+
diff --git a/net-im/aim-transport/files/README.Gentoo b/net-im/aim-transport/files/README.Gentoo
new file mode 100644
index 000000000000..61e97c3db631
--- /dev/null
+++ b/net-im/aim-transport/files/README.Gentoo
@@ -0,0 +1,43 @@
+This is a small help to get you started with the AIM Jabberd transport in
+Gentoo.
+
+Edit /etc/jabber/aimtrans.xml . This is the main jabber server config file.
+There change all references to localhost with the FQDN (Fully Qualified Domain
+Name) for your server.
+
+In the maimlinker section enter the IP of your main jabber server (normally
+127.0.0.1) and choose a port and secret (secret is the password the AIM
+transport will use to connect to the main jabber server).
+
+Now back to the multiple.xml to tell your main jabber server to listen to
+connections from the AIM transport.
+Search for "<vcard2jud/>" and after that, and before the </jsm> add:
+
+<browse>
+ <service type="aim" jid="aim.localhost" name="AIM Transport">
+ <ns>jabber:iq:gateway</ns>
+ <ns>jabber:iq:register</ns>
+ </service>
+</browse>
+
+Again here change localhost for your FQDN.
+
+Scrool down to the bottom of the file, and just before the </jabber> add:
+
+<service id="aim">
+ <host>aim.localhost</host>
+ <accept>
+ <ip>127.0.0.1</ip>
+ <port>5223</port>
+ <secret>myaimsecret</secret>
+ <timeout>30</timeout>
+ </accept>
+</service>
+
+(By know you know you have to change localhost for you FQDN).
+One very importante thing: even if it is the same machine the name's for the
+various services must be diferent, that means that there must be valid aliases
+for aim.FQDN .
+
+If you need help with configuration you can try the Jabber Admin Mailling list:
+http://mailman.jabber.org/listinfo/jadmin
diff --git a/net-im/aim-transport/files/aimtrans.xml b/net-im/aim-transport/files/aimtrans.xml
new file mode 100644
index 000000000000..76e13f549cff
--- /dev/null
+++ b/net-im/aim-transport/files/aimtrans.xml
@@ -0,0 +1,25 @@
+<jabber>
+
+ <service id="aimlinker">
+ <uplink/>
+ <connect>
+ <ip>127.0.0.1</ip>
+ <port>5233</port>
+ <secret>myaimsecret</secret>
+ </connect>
+ </service>
+
+ <service id='aim.localhost'>
+ <load><aim_transport>/usr/lib/jabberd/aimtrans.so</aim_transport></load>
+
+ <aimtrans xmlns='jabber:config:aimtrans'>
+ <aimbinarydir>/usr/lib/jabberd</aimbinarydir>
+ <vCard>
+ <FN>AIM Transport</FN>
+ <DESC>AIM Transport!</DESC>
+ <URL>http://aim.localhost/</URL>
+ </vCard>
+
+ </aimtrans>
+ </service>
+</jabber>
diff --git a/net-im/aim-transport/metadata.xml b/net-im/aim-transport/metadata.xml
new file mode 100644
index 000000000000..df7fa0cfa768
--- /dev/null
+++ b/net-im/aim-transport/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-im</herd>
+<maintainer>
+ <email>humpback@gentoo.org</email>
+ <name>Gustavo Felisberto</name>
+</maintainer>
+ <longdescription>Jabber transport for the AOL IM system</longdescription>
+</pkgmetadata>