summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2004-07-25 14:03:43 +0000
committerGustavo Felisberto <humpback@gentoo.org>2004-07-25 14:03:43 +0000
commitc918230207592dec5e15b7513f08fab071e35748 (patch)
treed52c822fae60891a75c9632828a26f9ea2816fb8 /net-im/naim/naim-0.11.7.2.ebuild
parenttypo fixed (diff)
downloadhistorical-c918230207592dec5e15b7513f08fab071e35748.tar.gz
historical-c918230207592dec5e15b7513f08fab071e35748.tar.bz2
historical-c918230207592dec5e15b7513f08fab071e35748.zip
Version bump
Diffstat (limited to 'net-im/naim/naim-0.11.7.2.ebuild')
-rw-r--r--net-im/naim/naim-0.11.7.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-im/naim/naim-0.11.7.2.ebuild b/net-im/naim/naim-0.11.7.2.ebuild
new file mode 100644
index 000000000000..5af4475f72ac
--- /dev/null
+++ b/net-im/naim/naim-0.11.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/naim/naim-0.11.7.2.ebuild,v 1.1 2004/07/25 14:03:43 humpback Exp $
+
+
+DESCRIPTION="An ncurses based AOL Instant Messenger"
+HOMEPAGE="http://naim.n.ml.org"
+SRC_URI="http://shell.n.ml.org/n/naim/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~macos"
+IUSE="debug"
+
+DEPEND=">=sys-libs/ncurses-5.2"
+
+src_compile() {
+ # --enable-profile
+ local myconf=""
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ econf \
+ --with-pkgdocdir=/usr/share/doc/${PF} \
+ --enable-detach \
+ ${myconf} \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS FAQ BUGS README NEWS ChangeLog doc/*.hlp
+}