summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2003-11-22 02:00:16 +0000
committerChuck Short <zul@gentoo.org>2003-11-22 02:00:16 +0000
commit0679d5bae59d3fc3867d0d07d977d0d697f7d0a3 (patch)
tree0e4e789d0a3b367d9c9a09dd53a96cb334e9639c /net-irc
parentInitial release, closes #31619. (diff)
downloadhistorical-0679d5bae59d3fc3867d0d07d977d0d697f7d0a3.tar.gz
historical-0679d5bae59d3fc3867d0d07d977d0d697f7d0a3.tar.bz2
historical-0679d5bae59d3fc3867d0d07d977d0d697f7d0a3.zip
Initial release, closes #31619.
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/ezbounce/Manifest5
-rw-r--r--net-irc/ezbounce/ezbounce-1.04a.ebuild36
-rw-r--r--net-irc/ezbounce/files/digest-ezbounce-1.04a1
-rw-r--r--net-irc/ezbounce/files/ezbounce-1.04a-crash-fix.patch22
-rw-r--r--net-irc/ezbounce/metadata.xml5
5 files changed, 68 insertions, 1 deletions
diff --git a/net-irc/ezbounce/Manifest b/net-irc/ezbounce/Manifest
index 4becfcbd50bd..0d38d5009de0 100644
--- a/net-irc/ezbounce/Manifest
+++ b/net-irc/ezbounce/Manifest
@@ -1,2 +1,5 @@
-MD5 38f5f27665515b524b8de649ddfba903 ezbounce-1.04a.ebuild 665
+MD5 ee527571a3a2ecbc0478ba8c8f2bdbe5 ezbounce-1.04a.ebuild 755
+MD5 19ea431fd1bbf23e17de696856ed4093 ChangeLog 451
+MD5 44c39c6ad372a8e5a5e7ee3311f703a7 metadata.xml 160
MD5 77781fdeabcd004ae4478c14971a9644 files/digest-ezbounce-1.04a 66
+MD5 2c41dd7703df2b1d7c993f8665105122 files/ezbounce-1.04a-crash-fix.patch 945
diff --git a/net-irc/ezbounce/ezbounce-1.04a.ebuild b/net-irc/ezbounce/ezbounce-1.04a.ebuild
new file mode 100644
index 000000000000..2228dfa244d7
--- /dev/null
+++ b/net-irc/ezbounce/ezbounce-1.04a.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ezbounce/ezbounce-1.04a.ebuild,v 1.1 2003/11/22 02:00:01 zul Exp $
+
+DESCRIPTION="ezbounce is a small IRC bouncer"
+HOMEPAGE="http://druglord.freelsd.org/ezbounce/"
+SRC_URI="http://druglord.freelsd.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="ssl"
+DEPEND=">=net-misc/mdidentd-1.04a
+ ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch ${FILESDIR}/${P}-crash-fix.patch
+}
+
+src_compile() {
+ local myconf
+
+ use ssl && myconf="${myconf} --with-ssl"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ dobin ezbounce
+ dodoc README
+ doman misc/ezbounce.1
+}
diff --git a/net-irc/ezbounce/files/digest-ezbounce-1.04a b/net-irc/ezbounce/files/digest-ezbounce-1.04a
new file mode 100644
index 000000000000..f1fdd329d49c
--- /dev/null
+++ b/net-irc/ezbounce/files/digest-ezbounce-1.04a
@@ -0,0 +1 @@
+MD5 f214fbd8ec1d95981639c9e1087436cb ezbounce-1.04a.tar.gz 189147
diff --git a/net-irc/ezbounce/files/ezbounce-1.04a-crash-fix.patch b/net-irc/ezbounce/files/ezbounce-1.04a-crash-fix.patch
new file mode 100644
index 000000000000..34141fa8611b
--- /dev/null
+++ b/net-irc/ezbounce/files/ezbounce-1.04a-crash-fix.patch
@@ -0,0 +1,22 @@
+diff -ur --new-file ezbounce-1.04a-orig/src/commands.cpp ezbounce-1.04a/src/commands.cpp
+--- ezbounce-1.04a-orig/src/commands.cpp 2003-04-26 18:15:41.000000000 -0500
++++ ezbounce-1.04a/src/commands.cpp 2003-07-01 00:59:51.000000000 -0500
+@@ -1193,7 +1193,7 @@
+ c = i.next();
+ if (c->checkf(DETACHED))
+ {
+- char buff[200], timebuff[15];
++ char timebuff[15];
+ if (!hShown)
+ {
+ cprintf("Current detached sessions for user %s:\n", u->name);
+@@ -1201,8 +1201,7 @@
+ hShown = 1;
+ }
+ duration(ircproxy_time() - c->detach_time, 0, timebuff, sizeof(timebuff));
+- sprintf(buff,"%-3d %-20s %-20s %s\n", ++idx, c->uinfo.irc->nick, c->uinfo.server, timebuff);
+- cprintf(buff);
++ cprintf("%-3d %-20s %-20s %s\n", ++idx, c->uinfo.irc->nick, c->uinfo.server, timebuff);
+ }
+ }
+ if (!hShown)
diff --git a/net-irc/ezbounce/metadata.xml b/net-irc/ezbounce/metadata.xml
new file mode 100644
index 000000000000..6ef15e900f17
--- /dev/null
+++ b/net-irc/ezbounce/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+</pkgmetadata>