summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-30 10:05:17 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-30 10:05:17 +0000
commit2588404032ed7d1671a595627409507a3563d277 (patch)
tree1395ef7d343066bad66e65baa73629b631841ea1 /net-libs/canlock/files
parentBump version dependency on libtextcat. (diff)
downloadhistorical-2588404032ed7d1671a595627409507a3563d277.tar.gz
historical-2588404032ed7d1671a595627409507a3563d277.tar.bz2
historical-2588404032ed7d1671a595627409507a3563d277.zip
Initial import (bug #104244).
Package-Manager: portage-2.2.0_alpha60/cvs/Linux x86_64
Diffstat (limited to 'net-libs/canlock/files')
-rw-r--r--net-libs/canlock/files/canlock-2b-make.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/canlock/files/canlock-2b-make.patch b/net-libs/canlock/files/canlock-2b-make.patch
new file mode 100644
index 000000000000..5ea34530cebd
--- /dev/null
+++ b/net-libs/canlock/files/canlock-2b-make.patch
@@ -0,0 +1,45 @@
+--- canlock2b.orig/Makefile
++++ canlock2b/Makefile
+@@ -15,16 +15,17 @@
+ $(CC) $(CFLAGS) t/$@.c -o $@ $(LDFLAGS)
+
+ $(STATIC_LIB):
+- cd src && make
++ cd src && $(MAKE) libcanlock.so.2.0.0
++ cd src && $(MAKE) libcanlock.a
+ ln -s src/libcanlock.a libcanlock.a
+
+ clean:
+ rm -f src/*.o t/*.o t/*.out *.gmon gmon.*
+- cd src && make clean
++ cd src && $(MAKE) clean
+ rm -f *.a canlocktest hmactest sha1test *.exe *.h lib-stamp
+
+ install: all
+- cd src && make install DESTDIR=$(DESTDIR)
++ cd src && $(MAKE) install DESTDIR=$(DESTDIR)
+ install --mode=644 include/canlock.h $(DESTDIR)/usr/include
+
+ test: all
+--- canlock2b.orig/src/Makefile
++++ canlock2b/src/Makefile
+@@ -13,8 +13,8 @@
+
+ libcanlock.a:
+ $(CC) $(CFLAGS) -c $(SOURCES)
+- ar cru libcanlock.a $(OBJS)
+- ranlib libcanlock.a
++ $(AR) cru libcanlock.a $(OBJS)
++ $(RANLIB) libcanlock.a
+ rm $(OBJS)
+
+ libcanlock.so.2.0.0:
+@@ -26,7 +26,7 @@
+ cd $(DESTDIR)/usr/lib && ln -s libcanlock.so.2.0.0 libcanlock.so.2
+ cd $(DESTDIR)/usr/lib && ln -s libcanlock.so.2.0.0 libcanlock.so
+ $(INSTALL) libcanlock.a $(DESTDIR)/usr/lib/libcanlock.a
+- ranlib $(DESTDIR)/usr/lib/libcanlock.a
++ $(RANLIB) $(DESTDIR)/usr/lib/libcanlock.a
+
+ clean:
+ rm -f $(OBJS) $(LIBS)