summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-03-09 16:27:42 +0000
committerCédric Krier <cedk@gentoo.org>2008-03-09 16:27:42 +0000
commitc001718127630850212b5595d72e8c072c6deb7d (patch)
tree2f149d8bddc41831eea03a29ebc5c220a92d3673 /net-libs/libnfnetlink/libnfnetlink-0.0.33.ebuild
parentalpha/ia64 stable wrt #212062 (diff)
downloadhistorical-c001718127630850212b5595d72e8c072c6deb7d.tar.gz
historical-c001718127630850212b5595d72e8c072c6deb7d.tar.bz2
historical-c001718127630850212b5595d72e8c072c6deb7d.zip
Version bump
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'net-libs/libnfnetlink/libnfnetlink-0.0.33.ebuild')
-rw-r--r--net-libs/libnfnetlink/libnfnetlink-0.0.33.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libnfnetlink/libnfnetlink-0.0.33.ebuild b/net-libs/libnfnetlink/libnfnetlink-0.0.33.ebuild
new file mode 100644
index 000000000000..d73b08f40c82
--- /dev/null
+++ b/net-libs/libnfnetlink/libnfnetlink-0.0.33.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/libnfnetlink-0.0.33.ebuild,v 1.1 2008/03/09 16:27:42 cedk Exp $
+
+inherit linux-info
+
+DESCRIPTION="the low-level library for netfilter related kernel/userspace communication"
+HOMEPAGE="http://www.netfilter.org/projects/libnfnetlink/"
+SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 6 14 ; then
+ die "${PN} requires at least 2.6.14 kernel version"
+ fi
+
+ #netfilter core team has changed some option names with kernel 2.6.20
+ if kernel_is lt 2 6 20 ; then
+ CONFIG_CHECK="IP_NF_CONNTRACK_NETLINK"
+ else
+ CONFIG_CHECK="NF_CT_NETLINK"
+ ERROR_NF_CT_NETLINK="CONFIG_NF_CT_NETLINK:\t is not set when it should be. You can activate it in the Core Netfilter Configuration"
+ fi
+
+ check_extra_config
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}