summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-04-24 17:27:52 +0000
committerThilo Bangert <bangert@gentoo.org>2002-04-24 17:27:52 +0000
commit08e389ef0c535e144ea16db373ed26ae1b4b50b8 (patch)
tree3dfe0de2f4c7371ad0ab99541ab234fefa09223a /net-mail/mailfront
parentclose bug #61 (yeah) - add a makewhatis.cron (diff)
downloadhistorical-08e389ef0c535e144ea16db373ed26ae1b4b50b8.tar.gz
historical-08e389ef0c535e144ea16db373ed26ae1b4b50b8.tar.bz2
historical-08e389ef0c535e144ea16db373ed26ae1b4b50b8.zip
new qmail-vmailmgr ebuilds - add virtual hosting capabilities to qmail
Diffstat (limited to 'net-mail/mailfront')
-rw-r--r--net-mail/mailfront/ChangeLog9
-rw-r--r--net-mail/mailfront/files/digest-mailfront-0.741
-rw-r--r--net-mail/mailfront/files/run-pop3front6
-rw-r--r--net-mail/mailfront/files/run-smtpfront14
-rw-r--r--net-mail/mailfront/mailfront-0.74.ebuild42
5 files changed, 72 insertions, 0 deletions
diff --git a/net-mail/mailfront/ChangeLog b/net-mail/mailfront/ChangeLog
new file mode 100644
index 000000000000..2147db16a83e
--- /dev/null
+++ b/net-mail/mailfront/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-mail/mailfront
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.2 2002/02/05 00:57:47 gbevin Exp
+
+*mailfront-0.74 (16 Apr 2002)
+
+ 16 Apr 2002; Thilo Bangert <bangert@gentoo.org> ChangeLog:
+
+ initial release
diff --git a/net-mail/mailfront/files/digest-mailfront-0.74 b/net-mail/mailfront/files/digest-mailfront-0.74
new file mode 100644
index 000000000000..631a70ad38ba
--- /dev/null
+++ b/net-mail/mailfront/files/digest-mailfront-0.74
@@ -0,0 +1 @@
+MD5 018894b210df1a8dfb360da5e6c70ac6 mailfront-0.74.tar.gz 59096
diff --git a/net-mail/mailfront/files/run-pop3front b/net-mail/mailfront/files/run-pop3front
new file mode 100644
index 000000000000..9e594a7e7baa
--- /dev/null
+++ b/net-mail/mailfront/files/run-pop3front
@@ -0,0 +1,6 @@
+#!/bin/sh
+exec /usr/bin/softlimit -m 2000000 \
+ /usr/bin/tcpserver -v -p -x /etc/tcp.smtp.cdb \
+ 0 pop-3 /var/qmail/bin/pop3front-auth cvm-vmailmgr-local \
+ /var/qmail/bin/pop3front-maildir .maildir 2>&1
+
diff --git a/net-mail/mailfront/files/run-smtpfront b/net-mail/mailfront/files/run-smtpfront
new file mode 100644
index 000000000000..33d0e01adf18
--- /dev/null
+++ b/net-mail/mailfront/files/run-smtpfront
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+QMAILDUID=`id -u qmaild`
+NOFILESGID=`id -g qmaild`
+
+#set CVM_SASL_LOGIN and CVM_SSASL_PLAIN to the path of cvm-vmailmgr socket (/etc/vmailmgr/cvm-vmailmgr-socket
+SOCKET=`head -1 /etc/vmailmgr/cvm-vmailmgr-socket`
+
+export CVM_SASL_LOGIN=$SOCKET
+export CVM_SASL_PLAIN=$SOCKET
+
+exec /usr/bin/softlimit -m 2000000 \
+ /usr/bin/tcpserver -H -R -v -p -x /etc/tcp.smtp.cdb \
+ -u $QMAILDUID -g $NOFILESGID 0 smtp rblsmtpd /var/qmail/bin/smtpfront-qmail 2>&1
diff --git a/net-mail/mailfront/mailfront-0.74.ebuild b/net-mail/mailfront/mailfront-0.74.ebuild
new file mode 100644
index 000000000000..1635f8c272a1
--- /dev/null
+++ b/net-mail/mailfront/mailfront-0.74.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# Maintainer: Thilo Bangert <bangert@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.3 2002/02/04 15:46:51 gbevin Exp
+
+S=${WORKDIR}/${P}
+
+DEPEND="virtual/glibc"
+
+RDEPEND="net-mail/cvm-vmailmgr
+ net-mail/qmail
+ net-mail/qmail-pop3d"
+
+DESCRIPTION="Mail server network protocol front-ends."
+SRC_URI="http://untroubled.org/mailfront/${P}.tar.gz"
+HOMEPAGE="http://untroubled.org/mailfront/"
+
+src_compile() {
+ cd ${S}
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+ emake || die
+}
+
+src_install () {
+ exeinto /var/qmail/bin
+ doexe pop3front-auth pop3front-maildir smtpfront-echo smtpfront-qmail smtpfront-reject
+
+ #install new run files for qmail-smtpd and qmail-pop3
+ exeinto /var/qmail/supervise/qmail-smtpd
+ newexe ${FILESDIR}/run-smtpfront run
+
+ exeinto /var/qmail/supervise/qmail-pop3d
+ newexe ${FILESDIR}/run-pop3front run
+
+}
+
+pkg_postinst() {
+ echo -e "\e[32;01m Now you need to restart qmail-smtpd and qmail-pop3d services:\033[0m"
+ echo ' $ svc -t /service/qmail-smtpd && svc -t /service/qmail-pop3d'
+ echo
+} \ No newline at end of file