summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-11 19:38:58 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-11 19:38:58 +0000
commitdd68608db6f9a9abeb023a9d79920344e8572268 (patch)
treee0ac77ccb49f0b9752675cc20a1a75cd08d22877 /net-mail/postfix
parentadded postfix-1.1.11.20020822 mask (diff)
downloadhistorical-dd68608db6f9a9abeb023a9d79920344e8572268.tar.gz
historical-dd68608db6f9a9abeb023a9d79920344e8572268.tar.bz2
historical-dd68608db6f9a9abeb023a9d79920344e8572268.zip
New postfix version. Testing ipv6 support. Eventually adding sasl2
support. Currently masked.
Diffstat (limited to 'net-mail/postfix')
-rw-r--r--net-mail/postfix/ChangeLog8
-rw-r--r--net-mail/postfix/files/digest-postfix-1.1.11.200208223
-rw-r--r--net-mail/postfix/postfix-1.1.11.20020822.ebuild155
3 files changed, 165 insertions, 1 deletions
diff --git a/net-mail/postfix/ChangeLog b/net-mail/postfix/ChangeLog
index dc62a7f93bb3..070f40554360 100644
--- a/net-mail/postfix/ChangeLog
+++ b/net-mail/postfix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/postfix
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/ChangeLog,v 1.31 2002/08/30 14:41:00 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/ChangeLog,v 1.32 2002/09/11 19:38:58 raker Exp $
+
+*postfix-1.1.11.20020822 (11 Sep 2002)
+
+ 11 Sep 2002; Nick Hadaway <raker@gentoo.org>
+ postfix-1.1.11.20020822.ebuild, files/digest-postfix-1.1.11.20020822 :
+ New postfix ebuild. Currently masked. Testing ipv6 patch.
*postfix-1.1.11.200206013-r1 (13 Aug 2002)
diff --git a/net-mail/postfix/files/digest-postfix-1.1.11.20020822 b/net-mail/postfix/files/digest-postfix-1.1.11.20020822
new file mode 100644
index 000000000000..2da93bc362b7
--- /dev/null
+++ b/net-mail/postfix/files/digest-postfix-1.1.11.20020822
@@ -0,0 +1,3 @@
+MD5 1a82f18a9ce23dc7c6d29d7023281067 postfix-1.1.11-20020822.tar.gz 1275033
+MD5 45661443f25719094ebb537d4865c07e pfixtls-0.8.11a-1.1.11-20020822-0.9.6g.tar.gz 196144
+MD5 300aa8eafa79e4df71dc53073e784fba tls+ipv6-1.4-pf-1.1.11-20020822.patch 348340
diff --git a/net-mail/postfix/postfix-1.1.11.20020822.ebuild b/net-mail/postfix/postfix-1.1.11.20020822.ebuild
new file mode 100644
index 000000000000..ae0d5913127d
--- /dev/null
+++ b/net-mail/postfix/postfix-1.1.11.20020822.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-1.1.11.20020822.ebuild,v 1.1 2002/09/11 19:38:58 raker Exp $
+
+PF_PV=1.1.11-20020822
+PF_P=postfix-${PF_PV}
+S=${WORKDIR}/${PF_P}
+TLS_P=pfixtls-0.8.11a-${PF_PV}-0.9.6g
+IPV6_P=tls+ipv6-1.4-pf-${PF_PV}
+
+DESCRIPTION="A fast and secure drop-in replacement for sendmail"
+HOMEPAGE="http://www.postfix.org/"
+SRC_URI="http://archive.progeny.com/postfix/experimental/${PF_P}.tar.gz
+ ssl? ( ftp://ftp.aet.tu-cottbus.de/pub/postfix_tls/${TLS_P}.tar.gz )
+ ipv6? ( ftp://ftp.stack.nl/pub/postfix/tls+ipv6/1.4/${IPV6_P}.patch )"
+
+LICENSE="IPL-1"
+SLOT="0"
+KEYWORDS="x86 sparc sparc64 ppc"
+
+PROVIDE="virtual/mta"
+DEPEND=">=sys-libs/db-3.2
+ >=dev-libs/libpcre-3.4
+ ldap? ( >=net-nds/openldap-1.2 )
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ ssl? ( >=dev-libs/openssl-0.9.6g )"
+RDEPEND="${DEPEND}
+ >=net-mail/mailbase-0.00
+ !virtual/mta"
+
+postfix_installed=no
+
+pkg_setup() {
+
+ if ! grep -q ^postdrop: /etc/group ; then
+ groupadd postdrop || die "problem adding group postdrop"
+ fi
+
+ if [ -d /etc/postfix ] ; then
+ postfix_installed=yes
+ fi
+
+}
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack ${DISTFILES}/${PF_P}.tar.gz
+
+ if [ `use ssl` ] && [ `use ipv6` ]
+ then
+ cd ${S}
+ patch -p1 < ${DISTFILES}/${IPV6_P}.patch || die "patch failed"
+ CCARGS="${CCARGS} -DHAS_SSL"
+ AUXLIBS="${AUXLIBS} -lssl -lcrypto"
+ elif [ `use ssl` ]
+ then
+ unpack ${DISTFILES}/${TLS_P}.tar.gz
+ cd ${S}
+ patch -p1 < ${WORKDIR}/${TLS_P}/pfixtls.diff || die "patch failed"
+ CCARGS="${CCARGS} -DHAS_SSL"
+ AUXLIBS="${AUXLIBS} -lssl -lcrypto"
+ fi
+
+ cd ${S}/conf
+ cp main.cf main.cf.orig
+ sed -e "s:/usr/libexec/postfix:/usr/lib/postfix:" main.cf.orig > main.cf
+
+ cd ${S}/src/global
+ cp mail_params.h mail_params.h.orig
+ sed -e "s:/usr/libexec/postfix:/usr/lib/postfix:" mail_params.h.orig > mail_params.h
+
+ use mysql && CCARGS="${CCARGS} -DHAS_MYSQL -I/usr/include/mysql" \
+ && AUXLIBS="${AUXLIBS} -lmysqlclient -lm"
+
+ use ldap && CCARGS="${CCARGS} -DHAS_LDAP" \
+ && AUXLIBS="${AUXLIBS} -lldap -llber"
+
+ use pam && AUXLIBS="${AUXLIBS} -lpam"
+
+ CCARGS="${CCARGS} -DHAS_PCRE"
+ AUXLIBS="${AUXLIBS} -L/usr/lib -lpcre -ldl -lcrypt"
+ DEBUG=""
+
+ cd ${S}
+ make tidy || die
+ make makefiles CC="cc" OPT="${CFLAGS}" DEBUG="${DEBUG}" \
+ CCARGS="${CCARGS}" AUXLIBS="${AUXLIBS}" || die
+}
+
+src_compile() {
+
+ emake || die "compile problem"
+
+}
+
+src_install () {
+
+ dodir /usr/bin /usr/sbin /usr/lib/postfix /etc/postfix/sample
+
+ cd ${S}/bin
+ dosbin post* sendmail
+ chown root.postdrop ${D}/usr/sbin/{postdrop,postqueue}
+ chmod 2755 ${D}/usr/sbin/{postdrop,postqueue}
+
+ dosym /usr/sbin/sendmail /usr/bin/mailq
+ dosym /usr/sbin/sendmail /usr/bin/newaliases
+ dosym /usr/sbin/sendmail /usr/lib/sendmail
+
+ cd ${S}/libexec
+ exeinto /usr/lib/postfix
+ doexe *
+
+ cd ${S}/man
+ doman man*/*
+
+ cd ${S}
+ dodoc *README COMPATIBILITY HISTORY LICENSE PORTING RELEASE_NOTES INSTALL
+ dohtml html/*
+
+ cd ${S}/conf
+ insinto /etc/postfix/sample
+ doins access aliases canonical relocated transport \
+ pcre_table regexp_table postfix-script* *.cf
+
+ exeinto /etc/postfix
+ doexe postfix-script post-install postfix-files || die
+
+ insinto /etc/postfix
+ doins ${FILESDIR}/main.cf ${S}/conf/master.cf ${FILESDIR}/saslpass || die
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/postfix.rc6 postfix
+ insinto /etc/pam.d ; newins ${FILESDIR}/smtp.pam smtp
+
+}
+
+pkg_postinst() {
+
+ install -d -m 0755 ${ROOT}/var/spool/postfix
+
+ if [ "${postfix_installed}" = "yes" ] ; then
+ ewarn "If you have upgraded from <postfix-1.1.8, you must update"
+ ewarn "/etc/postfix/master.cf to the latest version"
+ ewarn "(/etc/postfix/._cfg*_master.cf). Otherwise Postfix will"
+ ewarn "not work correctly."
+ fi
+
+ if [ ! -e /etc/mail/aliases.db ] ; then
+ echo
+ ewarn "You must edit /etc/mail/aliases to suit your needs"
+ ewarn "and then run /usr/bin/newaliases. Postfix will not"
+ ewarn "work correctly without it."
+ fi
+
+}