summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-03-08 23:49:00 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-03-08 23:49:00 +0000
commit50c244eff67eadc1023ed30d14d60883c499a3c2 (patch)
treee1cde6c288357f1fdafdfacf0c0a794158be0c94 /net-misc/dhcpcd/dhcpcd-1.3.22_p4-r4.ebuild
parentForced a version bump on these ebuilds. Basically -r0 is now -r4, -r2 is now... (diff)
downloadhistorical-50c244eff67eadc1023ed30d14d60883c499a3c2.tar.gz
historical-50c244eff67eadc1023ed30d14d60883c499a3c2.tar.bz2
historical-50c244eff67eadc1023ed30d14d60883c499a3c2.zip
Forced a version bump on these ebuilds. Basically, -r2 is now -r4 and -r3 is now -r5. The reason for the revision bump was to make this package PROVIDE virtual/dhcp. Closes a long-standing bloat-reduction request made on gentoo-dev mailing list by: William Hubbs <kc5eiv@kc5eiv.homeip.net> at http://article.gmane.org/gmane.linux.gentoo.devel/11579
Diffstat (limited to 'net-misc/dhcpcd/dhcpcd-1.3.22_p4-r4.ebuild')
-rw-r--r--net-misc/dhcpcd/dhcpcd-1.3.22_p4-r4.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-1.3.22_p4-r4.ebuild b/net-misc/dhcpcd/dhcpcd-1.3.22_p4-r4.ebuild
new file mode 100644
index 000000000000..be4f21d4fc59
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-1.3.22_p4-r4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-1.3.22_p4-r4.ebuild,v 1.1 2004/03/08 23:49:00 seemant Exp $
+
+IUSE="build static"
+
+inherit gnuconfig flag-o-matic eutils
+
+S=${WORKDIR}/${P/_p/-pl}
+DESCRIPTION="A dhcp client only"
+HOMEPAGE="http://www.phystech.com/download/"
+SRC_URI="ftp://ftp.phystech.com/pub/${P/_p/-pl}.tar.gz
+ http://dev.gentoo.org/~drobbins/${P}.diff.bz2
+ http://dev.gentoo.org/~drobbins/${P}-keepCacheAndResolv.diff.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc alpha hppa mips amd64 ia64"
+
+DEPEND="virtual/glibc"
+
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ use alpha && gnuconfig_update
+ use amd64 && gnuconfig_update
+ use hppa && gnuconfig_update
+ use ia64 && gnuconfig_update
+
+ cd ${S}
+ #Started working on this patch from an older version I found; then
+ #discovered that LFS had an updated one. We're using a patch that is
+ #identical to theirs. It makes dhcpcd FHS-compliant. (drobbins, 06
+ #Sep 2003)
+ epatch ${DISTDIR}/${P}.diff.bz2
+ #This next patch from Alwyn Schoeman <alwyn@smart.com.ph> is great;
+ #it adds a -z (shutdown, keep cache) and various other little tweaks.
+ #See http://bugs.gentoo.org/show_bug.cgi?id=23428 for more info.
+ epatch ${DISTDIR}/${P}-keepCacheAndResolv.diff.bz2
+ #remove hard-coded arch stuff (drobbins, 06 Sep 2003)
+ sed -i "s/ -march=i.86//g" configure
+ sed -i 's:/etc/ntp\.drift:/var/lib/ntp/ntp.drift:' dhcpconfig.c
+}
+
+src_compile() {
+ use static && append-flags -static
+
+ ./configure \
+ --prefix="" \
+ --sysconfdir=/var/lib \
+ --mandir=/usr/share/man || die
+
+ emake || die
+}
+
+src_install() {
+ einstall sbindir=${D}/sbin || die "Install failed"
+ if [ -z "`use build`" ]
+ then
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+ else
+ rm -rf ${D}/usr/share
+ fi
+}