summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-01-02 10:23:07 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-01-02 10:23:07 +0000
commitb528c77644c54467bd5c969a9003e4b00b9b7a63 (patch)
treedff04ca8563bddac35374d7d9cd26c9c9b32edf8 /net-misc/ices/ices-2.0.2.ebuild
parentCreate stable candidate. (diff)
downloadhistorical-b528c77644c54467bd5c969a9003e4b00b9b7a63.tar.gz
historical-b528c77644c54467bd5c969a9003e4b00b9b7a63.tar.bz2
historical-b528c77644c54467bd5c969a9003e4b00b9b7a63.zip
Version bump
Package-Manager: portage-2.2.15/cvs/Linux x86_64 Manifest-Sign-Key: 0x981CA6FC
Diffstat (limited to 'net-misc/ices/ices-2.0.2.ebuild')
-rw-r--r--net-misc/ices/ices-2.0.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-misc/ices/ices-2.0.2.ebuild b/net-misc/ices/ices-2.0.2.ebuild
new file mode 100644
index 000000000000..ec35f821e7b4
--- /dev/null
+++ b/net-misc/ices/ices-2.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ices/ices-2.0.2.ebuild,v 1.1 2015/01/02 10:23:06 polynomial-c Exp $
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="Icecast OGG streaming client, supports on the fly re-encoding"
+HOMEPAGE="http://www.icecast.org/ices.php"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2
+ >=media-libs/libshout-2
+ >=media-libs/libvorbis-1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ enewgroup ices
+ enewuser ices -1 -1 -1 ices
+}
+
+src_configure() {
+ econf --sysconfdir=/etc/ices2
+}
+
+src_install() {
+ default
+ insinto /etc/ices2
+ doins conf/*.xml
+ dohtml doc/*.{html,css}
+ newinitd "${FILESDIR}"/ices.initd-r1 ices
+ keepdir /var/log/ices
+ fperms 660 /var/log/ices
+ fowners ices:ices /var/log/ices
+ rm -rf "${D}"/usr/share/ices
+}