summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-03-25 17:18:37 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-03-25 17:18:37 +0000
commit43b9b00be4a9595cf6939a739670db143d07c68e (patch)
tree0c6ef0406f7822cfdbc2c973307865cf3291cb91 /net-misc/neon
parenttypo in network stop code (diff)
downloadhistorical-43b9b00be4a9595cf6939a739670db143d07c68e.tar.gz
historical-43b9b00be4a9595cf6939a739670db143d07c68e.tar.bz2
historical-43b9b00be4a9595cf6939a739670db143d07c68e.zip
Add a fix for libxml2 header change
Add a fix to ogle-gui for libxml2 headers
Diffstat (limited to 'net-misc/neon')
-rw-r--r--net-misc/neon/neon-0.19.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/neon/neon-0.19.2-r1.ebuild b/net-misc/neon/neon-0.19.2-r1.ebuild
new file mode 100644
index 000000000000..898bc862c5e1
--- /dev/null
+++ b/net-misc/neon/neon-0.19.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.19.2-r1.ebuild,v 1.1 2002/03/25 17:18:37 spider Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="HTTP and WebDAV client library"
+
+SRC_URI="http://www.webdav.org/${PN}/${P}.tar.gz"
+
+HOMEPAGE="http://www.webdav.org/neon"
+
+DEPEND="dev-libs/libxml2"
+
+src_compile() {
+ local myconf
+
+CFLAGS="${CFLAGS} -I/usr/include/libxml2/libxml"
+CXXFLAGS="${CXXFLAGS} -I/usr/include/libxml2/libxml"
+ if [ "`use ssl`" ] ; then
+ myconf="$myconf --with-ssl"
+ fi
+
+ ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} --enable-shared $myconf || die
+
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr install || die
+
+}
+