summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2001-09-15 23:06:03 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2001-09-15 23:06:03 +0000
commitb7f857c1757d334af705dbbef601c36ba4fbd4e4 (patch)
treec267ddf4ec444f169789c565aa7bf50c554d11dc /net-misc/neon
parentfix (diff)
downloadhistorical-b7f857c1757d334af705dbbef601c36ba4fbd4e4.tar.gz
historical-b7f857c1757d334af705dbbef601c36ba4fbd4e4.tar.bz2
historical-b7f857c1757d334af705dbbef601c36ba4fbd4e4.zip
Initial import
Diffstat (limited to 'net-misc/neon')
-rw-r--r--net-misc/neon/files/digest-neon-0.15.31
-rw-r--r--net-misc/neon/neon-0.15.3.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/neon/files/digest-neon-0.15.3 b/net-misc/neon/files/digest-neon-0.15.3
new file mode 100644
index 000000000000..9400f5f295a6
--- /dev/null
+++ b/net-misc/neon/files/digest-neon-0.15.3
@@ -0,0 +1 @@
+MD5 790ef01f17405881b63e94cbbce02194 neon-0.15.3.tar.gz
diff --git a/net-misc/neon/neon-0.15.3.ebuild b/net-misc/neon/neon-0.15.3.ebuild
new file mode 100644
index 000000000000..93dce40f7685
--- /dev/null
+++ b/net-misc/neon/neon-0.15.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.15.3.ebuild,v 1.1 2001/09/15 23:06:03 karltk Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="HTTP and WebDAV client library"
+
+SRC_URI="http://www.webdav.org/neon/neon-0.15.3.tar.gz"
+
+HOMEPAGE="http://www.webdav.org/neon"
+
+DEPEND="gnome-libs/libxml2"
+
+src_compile() {
+ local myconf
+
+ if [ "`use ssl`" ] ; then
+ myconf="$myconf --with-ssl"
+ fi
+
+ ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} --enable-shared $myconf || die
+
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr install || die
+
+}
+