summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-07-25 21:43:18 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-07-25 21:43:18 +0000
commit892310b6614f98438a6b55f73baf1ce1066633f4 (patch)
treefbc9fe392eeea4eb58649e9411688b1869954ed2 /net-misc/omniORB
parentmasked omniORB-305 for testing (diff)
downloadhistorical-892310b6614f98438a6b55f73baf1ce1066633f4.tar.gz
historical-892310b6614f98438a6b55f73baf1ce1066633f4.tar.bz2
historical-892310b6614f98438a6b55f73baf1ce1066633f4.zip
version update
Diffstat (limited to 'net-misc/omniORB')
-rw-r--r--net-misc/omniORB/ChangeLog14
-rw-r--r--net-misc/omniORB/files/digest-omniORB-3052
-rw-r--r--net-misc/omniORB/omniORB-305.ebuild116
3 files changed, 131 insertions, 1 deletions
diff --git a/net-misc/omniORB/ChangeLog b/net-misc/omniORB/ChangeLog
index 400f65317d5a..1aa32b3aebac 100644
--- a/net-misc/omniORB/ChangeLog
+++ b/net-misc/omniORB/ChangeLog
@@ -1,7 +1,19 @@
# ChangeLog for net-misc/omniORB
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/ChangeLog,v 1.3 2002/07/12 04:38:52 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/ChangeLog,v 1.4 2002/07/25 21:43:18 george Exp $
+*omniORB-305 (25 Jul 2002)
+
+ 25 Jul 2002; George Shapovalov <george@gentoo.org> omniORB-305.ebuild :
+
+ new version
+ fixes few bugs. Also omniORBpy is included, however omniNotify
+ is not (and is absent form the site)
+ BTW, omniORB is now on sourceforge, old location looks deserted for some time.
+
+ sandbox violation in omniORB-304-r6.ebuild reported by Jean-Michel Smith <jean@kcco.com>
+ corrected omniORB-304-r6.ebuild and mkomnistubs submitted by Matthias Sessler <matthias204@mac.com>
+
*omniORB-304-r7 (11 Jul 2002)
11 Jul 2002; Brandon Low <lostlogic@gentoo.org> omniORB-304-r7.ebuild :
diff --git a/net-misc/omniORB/files/digest-omniORB-305 b/net-misc/omniORB/files/digest-omniORB-305
new file mode 100644
index 000000000000..b4dfd8d160d7
--- /dev/null
+++ b/net-misc/omniORB/files/digest-omniORB-305
@@ -0,0 +1,2 @@
+MD5 49c6949e7508524e0c27cf68287c4dc9 omniORB_305.tar.gz 2465128
+MD5 83ca601d289aaa3e32ede0775e71e546 omniORBpy_1_5.tar.gz 807829
diff --git a/net-misc/omniORB/omniORB-305.ebuild b/net-misc/omniORB/omniORB-305.ebuild
new file mode 100644
index 000000000000..894339d96d9f
--- /dev/null
+++ b/net-misc/omniORB/omniORB-305.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/omniORB/omniORB-305.ebuild,v 1.1 2002/07/25 21:43:18 george Exp $
+
+S="${WORKDIR}/omni"
+DESCRIPTION="a robust, high-performance CORBA 2 ORB"
+SRC_URI="http://us.dl.sourceforge.net/omniORB/${PN}_${PV}.tar.gz
+ http://us.dl.sourceforge.net/omniORB/${PN}py_1_5.tar.gz"
+HOMEPAGE="www.sourceforge.net/omniORB"
+#the following one contains some more info, though it looks soemwhat deserted
+#HOMEPAGE="http://www.uk.research.att.com/omniORB/"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="x86 -sparc -ppc -sparc64"
+
+DEPEND="dev-lang/python"
+RDEPEND="${DEPEND}"
+
+PLT="i586_linux_2.0_glibc2.1"
+
+src_unpack() {
+
+ unpack ${PN}_${PV}.tar.gz
+ cd ${S}
+
+ cd ${S}/src/lib
+ unpack ${PN}py_1_5.tar.gz
+
+ cd ${S}/config
+ cp config.mk config.mk.orig
+ sed -e "s:#platform = ${PLT}:platform = ${PLT}:" \
+ config.mk.orig > config.mk
+
+ cd ${S}/mk
+ cp unix.mk unix.mk.orig
+ sed -e "s:^MKDIRHIER.*:MKDIRHIER = mkdir -p:" \
+ unix.mk.orig > unix.mk
+
+ cd platforms
+ cp ${PLT}.mk ${PLT}.orig
+ sed -e "s:#PYTHON = /usr.*:PYTHON=/usr/bin/python:" \
+ ${PLT}.orig > ${PLT}.mk
+
+}
+
+src_compile() {
+ cd ${S}/src
+ make export || die
+
+ cd ${S}/src/lib
+ make export || die
+}
+
+src_install () {
+
+ dodir /usr/share/omniORB/bin/scripts
+ cp -af bin/scripts/* ${D}/usr/share/omniORB/bin/scripts
+ dobin bin/${PLT}/*
+
+ insinto /usr/idl
+ doins idl/*.idl
+
+ insinto /usr/idl/COS
+ doins idl/COS/*.idl
+
+ cp -af include ${D}/usr
+
+ # change from python2.1 to python2.2
+ dodir /usr/lib/python2.2/site-packages
+
+ cp -af lib/${PLT}/_* ${D}/usr/lib/python2.2/site-packages
+ dolib lib/${PLT}/*.{a,so*}
+ rm ${D}/usr/lib/_*.*
+
+ exeinto /usr/lib/python2.2/site-packages
+ doexe lib/${PLT}/omnicpp
+ cp -af lib/python/* ${D}/usr/lib/python2.2/
+ doman man/man[15]/*.[15]
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/omniORB.rc6 omniORB
+ dodir /etc/omniorb
+ insinto /etc/omniorb
+ cd ${S}
+# doins src/services/omniNotify/channel.cfg
+# doins src/services/omniNotify/standard.cfg
+
+ dodoc CHANGES* COPYING* CREDITS PORTING README* ReleaseNote_omniORB_304 \
+ THIS_IS_omniORB_3_0_4
+
+ cd doc
+ docinto print
+ dodoc *.ps
+ dodoc *.tex
+ dodoc *.pdf
+
+ dodoc -r .
+
+ dodir /etc/env.d/
+ echo "PATH=/usr/share/omniORB/bin/scripts" > ${D}/etc/env.d/90omniORB
+ echo "OMNIORB_CONFIG=/etc/omniorb/omniORB.cfg" >> ${D}/etc/env.d/90omniORB
+
+ dodoc COPYING CREDITS
+}
+
+pkg_postinst() {
+ echo "Performing post-installation routines for ${P}."
+
+ if [ ! -f "${ROOT}etc/omniorb/omniORB.cfg" ] ; then
+ echo "ORBInitialHost `uname -n`" > ${ROOT}etc/omniorb/omniORB.cfg
+ echo "ORBInitialPort 2809" >> ${ROOT}etc/omniorb/omniORB.cfg
+ fi
+
+ /usr/bin/python ${FILESDIR}/mkomnistubs.py
+}