summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-12-05 00:19:47 +0000
committerDonny Davies <woodchip@gentoo.org>2002-12-05 00:19:47 +0000
commit0518c591dd531cf0e8b180e3136eacea8f528c78 (patch)
tree2a78fcbcf4b658ccb065645109e2d82ac7ff9810 /net-misc
parentnew audigy ebuild (diff)
downloadhistorical-0518c591dd531cf0e8b180e3136eacea8f528c78.tar.gz
historical-0518c591dd531cf0e8b180e3136eacea8f528c78.tar.bz2
historical-0518c591dd531cf0e8b180e3136eacea8f528c78.zip
fix pidfile location
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd/ChangeLog7
-rw-r--r--net-misc/dhcpcd/dhcpcd-1.3.22_p3-r2.ebuild45
-rw-r--r--net-misc/dhcpcd/files/digest-dhcpcd-1.3.22_p3-r21
3 files changed, 52 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index c1eb48d2d0ca..01f98dd756c8 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.8 2002/11/12 22:17:21 wwoods Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.9 2002/12/05 00:19:47 woodchip Exp $
+
+*dhcpcd-1.3.22_p3-r2 (04 Dec 2002)
+
+ 04 Dec 2002; Donny Davies <woodchip@gentoo.org> dhcpcd-1.3.22_p3-r1.ebuild :
+ Added a fix to force the pidfile into /var/run.
*dhcpcd-1.3.22_p3-r1 (31 Oct 2002)
diff --git a/net-misc/dhcpcd/dhcpcd-1.3.22_p3-r2.ebuild b/net-misc/dhcpcd/dhcpcd-1.3.22_p3-r2.ebuild
new file mode 100644
index 000000000000..ac6add85197a
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-1.3.22_p3-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-1.3.22_p3-r2.ebuild,v 1.1 2002/12/05 00:19:47 woodchip Exp $
+
+inherit gnuconfig
+
+S=${WORKDIR}/${P/_p/-pl}
+DESCRIPTION="A dhcp client only"
+SRC_URI="ftp://ftp.phystech.com/pub/${P/_p/-pl}.tar.gz"
+HOMEPAGE="http://www.phystech.com/download/"
+DEPEND=""
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ use alpha && gnuconfig_update
+
+ #make the pidfile always goto /var/run (woodchip Dec 4 2002)
+ cd ${S}
+ cp client.c client.c.orig
+ sed -e 's%\(PID_FILE_PATH,\)ConfigDir\(,IfNameExt\)%\1"/var/run"\2%' \
+ client.c.orig >client.c
+ cp signals.c signals.c.orig
+ sed -e 's%\(PID_FILE_PATH,\)ConfigDir\(,IfNameExt\)%\1"/var/run"\2%' \
+ signals.c.orig >signals.c
+}
+
+src_compile() {
+ econf || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install () {
+ einstall sbindir=${D}/sbin || die "Install failed"
+ if [ -z "`use build`" ]
+ then
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+ else
+ rm -rf ${D}/usr/share
+ fi
+ insinto /etc/pcmcia
+ doins pcmcia/2.9.7/network*
+}
diff --git a/net-misc/dhcpcd/files/digest-dhcpcd-1.3.22_p3-r2 b/net-misc/dhcpcd/files/digest-dhcpcd-1.3.22_p3-r2
new file mode 100644
index 000000000000..ead94227578c
--- /dev/null
+++ b/net-misc/dhcpcd/files/digest-dhcpcd-1.3.22_p3-r2
@@ -0,0 +1 @@
+MD5 9a974a96d953508dc4c3bcfa67869fd5 dhcpcd-1.3.22-pl3.tar.gz 137365