summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-12-04 19:50:47 +0000
committerMike Frysinger <vapier@gentoo.org>2002-12-04 19:50:47 +0000
commit44d9b9d369c2f610d57d3ff2c4e251972e0144ca (patch)
tree69601c86f4b19fce01a3d1668706c40d0db33ae2 /net-misc
parentbug fix (diff)
downloadhistorical-44d9b9d369c2f610d57d3ff2c4e251972e0144ca.tar.gz
historical-44d9b9d369c2f610d57d3ff2c4e251972e0144ca.tar.bz2
historical-44d9b9d369c2f610d57d3ff2c4e251972e0144ca.zip
cleanups
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rwbs/ChangeLog6
-rw-r--r--net-misc/rwbs/files/rwbs.conf22
-rw-r--r--net-misc/rwbs/files/rwbs.rc21
-rw-r--r--net-misc/rwbs/rwbs-0.27.ebuild70
4 files changed, 57 insertions, 62 deletions
diff --git a/net-misc/rwbs/ChangeLog b/net-misc/rwbs/ChangeLog
index 0a2f3622202f..90cbd3add782 100644
--- a/net-misc/rwbs/ChangeLog
+++ b/net-misc/rwbs/ChangeLog
@@ -1,12 +1,14 @@
# ChangeLog for net-misc/rwbs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rwbs/ChangeLog,v 1.2 2002/12/04 19:50:47 vapier Exp $
*rwbs-0.27 (5 Nov 2002)
+ 04 Dec 2002; Mike Frysinger <vapier@gentoo.org> :
+ Cleaned up ebuild and added sep files for conf.d/init.d
+
5 Nov 2002; Matt Keadle <mkeadle@gentoo.org> rwbs-0.27.ebuild
ChangeLog files/digest-rwbs-0.27:
-
Added initial ChangeLog which should be updated whenever the package is
updated in any way. Thanks to "delta407" for submitting this
ebuild.
diff --git a/net-misc/rwbs/files/rwbs.conf b/net-misc/rwbs/files/rwbs.conf
new file mode 100644
index 000000000000..51dd7ebf39e8
--- /dev/null
+++ b/net-misc/rwbs/files/rwbs.conf
@@ -0,0 +1,22 @@
+# Roger Wilco base station configuration
+#
+# $ rwbs --help reads:
+# usage: ./rwbs [-b(ackwardcompat)] [-t(est)] [-s(tatic)] [-p <passwd>] [-u <udpport>] [-x
+<connectspeed>] [$
+# connectspeed is an integer measuring the allocated broadcast
+# capacity for the channel host. The recommended value is 1.
+# Higher values will cause the RWBS to use its additional broadcast capacity
+# to help relay transmissions, at the expense of scalability.
+# the b(ackwardcompat) option tells RWBS to appear as a "user" on the
+# channel. Mark I users will prefer this, but not Mark Ia users.
+# The s(tatic) option indicates that a client asking to join a
+# non-existent named channel should be turned away with an error.
+# rather than being hosted on a dynamically-created channel.
+# hostname is what your station's name will be in the Roger Wilco Channel Tab.
+# For instance, if you used -n "Clan Hurt", Roger Wilco users will see
+# an entry in the Channel window named "Clan Hurt Base"
+# If the -t(est) flag is used, the base station echoes transmissions
+# when there is just one other party on the channel.
+
+# Specify whatever options you want on this line
+RWBS_OPTS='-n "Gentoo Linux"'
diff --git a/net-misc/rwbs/files/rwbs.rc b/net-misc/rwbs/files/rwbs.rc
new file mode 100644
index 000000000000..48a1aea3e6c9
--- /dev/null
+++ b/net-misc/rwbs/files/rwbs.rc
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rwbs/files/rwbs.rc,v 1.1 2002/12/04 19:50:47 vapier Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Roger Wilco base station"
+ start-stop-daemon --start --quiet --exec /usr/bin/rwbs -b \
+ -- \${RWBS_OPTS} >>/var/log/rwbs 2>&1
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Roger Wilco base station"
+ start-stop-daemon --stop --quiet --exec /usr/bin/rwbs > /dev/null 2>&1
+ eend $?
+}
diff --git a/net-misc/rwbs/rwbs-0.27.ebuild b/net-misc/rwbs/rwbs-0.27.ebuild
index b55b030e297c..06fa9c04b03a 100644
--- a/net-misc/rwbs/rwbs-0.27.ebuild
+++ b/net-misc/rwbs/rwbs-0.27.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header:
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rwbs/rwbs-0.27.ebuild,v 1.3 2002/12/04 19:50:47 vapier Exp $
DESCRIPTION="Roger Wilco base station"
HOMEPAGE="http://rogerwilco.gamespy.com/"
SRC_URI="http://games.gci.net/pub/VoiceOverIP/RogerWilco/rwbs_Linux_0_27.tar.gz"
+LICENSE="Resounding"
KEYWORDS="~x86"
SLOT="0"
@@ -15,72 +16,21 @@ DEPEND=""
S=${WORKDIR}
src_install() {
- dodoc README.TXT CHANGES.TXT LICENSE.TXT
+ dodoc README.TXT CHANGES.TXT
+ rm -f {README,CHANGES,LICENSE}.TXT
- dobin ${S}/rwbs ${S}/run_rwbs
- rm -f ${S}/rwbs ${S}/run_rwbs
+ dobin rwbs run_rwbs
+ rm -f rwbs run_rwbs
# Put distribution into /usr/share/rwbs
dodir /usr/share/rwbs/
mv * ${D}/usr/share/rwbs/
# Do conf script
- dodir /etc/conf.d/
- cat > ${D}/etc/conf.d/rwbs <<EOF
-# Roger Wilco base station configuration
-#
-# $ rwbs --help reads:
-# usage: ./rwbs [-b(ackwardcompat)] [-t(est)] [-s(tatic)] [-p <passwd>] [-u <udpport>] [-x <connectspeed>] [-n <hostname>]
-# connectspeed is an integer measuring the allocated broadcast
-# capacity for the channel host. The recommended value is 1.
-# Higher values will cause the RWBS to use its additional broadcast capacity
-# to help relay transmissions, at the expense of scalability.
-# the b(ackwardcompat) option tells RWBS to appear as a "user" on the
-# channel. Mark I users will prefer this, but not Mark Ia users.
-# The s(tatic) option indicates that a client asking to join a
-# non-existent named channel should be turned away with an error.
-# rather than being hosted on a dynamically-created channel.
-# hostname is what your station's name will be in the Roger Wilco Channel Tab.
-# For instance, if you used -n "Clan Hurt", Roger Wilco users will see
-# an entry in the Channel window named "Clan Hurt Base"
-# If the -t(est) flag is used, the base station echoes transmissions
-# when there is just one other party on the channel.
-
-# Specify whatever options you want on this line
-RWBS_OPTS='-n "Gentoo Linux"'
-EOF
+ insinto /etc/conf.d
+ newins ${FILESDIR}/rwbs.conf rwbs
# do init script
- dodir /etc/init.d/
- cat > ${D}/etc/init.d/rwbs <<EOF
-#!/sbin/runscript
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting Roger Wilco base station"
- start-stop-daemon --start --quiet --exec /usr/bin/rwbs -b \\
- -- \${RWBS_OPTS} >>/var/log/rwbs 2>&1
- eend $?
-}
-
-stop() {
- ebegin "Stopping Roger Wilco base station"
- start-stop-daemon --stop --quiet --exec /usr/bin/rwbs \\
- > /dev/null 2>&1
- eend $?
-}
-EOF
- chmod 755 ${D}/etc/init.d/rwbs
-}
-
-pkg_postinst() {
- einfo
- einfo "This build of ${PN} uses an init script, located at"
- einfo "/etc/init.d/rwbs, to start and stop ${PN}."
- einfo
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/rwbs.rc rwbs
}