summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-08-19 05:43:20 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-08-19 05:43:20 +0000
commited4260e4335d1d73baba06d092dedf7f3d44422e (patch)
tree6d3f75cac09bf98f3562cb8a0798ea9119e86162 /net-misc
parentIn media-sound... gnapster does not require gnome (diff)
downloadhistorical-ed4260e4335d1d73baba06d092dedf7f3d44422e.tar.gz
historical-ed4260e4335d1d73baba06d092dedf7f3d44422e.tar.bz2
historical-ed4260e4335d1d73baba06d092dedf7f3d44422e.zip
wget fix. Now if "build" or "bootcd" are defined, only "/usr/bin/wget"
gets installed, and that's it. And it bypasses "make install" which should fix a prob when building on a build image.
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wget/wget-1.7-r1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-misc/wget/wget-1.7-r1.ebuild b/net-misc/wget/wget-1.7-r1.ebuild
index 80de6a257abd..9f57f2f0bb7f 100644
--- a/net-misc/wget/wget-1.7-r1.ebuild
+++ b/net-misc/wget/wget-1.7-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.7-r1.ebuild,v 1.4 2001/08/13 19:20:17 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.7-r1.ebuild,v 1.5 2001/08/19 05:43:20 drobbins Exp $
A="${P}.tar.gz wget-new-percentage-1.7-20010606.diff"
S=${WORKDIR}/${P}
@@ -42,16 +42,16 @@ src_compile() {
}
src_install() {
-
+ if [ "`use build`" ] || [ "`use bootcd`" ] ; then
+ insinto /usr
+ dobin ${S}/src/wget
+ return
+ fi
+
try make prefix=${D}/usr sysconfdir=${D}/etc/wget \
mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
-
- if [ "`use build`" ] || [ "`use bootcd`" ] ; then
- rm -rf ${D}/usr
- else
- dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
- dodoc doc/sample.wgetrc
- fi
+ dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
+ dodoc doc/sample.wgetrc
}