summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-06-14 18:28:08 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-06-14 18:28:08 +0000
commit58731efa8a75bd500618c1ed88c3424f1b1f1daa (patch)
treeadb74f973d4c21b33abc216d2baa2d8da5a7db3b /net-nds/389-ds-base
parentFix wrong command in desktop files, bug #370345 and a problem with offlinehel... (diff)
downloadhistorical-58731efa8a75bd500618c1ed88c3424f1b1f1daa.tar.gz
historical-58731efa8a75bd500618c1ed88c3424f1b1f1daa.tar.bz2
historical-58731efa8a75bd500618c1ed88c3424f1b1f1daa.zip
version bump, fixes Gentoo bug #371633, drop older releases
Package-Manager: portage-2.2.0_alpha30/cvs/Linux x86_64
Diffstat (limited to 'net-nds/389-ds-base')
-rw-r--r--net-nds/389-ds-base/389-ds-base-1.2.6-r2.ebuild197
-rw-r--r--net-nds/389-ds-base/389-ds-base-1.2.8.2.ebuild (renamed from net-nds/389-ds-base/389-ds-base-1.2.7.5.ebuild)2
-rw-r--r--net-nds/389-ds-base/ChangeLog8
-rw-r--r--net-nds/389-ds-base/Manifest8
4 files changed, 11 insertions, 204 deletions
diff --git a/net-nds/389-ds-base/389-ds-base-1.2.6-r2.ebuild b/net-nds/389-ds-base/389-ds-base-1.2.6-r2.ebuild
deleted file mode 100644
index 172590f3bd41..000000000000
--- a/net-nds/389-ds-base/389-ds-base-1.2.6-r2.ebuild
+++ /dev/null
@@ -1,197 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/389-ds-base/389-ds-base-1.2.6-r2.ebuild,v 1.2 2011/03/23 06:25:58 eras Exp $
-
-EAPI=2
-
-WANT_AUTOMAKE="1.9"
-MY_P=${P/_alpha/.a}
-MY_P=${MY_P/_rc/.rc}
-inherit eutils multilib flag-o-matic autotools
-
-DESCRIPTION="389 Directory Server (core librares and daemons )"
-HOMEPAGE="http://port389.org/"
-SRC_URI="http://directory.fedoraproject.org/sources/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2-with-exceptions"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="autobind auto-dn-suffix debug doc +pam-passthru +dna +ldapi +bitwise +presence kerberos selinux"
-
-ALL_DEPEND="dev-libs/nss[utils]
- dev-libs/nspr
- dev-libs/svrcore
- dev-libs/mozldap
- >=dev-libs/cyrus-sasl-2.1.19
- >=dev-libs/icu-3.4
- >=sys-libs/db-4.5
- >=net-analyzer/net-snmp-5.1.2
- dev-libs/openssl
- sys-apps/tcp-wrappers
- sys-libs/pam
- sys-libs/zlib
- dev-perl/perl-mozldap
- dev-libs/libpcre:3
- kerberos? ( net-nds/openldap
- >=app-crypt/mit-krb5-1.7-r100[openldap] )
- selinux? ( >=sys-apps/policycoreutils-1.30.30
- sec-policy/selinux-base-policy )"
-
-DEPEND="${ALL_DEPEND}
- dev-util/pkgconfig
- sys-devel/libtool
- doc? ( app-doc/doxygen )
- selinux? ( sys-devel/m4 >=sys-apps/checkpolicy-1.30.12 )
- sys-apps/sed"
-RDEPEND="${ALL_DEPEND}
- virtual/perl-Time-Local
- virtual/perl-MIME-Base64"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- enewgroup dirsrv
- enewuser dirsrv -1 -1 -1 dirsrv
-}
-
-src_prepare() {
-
- # as per 389 documentation, when 64bit, export USE_64
- use amd64 && export USE_64=1
-
- sed -i -e 's/nobody/dirsrv/g' configure.ac || die "sed failed on configure.ac"
- use selinux && epatch "${FILESDIR}/1.2.6"/*selinux*.patch
- eautoreconf
-
- # enable nsslapd-allow-unauthenticated-binds by default
- sed -i '/^nsslapd-allow-unauthenticated-binds/ s/off/on/' "${S}"/ldap/ldif/template-dse.ldif.in || \
- die "cannot tweak default setting: nsslapd-allow-unauthenticated-binds"
-
-}
-
-src_configure() {
- local myconf=""
-
- use auto-dn-suffix && myconf="${myconf} --enable-auto-dn-suffix"
- use selinux && myconf="${myconf} --with-selinux"
-
- econf \
- $(use_enable debug) \
- $(use_enable pam-passthru) \
- $(use_enable ldapi) \
- $(use_enable autobind) \
- $(use_enable dna) \
- $(use_enable bitwise) \
- $(use_enable presence) \
- $(use_with kerberos) \
- --enable-maintainer-mode \
- --enable-autobind \
- --with-fhs \
- $myconf || die "econf failed"
-}
-
-src_compile() {
- append-lfs-flags
-
- # Use -j1 otherwise libacl-plugin.so could fail to install properly
- emake -j1 || die "compile failed"
- if use selinux; then
- emake -f selinux/Makefile || die " build selinux policy failed"
- fi
-}
-
-src_install () {
- # Use -j1 otherwise libacl-plugin.so could fail to install properly
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- if use selinux;then
- emake -f selinux/Makefile DESTDIR="${D}" install || die "Install selinux policy failed"
- fi
-
- # install not installed header
- insinto /usr/include/dirsrv
- doins ldap/servers/slapd/slapi-plugin.h
-
- # for build free-ipa require winsync-plugin
- doins ldap/servers/plugins/replication/winsync-plugin.h
-
- # make sure perl scripts have a proper shebang
- cd "${D}"/usr/share/dirsrv/script-templates/
-
- for i in $(find ./ -iname '*.pl') ;do
- sed -i -e 's/#{{PERL-EXEC}}/#\!\/usr\/bin\/perl/' $i || die
- done
-
- # remove redhat style init script
- rm -rf "${D}"/etc/rc.d || die
- rm -rf "${D}"/etc/default || die
-
- # and install gentoo style init script
- newinitd "${FILESDIR}"/389-ds.initd 389-ds
- newinitd "${FILESDIR}"/389-ds-snmp.initd 389-ds-snmp
-
- # install Gentoo-specific start/stop scripts
- rm -f "${D}"/usr/sbin/{re,}start-dirsrv || die "cannot remove 389 start/stop executables"
- exeinto /usr/sbin
- doexe "${FILESDIR}"/{re,}start-dirsrv
-
- # cope with libraries being in /usr/lib/dirsrv
- dodir /etc/env.d
- echo "LDPATH=/usr/$(get_libdir)/dirsrv" > "${D}"/etc/env.d/08dirsrv
-
- # create the directory where our log file and database
- diropts -m 0755
- dodir /var/lib/dirsrv
- keepdir /var/lib/dirsrv
- dodir /var/lock/dirsrv
- keepdir /var/lock/dirsrv
- # snmp agent, required directory
- keepdir /var/agentx
- dodir /var/agentx
-
- if use doc; then
- cd "${S}"
- doxygen slapi.doxy || die "cannot run doxygen"
- dohtml -r docs/html
- fi
-}
-
-pkg_postinst() {
- if use selinux; then
- if has "loadpolicy" $FEATURES; then
- einfo "Inserting the following modules into the module store"
- cd /usr/share/selinux/targeted # struct policy not supported
- semodule -s dirsrv -i dirsrv.pp
- else
- elog
- elog "Policy has not been loaded. It is strongly suggested"
- elog "that the policy be loaded before continuing!!"
- elog
- elog "Automatic policy loading can be enabled by adding"
- elog "\"loadpolicy\" to the FEATURES in make.conf."
- elog
- ebeep 4
- fi
- fi
-
- elog
- elog "If you are planning to use 389-ds-snmp (ldap-agent),"
- elog "make sure to properly configure: /etc/dirsrv/config/ldap-agent.conf"
- elog "adding proper 'server' entries, and adding the lines below to"
- elog " => /etc/snmp/snmpd.conf"
- elog
- elog "master agentx"
- elog "agentXSocket /var/agentx/master"
- elog
- elog
- elog "To start 389 Directory Server (LDAP service) at boot:"
- elog
- elog " rc-update add 389-ds default"
- elog
-
- elog "If you are upgrading from previous 1.2.6 release candidates"
- elog "please see:"
- elog "http://directory.fedoraproject.org/wiki/Subtree_Rename#warning:_upgrade_from_389_v1.2.6_.28a.3F.2C_rc1_.7E_rc6.29_to_v1.2.6_rc6_or_newer"
- elog
-
-}
diff --git a/net-nds/389-ds-base/389-ds-base-1.2.7.5.ebuild b/net-nds/389-ds-base/389-ds-base-1.2.8.2.ebuild
index 84d61534dac4..f401f8b4c2c4 100644
--- a/net-nds/389-ds-base/389-ds-base-1.2.7.5.ebuild
+++ b/net-nds/389-ds-base/389-ds-base-1.2.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/389-ds-base/389-ds-base-1.2.7.5.ebuild,v 1.3 2011/03/23 06:25:58 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/389-ds-base/389-ds-base-1.2.8.2.ebuild,v 1.1 2011/06/14 18:28:08 lxnay Exp $
EAPI=2
diff --git a/net-nds/389-ds-base/ChangeLog b/net-nds/389-ds-base/ChangeLog
index 3841556f0b38..6a431829a039 100644
--- a/net-nds/389-ds-base/ChangeLog
+++ b/net-nds/389-ds-base/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nds/389-ds-base
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/389-ds-base/ChangeLog,v 1.15 2011/03/23 06:25:58 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/389-ds-base/ChangeLog,v 1.16 2011/06/14 18:28:08 lxnay Exp $
+
+*389-ds-base-1.2.8.2 (14 Jun 2011)
+
+ 14 Jun 2011; Fabio Erculiani <lxnay@gentoo.org> +389-ds-base-1.2.8.2.ebuild,
+ -389-ds-base-1.2.6-r2.ebuild, -389-ds-base-1.2.7.5.ebuild:
+ version bump, fixes Gentoo bug #371633, drop older releases
23 Mar 2011; Eray Aslan <eras@gentoo.org> 389-ds-base-1.2.6-r2.ebuild,
389-ds-base-1.2.7.5.ebuild:
diff --git a/net-nds/389-ds-base/Manifest b/net-nds/389-ds-base/Manifest
index 3da1a65cb181..1511af0427d3 100644
--- a/net-nds/389-ds-base/Manifest
+++ b/net-nds/389-ds-base/Manifest
@@ -4,9 +4,7 @@ AUX 389-ds-snmp.initd 1076 RMD160 7a3be7745e7e7a6de675b40b56556bfacef76a9a SHA1
AUX 389-ds.initd 1995 RMD160 1c6140438e874b5e75bc13533fb493780675a2ff SHA1 a3c567584ce949317a741f2a8410f758d507f9b5 SHA256 722f0c18f21ccb60054433e62748008ffd908d026220be4f705dcf46e9322a92
AUX restart-dirsrv 581 RMD160 8812d099f1da6bcbefc0d09fe719f340f3c6d534 SHA1 0db36dd8f0379f1cd4bcc10da4f6cfe6dc37eacd SHA256 fd0dfbce5d74b065fc1bef6e11527d56c7fc4f16ae55383841c05d35d03173b2
AUX start-dirsrv 303 RMD160 92d3d03931614f9a85345feec5a070c7a664996f SHA1 b2b92fc7d6aaec16d9ed31ff4fb5a596f9ce32f7 SHA256 d29272f92d2c4420da8aad7919861ab667c8f224bde560491f1626957418d361
-DIST 389-ds-base-1.2.6.tar.bz2 2869328 RMD160 2cf578ce766a254a103a9b5d91239c6985c8c8d2 SHA1 82aad9a2ac069c3f922fd4e62afa35c9ae051884 SHA256 5bb4ba3bba89623910dc9ce948b7699c5ca4f3201c2773aa3e85b60fd0f03f63
-DIST 389-ds-base-1.2.7.5.tar.bz2 2855009 RMD160 8fc68734b02120957c33448f3920360ecdaeb3fc SHA1 5277c8b26ab45c4399a836de4c4c0294b6b4de2b SHA256 0dd0f0e0905673b8bcb46b23d7123f971ab5afe2567043338baec0e7e4ee31a6
-EBUILD 389-ds-base-1.2.6-r2.ebuild 5471 RMD160 9715dfae02c10e89e3551949dcc4e29f2d1a32d4 SHA1 6e48cd7e5317b611e7f244053370dd58ff009e2f SHA256 2dcdcca6fab99d536058d3b8d81a910d33b3172dbbb0304244814f458e43d600
-EBUILD 389-ds-base-1.2.7.5.ebuild 5552 RMD160 515db23c9b4b1bd6047c80a88e952eec5fe2a0c2 SHA1 95c7bd7cf0ad0efaee6ff17a83511ad106c4487b SHA256 0b7531750acb57966d69d75fb614898e250cca9557a5a1471a4b5bf0ac50e5be
-MISC ChangeLog 3276 RMD160 59266c67d709e46dea065fc4c246d2aafff2372e SHA1 83f45dc2ed70fdd35b63f3ace1abe9562ceb370f SHA256 9bcef537ad116436a45b30ef2ecec5750f20158699f0d7cb8754dcd05cc43e7c
+DIST 389-ds-base-1.2.8.2.tar.bz2 2879878 RMD160 2ffd78ebba3d48450183c9366bf744adc1077cc9 SHA1 676577da7b1a68b915198c94491981d78c2afd42 SHA256 ddff795cfaa1181245c468589a2c0d0e0f75a08db7e7ddc8bbb91baf06d9658a
+EBUILD 389-ds-base-1.2.8.2.ebuild 5553 RMD160 2c1c54552732958cfcca6ea567cd27ccd9ef5a66 SHA1 7ee39a2c566165862a73fbbd1ea8b6444b3f1984 SHA256 5b3601036515df7cab3213f6149537077cac809502932a16af75c7107b07d92c
+MISC ChangeLog 3516 RMD160 8a81b0823d593f2d6879a6dd8c8a99441a47ee6e SHA1 2fa761cc5ec8c9dced97540b415165977e8bab83 SHA256 248bb19cbe10fc792604c4061674a6df1f6126b83766a40e18f29470be7b245f
MISC metadata.xml 1070 RMD160 f31a4089eb70f9228378f1fb6dd69ae2942bc9a3 SHA1 5b58beab1b9e2a63c7378bdf9836683a888600de SHA256 b7bd4cba6afb6af7418c4c6467ef998cdcd381765de671462f15872d29fa4066