summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-07-11 03:34:57 +0000
committerDonny Davies <woodchip@gentoo.org>2003-07-11 03:34:57 +0000
commit0d6d4048471d06dd3d0c80773a26868911583541 (patch)
tree0b63a8db636c91dfcebc016ebffb5be066d1ce44 /net-nds/ypserv
parentbump and updates... (diff)
downloadhistorical-0d6d4048471d06dd3d0c80773a26868911583541.tar.gz
historical-0d6d4048471d06dd3d0c80773a26868911583541.tar.bz2
historical-0d6d4048471d06dd3d0c80773a26868911583541.zip
bump and updates...
Diffstat (limited to 'net-nds/ypserv')
-rw-r--r--net-nds/ypserv/Manifest6
-rw-r--r--net-nds/ypserv/files/rpc.yppasswdd19
-rw-r--r--net-nds/ypserv/files/ypserv.confd4
-rw-r--r--net-nds/ypserv/files/ypserv.rc28
-rw-r--r--net-nds/ypserv/ypserv-2.8.ebuild53
5 files changed, 107 insertions, 3 deletions
diff --git a/net-nds/ypserv/Manifest b/net-nds/ypserv/Manifest
index 5455f9eb26d3..86f7fbc683a3 100644
--- a/net-nds/ypserv/Manifest
+++ b/net-nds/ypserv/Manifest
@@ -1,8 +1,8 @@
-MD5 a78d6b77784555fefbf705079a9dedf3 ChangeLog 1887
+MD5 5a01e0dc5a3eb48056d5153e42aae9a0 ChangeLog 2097
MD5 35a8cb8c9e2b7e839d90b1a456973a14 ypserv-1.3.12.ebuild 1609
MD5 67da13c9aa07c76c0fe63b40f1ddd3ba ypserv-2.5-r1.ebuild 1613
MD5 03c1ab38d5c952e9ed92393984576235 ypserv-2.5.ebuild 992
-MD5 ac97a831ecae0e4675b02a57439b6118 ypserv-2.8.ebuild 1605
+MD5 e74f2693fb80933c020e308fcdf27b37 ypserv-2.8.ebuild 1569
MD5 d65fdf73994b1d6d96d9820cbcae02ef files/defs.sed 856
MD5 d8a2530491cec60a01a03e74b63b37c7 files/digest-ypserv-1.3.12 65
MD5 9c20be3742d94aee43877c12df611b05 files/digest-ypserv-2.5 62
@@ -11,6 +11,6 @@ MD5 723eea6eeee5a020cd9ff8cc3959fb6a files/ypserv-confd 216
MD5 bc2e829e5cfce15dae06614f152d8e19 files/ypserv-initd 1089
MD5 66cb16c281ac0a8b0ccb4056d9a60491 files/ypserv.confd 117
MD5 7d40247a0e986ba4ae920c685e811f53 files/rpc.yppasswdd 422
-MD5 08beca0f4864ae53f74df8e88d0e2099 files/ypserv.rc 691
+MD5 3b6a227e0fcb71bf2642f78de597fe40 files/ypserv.rc 692
MD5 c4e764aff5598d93c05d8c74f878b5ce files/digest-ypserv-2.8 62
MD5 5950ee3a17fa970f3c76bc615b024b6c files/1.3.12/volatile-fix-gcc-3.2.diff 385
diff --git a/net-nds/ypserv/files/rpc.yppasswdd b/net-nds/ypserv/files/rpc.yppasswdd
new file mode 100644
index 000000000000..f08f7728402a
--- /dev/null
+++ b/net-nds/ypserv/files/rpc.yppasswdd
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+ need net portmap ypserv
+}
+
+start() {
+ ebegin "Starting rpc.yppasswdd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/rpc.yppasswdd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping rpc.yppasswdd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/rpc.yppasswdd
+ eend $?
+}
diff --git a/net-nds/ypserv/files/ypserv.confd b/net-nds/ypserv/files/ypserv.confd
new file mode 100644
index 000000000000..7f2e74440a24
--- /dev/null
+++ b/net-nds/ypserv/files/ypserv.confd
@@ -0,0 +1,4 @@
+# Config file for /etc/init.d/ypserv
+
+# NIS domain (not necessarily the same as DNS domain)
+#YP_DOMAIN=my.nis.domain
diff --git a/net-nds/ypserv/files/ypserv.rc b/net-nds/ypserv/files/ypserv.rc
new file mode 100644
index 000000000000..7bd11046dc71
--- /dev/null
+++ b/net-nds/ypserv/files/ypserv.rc
@@ -0,0 +1,28 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/files/ypserv.rc,v 1.1 2003/07/11 03:34:38 woodchip Exp $
+
+depend() {
+ need net portmap
+}
+
+checkconfig() {
+ [ -n "$YP_DOMAIN" ] && return 0
+ eerror "You need to setup YP_DOMAIN in /etc/conf.d/ypserv"
+ return 1
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting NIS Server"
+ ypdomainname "$YP_DOMAIN"
+ start-stop-daemon --start --quiet --exec /usr/sbin/ypserv
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping NIS Server"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ypserv
+ eend $?
+}
diff --git a/net-nds/ypserv/ypserv-2.8.ebuild b/net-nds/ypserv/ypserv-2.8.ebuild
new file mode 100644
index 000000000000..ad0914c0783e
--- /dev/null
+++ b/net-nds/ypserv/ypserv-2.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypserv/ypserv-2.8.ebuild,v 1.1 2003/07/11 03:34:37 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Network Information Service server"
+SRC_URI="mirror://kernel/linux/utils/net/NIS/${P}.tar.gz"
+HOMEPAGE="http://www.linux-nis.org/nis/"
+
+IUSE=""
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+DEPEND=">=sys-libs/gdbm-1.8.0"
+
+src_compile() {
+ econf --enable-yppasswd || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
+
+ insinto /etc
+ doins etc/ypserv.conf etc/netgroup etc/netmasks
+
+ insinto /var/yp
+ doins etc/securenets
+
+ insinto /etc/conf.d
+ doins ${FILESDIR}/ypserv.confd ypserv
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/ypserv.rc ypserv
+ newexe ${FILESDIR}/rpc.yppasswdd rpc.yppasswdd
+
+ # Save the old config into the new package as CONFIG_PROTECT
+ # doesn't work for this package.
+ if [ -f ${ROOT}/var/yp/Makefile ]; then
+ mv ${D}/var/yp/Makefile ${D}/var/yp/Makefile.dist
+ cp ${ROOT}/var/yp/Makefile ${D}/var/yp/Makefile
+ einfo "As you have a previous /var/yp/Makefile, I have added"
+ einfo "this file into the new package and installed the new"
+ einfo "file as /var/yp/Makefile.dist"
+ fi
+}
+
+pkg_postinst() {
+ einfo "To complete setup, you will need to edit /var/yp/securenets,"
+ einfo "/etc/conf.d/ypserv, /etc/ypserv.conf, and possibly"
+ einfo "/var/yp/Makefile."
+}