summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJochen Maes <sejo@gentoo.org>2004-11-15 10:29:24 +0000
committerJochen Maes <sejo@gentoo.org>2004-11-15 10:29:24 +0000
commitc272eed1651148b808a55d3d9239ad874384f0e5 (patch)
treea6b6e3b88b727c7e1f10fe728df284c66e125726 /net-p2p/azureus
parentbug #71223: win9x/Me lanman printing. bug #70628: 3.0.8 docs upstream permiss... (diff)
downloadhistorical-c272eed1651148b808a55d3d9239ad874384f0e5.tar.gz
historical-c272eed1651148b808a55d3d9239ad874384f0e5.tar.bz2
historical-c272eed1651148b808a55d3d9239ad874384f0e5.zip
initial add to tree
Diffstat (limited to 'net-p2p/azureus')
-rw-r--r--net-p2p/azureus/ChangeLog7
-rw-r--r--net-p2p/azureus/Manifest9
-rw-r--r--net-p2p/azureus/azureus-2.2.0.0.ebuild64
-rw-r--r--net-p2p/azureus/files/SWTThread.java91
-rw-r--r--net-p2p/azureus/files/azureus-gentoo.sh65
-rw-r--r--net-p2p/azureus/files/azureus.desktop8
-rw-r--r--net-p2p/azureus/files/azureus.pngbin0 -> 743 bytes
-rw-r--r--net-p2p/azureus/files/build.xml21
-rw-r--r--net-p2p/azureus/files/digest-azureus-2.2.0.02
-rw-r--r--net-p2p/azureus/metadata.xml10
10 files changed, 277 insertions, 0 deletions
diff --git a/net-p2p/azureus/ChangeLog b/net-p2p/azureus/ChangeLog
new file mode 100644
index 000000000000..e4266b2ab91f
--- /dev/null
+++ b/net-p2p/azureus/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for net-p2p/azureus
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.1 2004/11/15 10:29:24 sejo Exp $
+
+ 15 Nov 2004; <SeJo@gentoo.org> :
+ initial add of ebuild
+
diff --git a/net-p2p/azureus/Manifest b/net-p2p/azureus/Manifest
new file mode 100644
index 000000000000..ffe18dfbccaf
--- /dev/null
+++ b/net-p2p/azureus/Manifest
@@ -0,0 +1,9 @@
+MD5 a63336d02253ae5fe2ad69f813bdd7d8 metadata.xml 329
+MD5 575d8c4c512344e302dcda6e0b2f8723 ChangeLog 261
+MD5 f4bbad69c5641c5a91d1daa68ab3e492 azureus-2.2.0.0.ebuild 2169
+MD5 21218e1a7c134f02c8e42bcb63375e74 files/SWTThread.java 2549
+MD5 176ecbdf186cc2d1e318ece1acd3f1bf files/build.xml 659
+MD5 70c17db47c9a596929112714f82ac010 files/azureus.desktop 153
+MD5 2d3136c60488dd51bef012cbcb59201b files/azureus.png 743
+MD5 5ad6311f84c6f6205bf3c57160a246a2 files/azureus-gentoo.sh 1793
+MD5 67821fe5d66efda508803dfa3a87b967 files/digest-azureus-2.2.0.0 134
diff --git a/net-p2p/azureus/azureus-2.2.0.0.ebuild b/net-p2p/azureus/azureus-2.2.0.0.ebuild
new file mode 100644
index 000000000000..f3fd32f0d28a
--- /dev/null
+++ b/net-p2p/azureus/azureus-2.2.0.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/azureus-2.2.0.0.ebuild,v 1.1 2004/11/15 10:29:24 sejo Exp $
+
+DESCRIPTION="Azureus - Java BitTorrent Client"
+HOMEPAGE="http://azureus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/azureus/Azureus_${PV}_source.zip
+ mirror://gentoo/seda-20040224.zip"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+DEPEND="virtual/libc
+ >=dev-java/swt-3.0
+ >=app-arch/unzip-5.0"
+RDEPEND="virtual/libc
+ >=dev-java/swt-3.0
+ >=dev-java/log4j-1.2.8
+ >=dev-java/commons-cli-1.0
+ >=dev-java/systray4j-2.4"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ PROGRAM_DIR="/usr/lib/${PN}"
+ mkdir ${S} && cd ${S}
+ unpack ${A}
+ cp ${FILESDIR}/build.xml ${S} || die "cp build.xml failed"
+ #removing osx files and entries
+ cp -f ${FILESDIR}/SWTThread.java \
+ ${S}/org/gudy/azureus2/ui/swt/mainwindow/SWTThread.java \
+ || die "cp SWTThread.java failed!"
+ # copying the shell to run the app
+ cp ${FILESDIR}/azureus-gentoo.sh ${S}/azureus \
+ || die "cp azureus-gentoo.sh filed"
+ # Set runtime settings in the startup script
+ sed -i "s:##PROGRAM_DIR##:${PROGRAM_DIR}:" ${S}/azureus \
+ || die "sed azureus program dir failed !"
+ rm -fr org/gudy/azureus2/ui/swt/osx org/gudy/azureus2/ui/swt/test
+}
+
+src_compile() {
+ # Figure out correct boot classpath
+ if [ ! -z "$(java-config --java-version | grep IBM)" ] ; then
+ # IBM JRE
+ ant_extra_opts="-Dbootclasspath=$(java-config --jdk-home)/jre/lib/core.jar:$(java-config --jdk-home)/jre/lib/xml.jar:$(java-config --jdk-home)/jre/lib/graphics.jar"
+ else
+ # Sun derived JREs (Blackdown, Sun)
+ ant_extra_opts="-Dbootclasspath=$(java-config --jdk-home)/jre/lib/rt.jar"
+ fi
+ ant -q -q \
+ -buildfile build.xml ${ant_extra_opts} jar \
+ || die "ant build failed"
+}
+
+src_install() {
+ insinto ${PROGRAM_DIR}
+ doins *.jar || die "doins jar failed"
+ dobin azureus || die "dobin /usr/bin/azureus failed"
+ insinto /usr/share/pixmaps
+ doins "${FILESDIR}/azureus.png"
+ insinto /usr/share/applications
+ doins "${FILESDIR}/azureus.desktop"
+ dodoc seda-README.txt
+}
diff --git a/net-p2p/azureus/files/SWTThread.java b/net-p2p/azureus/files/SWTThread.java
new file mode 100644
index 000000000000..33c1a0e9c35f
--- /dev/null
+++ b/net-p2p/azureus/files/SWTThread.java
@@ -0,0 +1,91 @@
+/*
+ * Created on Apr 30, 2004
+ * Created by Olivier Chalouhi
+ * Copyright (C) 2004 Aelitis, All Rights Reserved.
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version 2
+ * of the License, or (at your option) any later version.
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ *
+ * AELITIS, SARL au capital de 30,000 euros
+ * 8 Allee Lenotre, La Grille Royale, 78600 Le Mesnil le Roi, France.
+ *
+ */
+package org.gudy.azureus2.ui.swt.mainwindow;
+
+
+import org.eclipse.swt.widgets.Display;
+import org.gudy.azureus2.core3.util.*;
+
+/**
+ * The main SWT Thread, the only one that should run any GUI code.
+ */
+public class SWTThread {
+
+ private static SWTThread instance;
+
+ public static SWTThread getInstance() {
+ return instance;
+ }
+
+ public static void createInstance(Application app) throws SWTThreadAlreadyInstanciatedException {
+ if(instance != null) {
+ throw new SWTThreadAlreadyInstanciatedException();
+ }
+ //Will only return on termination
+ new SWTThread(app);
+
+ }
+
+
+ Display display;
+ private boolean terminated;
+ private Thread runner;
+
+ private SWTThread(final Application app) {
+
+ instance = this;
+
+ display = new Display();
+ Display.setAppName("Azureus");
+
+ runner = new Thread( new AERunnable(){ public void runSupport(){app.run();}},"Main Thread");
+ runner.start();
+
+ while(!display.isDisposed() && !terminated) {
+ try {
+ if (!display.readAndDispatch())
+ display.sleep();
+ }
+ catch (Exception e) {
+ Debug.printStackTrace( e );
+ }
+ }
+
+ //if it hasn been terminated, there's no way to stop the application
+ //as the application is the one who has stopped it.
+ if(!terminated) {
+ app.stopIt();
+ }
+
+ display.dispose();
+ }
+
+
+
+ public void terminate() {
+ terminated = true;
+ }
+
+ public Display getDisplay() {
+ return display;
+ }
+}
diff --git a/net-p2p/azureus/files/azureus-gentoo.sh b/net-p2p/azureus/files/azureus-gentoo.sh
new file mode 100644
index 000000000000..b85c48417809
--- /dev/null
+++ b/net-p2p/azureus/files/azureus-gentoo.sh
@@ -0,0 +1,65 @@
+#!/bin/sh
+
+PROGRAM_DIR=##PROGRAM_DIR## # directory where all the files were extracted
+
+AZ_CONFIG="${HOME}/.Azureus/gentoo.config"
+if [ -f ~/.Azureus/gentoo.config ]; then
+ . ~/.Azureus/gentoo.config
+else
+ if [ ! -e ~/.Azureus ]; then
+ mkdir ~/.Azureus
+ echo "Creating ~/.Azureus..."
+ fi
+
+ # Setup defaults
+ UI_OPTIONS="--ui=swt"
+
+ # Create the config file
+ cat > ${AZ_CONFIG} <<END
+# User Interface options:
+# web - web based
+# web2 - web based
+# console - console based
+# swt - swt (GUI) based
+#
+# When selecting just 1, use '--ui=<ui>'
+# When selecting multiple, use '--uis=<ui>,<ui>'
+UI_OPTIONS="--ui=swt"
+END
+
+fi
+
+MSG0="ERROR:\nYou must edit this script and change PROGRAM_DIR to point to where you installed Azureus"
+MSG1="Attempting to start Azureus..."
+
+AZDIR=./
+if [ ! -e id.azureus.dir.file ]; then
+ AZDIR=$PROGRAM_DIR
+ if [ ! -d $AZDIR ]; then
+ echo $MSG0 >&2
+ exit -1
+ fi
+fi
+
+cd ${AZDIR}
+echo $MSG1
+
+# This should work as long as your classpath is setup right...
+#JARS=`ls *.jar | grep -v Azureus2`
+#for FILE in $JARS; do CLASSPATH="${FILE}:${CLASSPATH}"; done
+#java -cp $CLASSPATH -Djava.library.path="/usr/lib:${AZDIR}" -jar Azureus2.jar ${UI_OPTIONS} "$1"
+
+# Try this if the above doesn't work
+for FILE in *.jar; do CLASSPATH="${FILE}:${CLASSPATH}"; done
+java -cp $CLASSPATH -Djava.library.path="/usr/share/swt/lib:${AZDIR}" org.gudy.azureus2.ui.swt.Main "$1"
+
+if [ $? -ne 0 ]; then
+ echo "If you recieved an error about a missing java class, you need to setup"
+ echo "your classpath correctly."
+ echo "This should do the trick (as root):"
+ echo "java-config --add-system-classpath=junit,log4j,commons-cli-1,systray4j,swt"
+ echo "env-update && source /etc/profile"
+ echo
+ echo "Currently, your classpath (including azureus additions) is:"
+ echo "${CLASSPATH}"
+fi
diff --git a/net-p2p/azureus/files/azureus.desktop b/net-p2p/azureus/files/azureus.desktop
new file mode 100644
index 000000000000..7a45c5e9d52d
--- /dev/null
+++ b/net-p2p/azureus/files/azureus.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Azureus
+Comment=Azureus BitTorrent Client
+Exec=azureus
+Icon=azureus.png
+Terminal=0
+Categories=Application;Network;
+Type=Application
diff --git a/net-p2p/azureus/files/azureus.png b/net-p2p/azureus/files/azureus.png
new file mode 100644
index 000000000000..9ece3a943457
--- /dev/null
+++ b/net-p2p/azureus/files/azureus.png
Binary files differ
diff --git a/net-p2p/azureus/files/build.xml b/net-p2p/azureus/files/build.xml
new file mode 100644
index 000000000000..b0f7d850c9b6
--- /dev/null
+++ b/net-p2p/azureus/files/build.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<project basedir="." default="compile" name="Azureus">
+ <target name="compile">
+ <javac debug="true" deprecation="false" destdir="." srcdir=".">
+ <classpath>
+ <pathelement location="."/>
+ <pathelement location="/usr/share/commons-cli-1/lib/commons-cli.jar"/>
+ <pathelement location="/usr/share/swt/lib/swt.jar"/>
+ <pathelement location="seda.jar"/>
+ </classpath>
+ </javac>
+ </target>
+ <target name="jar" depends="compile">
+ <jar jarfile="azureus.jar" basedir=".">
+ <fileset dir=".">
+ <include name="**/*.class"/>
+ <include name="**/*.properties"/>
+ </fileset>
+ </jar>
+ </target>
+</project>
diff --git a/net-p2p/azureus/files/digest-azureus-2.2.0.0 b/net-p2p/azureus/files/digest-azureus-2.2.0.0
new file mode 100644
index 000000000000..483f1b88554d
--- /dev/null
+++ b/net-p2p/azureus/files/digest-azureus-2.2.0.0
@@ -0,0 +1,2 @@
+MD5 aed39c29a6bcad2c2d377d5f5ef20e0e Azureus_2.2.0.0_source.zip 3052987
+MD5 5f79ac344851884646166d733b5cde8d seda-20040224.zip 755126
diff --git a/net-p2p/azureus/metadata.xml b/net-p2p/azureus/metadata.xml
new file mode 100644
index 000000000000..b98bac8e78ab
--- /dev/null
+++ b/net-p2p/azureus/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sejo@gentoo.org</email>
+ <name>Maes Jochen</name>
+ <description>Maintainer</description>
+ </maintainer>
+ <longdescription>Azureus P2P source build</longdescription>
+</pkgmetadata>