summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-11-30 01:22:59 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-11-30 01:22:59 +0000
commit03c96cae75042ba9dcbfd46efe1a31dcc2cbd853 (patch)
tree942af0e8fef9988b40733d5231b5184a8fa97614 /net-p2p/giftcurs/giftcurs-0.5.5.ebuild
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadhistorical-03c96cae75042ba9dcbfd46efe1a31dcc2cbd853.tar.gz
historical-03c96cae75042ba9dcbfd46efe1a31dcc2cbd853.tar.bz2
historical-03c96cae75042ba9dcbfd46efe1a31dcc2cbd853.zip
ok, I got this letter from somone who appears to be related to the
project, yet doesnt appear in its ChangeLog. Subject: giFTcurs gentoo package From: Josh Guilfoyle <jasta@gotlinux.org> If you aren't going to keep up to date with giFTcurs releases, I strongly suggest you remove the package from gentoo. In fact, consider this a request to remove the package. ---- This person is not related to the giFTcurs project, and only does it for the kick of bashing Gentoo. Am I naive who actually believe people ought to be polite? BAH!
Diffstat (limited to 'net-p2p/giftcurs/giftcurs-0.5.5.ebuild')
-rw-r--r--net-p2p/giftcurs/giftcurs-0.5.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-p2p/giftcurs/giftcurs-0.5.5.ebuild b/net-p2p/giftcurs/giftcurs-0.5.5.ebuild
new file mode 100644
index 000000000000..aed217c0a72f
--- /dev/null
+++ b/net-p2p/giftcurs/giftcurs-0.5.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/giftcurs/giftcurs-0.5.5.ebuild,v 1.1 2002/11/30 01:22:59 spider Exp $
+
+MY_P="giFTcurs-${PV}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="A cursed frontend to the giFT (OpenFT) daemon"
+SRC_URI="mirror://sourceforge/giftcurs/${MY_P}.tar.gz"
+HOMEPAGE="http://giftcurs.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="gpm nls"
+KEYWORDS="~x86 ~sparc ~sparc64"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=net-p2p/gift-cvs-0.10.0"
+
+src_compile() {
+ local myconf=""
+
+ use gpm || myconf="${myconf} --disable-mouse --disable-libgpm"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf $myconf || die "./configure failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ einstall || die "Installation failed"
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog NEWS README THANKS TODO
+}