summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-03-23 08:32:58 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-03-23 08:32:58 +0000
commite07ca45ea71ed2f2def0ffa1d5892af9598cb537 (patch)
tree6e6e0a9f4df5b8191736c3f8721562705fbb1ead /net-p2p/ktorrent
parentFix slot-deps on gnome libs (diff)
downloadhistorical-e07ca45ea71ed2f2def0ffa1d5892af9598cb537.tar.gz
historical-e07ca45ea71ed2f2def0ffa1d5892af9598cb537.tar.bz2
historical-e07ca45ea71ed2f2def0ffa1d5892af9598cb537.zip
Version bump
Package-Manager: portage-2.2.0_alpha28/cvs/Linux x86_64
Diffstat (limited to 'net-p2p/ktorrent')
-rw-r--r--net-p2p/ktorrent/ChangeLog7
-rw-r--r--net-p2p/ktorrent/Manifest4
-rw-r--r--net-p2p/ktorrent/ktorrent-4.1.0.ebuild102
3 files changed, 111 insertions, 2 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index a6e26e939943..2b72428fdbca 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.162 2011/01/17 11:42:27 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.163 2011/03/23 08:32:58 scarabeus Exp $
+
+*ktorrent-4.1.0 (23 Mar 2011)
+
+ 23 Mar 2011; Tomáš Chvátal <scarabeus@gentoo.org> +ktorrent-4.1.0.ebuild:
+ Version bump
17 Jan 2011; Tomáš Chvátal <scarabeus@gentoo.org> -ktorrent-3.3.4.ebuild:
old
diff --git a/net-p2p/ktorrent/Manifest b/net-p2p/ktorrent/Manifest
index 0856977365a2..ecf5d140d289 100644
--- a/net-p2p/ktorrent/Manifest
+++ b/net-p2p/ktorrent/Manifest
@@ -1,4 +1,6 @@
DIST ktorrent-4.0.5.tar.bz2 2813499 RMD160 a5cc3f4a97fd1158a08f8d8502e5c4b429b80d2f SHA1 eca1186dcd878868317743b21b90fb5880b774bf SHA256 d6b199be0d24933da55c5eee8d13d22fda03b7098aca59e4468387c25206fecd
+DIST ktorrent-4.1.0.tar.bz2 2918327 RMD160 61d7fc0a9b7f6c076216114938a572f151bec251 SHA1 0d5bdde42401c75a0e1de4e7bb287443ff1d24e3 SHA256 aa2b1133f7a42b6112ff9d55b2b441b9c8df041938e33c5246bb0d1da284aa6e
EBUILD ktorrent-4.0.5.ebuild 2969 RMD160 5d4656dcb56a8aebdc7b2b3ed9dd215ce9174ae0 SHA1 f0f615ea335f7950e85ed52bdc12f6be906a5e84 SHA256 3212be11a51602163f35427de2b0f9f17f35458f45a07357420521eb60c3ba11
-MISC ChangeLog 24343 RMD160 f6323136cd4dcbe79fca70b202c24f9d4f3ddded SHA1 e472fb5ee4c5da73ac934dcccbc25c61cad9b1a0 SHA256 9a506d38ad03a9d2611d3ec304f2140666b5bae5493784eb1b7b5e0a1567c26f
+EBUILD ktorrent-4.1.0.ebuild 3184 RMD160 756fd16cad85150b4d5e821bffb2298f08a635b6 SHA1 d7ba35278e057c95e7aa9a80612cb4e9fec85c3a SHA256 450f5d41d8d7ec64a61314f14bb8b83558bd1e234f33c44d177740bc1951bc64
+MISC ChangeLog 24469 RMD160 62ebad02ab0e0451967c0a47ddaa1b8e6e2b9e2b SHA1 f83b826b2fb083ad3860e6d37f34340b4e0c1fde SHA256 0fb03f2a00451baa20ba597e9ed198fb15d4c78c57aa139c358bb025c124a055
MISC metadata.xml 1389 RMD160 85af8086d711dc47de7d5cc61923b58ca7a42df2 SHA1 d13e12b8ff9d2cb59fdc53c88804b8d12af2f79e SHA256 e7fa6c95c77618daa38c5baf4c97621eb7cdb7b38e38f9f81f30804d77097cf7
diff --git a/net-p2p/ktorrent/ktorrent-4.1.0.ebuild b/net-p2p/ktorrent/ktorrent-4.1.0.ebuild
new file mode 100644
index 000000000000..183a3a5bca70
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-4.1.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-4.1.0.ebuild,v 1.1 2011/03/23 08:32:58 scarabeus Exp $
+
+EAPI=3
+
+KDE_SCM="git"
+KDE_MINIMAL="4.5"
+LIBKT_VERSION_MIN="${PV}"
+LIBKT_VERSION_MAX="99999999"
+if [[ ${PV} != 9999* ]]; then
+ inherit versionator
+ # upstream likes to skip that _ in beta releases
+ MY_PV="${PV/_/}"
+ LIBKT_VERSION_MIN=$(($(get_major_version)-3)).$(get_version_component_range 2-3 ${PV})
+ LIBKT_VERSION_MAX=$(($(get_major_version)-3)).$(($(get_version_component_range 2)+1))
+ MY_P="${PN}-${MY_PV}"
+ KDE_HANDBOOK="optional"
+ KDE_DOC_DIRS="doc"
+
+ KDE_LINGUAS="ar ast be bg ca ca@valencia cs da de el en_GB eo es et eu
+ fi fr ga gl hi hne hr hu is it ja km lt lv mai ms nb nds nl nn oc
+ pl pt pt_BR ro ru se si sk sl sr sr@ijekavian sr@ijekavianlatin
+ sr@latin sv tr uk zh_CN zh_TW"
+ SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}"/"${MY_P}"
+
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+else
+ LIBKT_VERSION_MIN="${PV}"
+ LIBKT_VERSION_MAX="99999999"
+ KEYWORDS=""
+fi
+
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="+bwscheduler debug +downloadorder +infowidget +ipfilter +kross +logviewer
++magnetgenerator +mediaplayer plasma rss +scanfolder +search +shutdown +stats
++upnp webinterface +zeroconf"
+
+COMMONDEPEND="
+ <net-libs/libktorrent-${LIBKT_VERSION_MAX}
+ >=net-libs/libktorrent-${LIBKT_VERSION_MIN}
+ mediaplayer? ( >=media-libs/taglib-1.5 )
+ plasma? ( $(add_kdebase_dep libtaskmanager) )
+ rss? ( $(add_kdebase_dep kdepimlibs) )
+ shutdown? (
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep solid)
+ )
+"
+DEPEND="${COMMONDEPEND}
+ dev-libs/boost
+ sys-devel/gettext
+"
+RDEPEND="${COMMONDEPEND}
+ infowidget? ( dev-libs/geoip )
+ ipfilter? (
+ app-arch/bzip2
+ app-arch/unzip
+ $(add_kdebase_dep kdebase-kioslaves)
+ )
+ kross? ( $(add_kdebase_dep krosspython) )
+"
+
+src_prepare() {
+ if ! use plasma; then
+ sed -i \
+ -e "s:add_subdirectory(plasma):#nada:g" \
+ CMakeLists.txt || die "Failed to make plasmoid optional"
+ fi
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable bwscheduler BWSCHEDULER_PLUGIN)
+ $(cmake-utils_use_enable downloadorder DOWNLOADORDER_PLUGIN)
+ $(cmake-utils_use_enable infowidget INFOWIDGET_PLUGIN)
+ $(cmake-utils_use_with infowidget SYSTEM_GEOIP)
+ $(cmake-utils_use_enable ipfilter IPFILTER_PLUGIN)
+ $(cmake-utils_use_enable kross SCRIPTING_PLUGIN)
+ $(cmake-utils_use_enable logviewer LOGVIEWER_PLUGIN)
+ $(cmake-utils_use_enable magnetgenerator MAGNETGENERATOR_PLUGIN)
+ $(cmake-utils_use_enable mediaplayer MEDIAPLAYER_PLUGIN)
+ $(cmake-utils_use_enable rss SYNDICATION_PLUGIN)
+ $(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
+ $(cmake-utils_use_enable search SEARCH_PLUGIN)
+ $(cmake-utils_use_enable shutdown SHUTDOWN_PLUGIN)
+ $(cmake-utils_use_enable stats STATS_PLUGIN)
+ $(cmake-utils_use_enable upnp UPNP_PLUGIN)
+ $(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)
+ $(cmake-utils_use_enable zeroconf ZEROCONF_PLUGIN)
+ )
+ kde4-base_src_configure
+}