summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-10-16 18:48:47 +0000
committerAlin Năstac <mrness@gentoo.org>2006-10-16 18:48:47 +0000
commitdbf1f1a7668312c1e1655b3975ee0d6dee23e843 (patch)
tree5d872b6adac0eae8b8daee14916feb9b976b40a3 /net-proxy
parentVersion bump. Thank upstream dev Loren Bandiera for report. Fixed indentation... (diff)
downloadhistorical-dbf1f1a7668312c1e1655b3975ee0d6dee23e843.tar.gz
historical-dbf1f1a7668312c1e1655b3975ee0d6dee23e843.tar.bz2
historical-dbf1f1a7668312c1e1655b3975ee0d6dee23e843.zip
Remove /etc/squid/errors symlink (#151304).
Package-Manager: portage-2.1.1
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/squid/ChangeLog8
-rw-r--r--net-proxy/squid/files/digest-squid-2.6.4-r26
-rw-r--r--net-proxy/squid/squid-2.6.4-r2.ebuild201
3 files changed, 214 insertions, 1 deletions
diff --git a/net-proxy/squid/ChangeLog b/net-proxy/squid/ChangeLog
index 2fbdb88a58e3..3198ea750d93 100644
--- a/net-proxy/squid/ChangeLog
+++ b/net-proxy/squid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/squid
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/ChangeLog,v 1.98 2006/10/07 05:10:25 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/ChangeLog,v 1.99 2006/10/16 18:48:47 mrness Exp $
+
+*squid-2.6.4-r2 (16 Oct 2006)
+
+ 16 Oct 2006; Alin Nastac <mrness@gentoo.org> -squid-2.6.4-r1.ebuild,
+ +squid-2.6.4-r2.ebuild:
+ Remove /etc/squid/errors symlink (#151304).
*squid-2.6.4-r1 (07 Oct 2006)
diff --git a/net-proxy/squid/files/digest-squid-2.6.4-r2 b/net-proxy/squid/files/digest-squid-2.6.4-r2
new file mode 100644
index 000000000000..833e75cf798c
--- /dev/null
+++ b/net-proxy/squid/files/digest-squid-2.6.4-r2
@@ -0,0 +1,6 @@
+MD5 950ad860e6b07fb31744980319962abe squid-2.6.STABLE4-patches-20061016.tar.gz 7261
+RMD160 99571e719c8cffa77552967fdb788aa712a6d59f squid-2.6.STABLE4-patches-20061016.tar.gz 7261
+SHA256 9493ed808920b89d527c26309a0b94a17ea35ac0da2acf65cc91547cf9a151c6 squid-2.6.STABLE4-patches-20061016.tar.gz 7261
+MD5 b29affd7dd5b57ca4fdcfdb177c4e402 squid-2.6.STABLE4.tar.gz 1627562
+RMD160 98fbcb6c817b6f6cce9530b7dfdc1d81571eea89 squid-2.6.STABLE4.tar.gz 1627562
+SHA256 ab346a474c73a308a9589be49bae4139c8b158247cefe3ffd27d2301ba86c5d0 squid-2.6.STABLE4.tar.gz 1627562
diff --git a/net-proxy/squid/squid-2.6.4-r2.ebuild b/net-proxy/squid/squid-2.6.4-r2.ebuild
new file mode 100644
index 000000000000..654469a3ee82
--- /dev/null
+++ b/net-proxy/squid/squid-2.6.4-r2.ebuild
@@ -0,0 +1,201 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/squid-2.6.4-r2.ebuild,v 1.1 2006/10/16 18:48:47 mrness Exp $
+
+inherit eutils pam toolchain-funcs flag-o-matic autotools linux-info
+
+#lame archive versioning scheme..
+S_PV="${PV%.*}"
+S_PL="${PV##*.}"
+S_PL="${S_PL/_rc/-RC}"
+S_PP="${PN}-${S_PV}.STABLE${S_PL}"
+PATCH_VERSION="20061016"
+
+DESCRIPTION="A full-featured web proxy cache"
+HOMEPAGE="http://www.squid-cache.org/"
+SRC_URI="http://www.squid-cache.org/Versions/v2/${S_PV}/${S_PP}.tar.gz
+ mirror://gentoo/${S_PP}-patches-${PATCH_VERSION}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="pam ldap sasl nis ssl snmp selinux logrotate zero-penalty-hit \
+ pf-transparent ipf-transparent \
+ elibc_uclibc kernel_linux \
+ underscores customlog follow-xff" #Dead flags; should be removed when <squid-2.6.1 versions are removed
+
+RDEPEND="pam? ( virtual/pam )
+ ldap? ( >=net-nds/openldap-2.1.26 )
+ ssl? ( >=dev-libs/openssl-0.9.7j )
+ sasl? ( >=dev-libs/cyrus-sasl-2.1.21 )
+ selinux? ( sec-policy/selinux-squid )
+ !x86-fbsd? ( logrotate? ( app-admin/logrotate ) )
+ >=sys-libs/db-4"
+DEPEND="${RDEPEND} dev-lang/perl"
+
+S="${WORKDIR}/${S_PP}"
+
+pkg_setup() {
+ enewgroup squid 31
+ enewuser squid 31 -1 /var/cache/squid squid
+
+ use underscores && ewarn "underscores USE flag has no effect (the option is available through allow_underscore configuration directive)."
+ use customlog && ewarn "customlog USE flag has no effect (the correspondent patch has been included in the main version)."
+ use follow-xff && ewarn "follow-xff USE flag has no effect (the correspondent patch has been included in the main version)."
+}
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd "${S}" || die "dir ${S} not found"
+
+ # Do bulk patching from squids bug fix list as well as our patches
+ use zero-penalty-hit || rm "${WORKDIR}"/patch/9*ToS_Hit*
+ EPATCH_SUFFIX="patch"
+ epatch "${WORKDIR}/patch"
+
+ sed -i -e 's%LDFLAGS="-g"%LDFLAGS=""%' configure.in
+
+ #disable lazy bindings on (some at least) suided basic auth programs
+ sed -i -e '$aAM_LDFLAGS = '$(bindnow-flags) \
+ helpers/basic_auth/*/Makefile.am
+
+ eautoreconf
+}
+
+src_compile() {
+ local basic_modules="getpwnam,NCSA,SMB,MSNT,multi-domain-NTLM"
+ use ldap && basic_modules="LDAP,${basic_modules}"
+ use pam && basic_modules="PAM,${basic_modules}"
+ use sasl && basic_modules="SASL,${basic_modules}"
+ use nis && ! use elibc_uclibc && basic_modules="YP,${basic_modules}"
+
+ local ext_helpers="ip_user,session,unix_group,wbinfo_group"
+ use ldap && ext_helpers="ldap_group,${ext_helpers}"
+
+ local myconf=""
+
+ # Support for uclibc #61175
+ if use elibc_uclibc; then
+ myconf="${myconf} --enable-storeio=ufs,diskd,aufs,null"
+ myconf="${myconf} --disable-async-io"
+ else
+ myconf="${myconf} --enable-storeio=ufs,diskd,coss,aufs,null"
+ myconf="${myconf} --enable-async-io"
+ fi
+
+ if use kernel_linux; then
+ myconf="${myconf} --enable-linux-netfilter"
+ if kernel_is ge 2 6 ; then
+ myconf="${myconf} --enable-epoll"
+ fi
+ elif use kernel_FreeBSD || use kernel_OpenBSD || use kernel_NetBSD ; then
+ myconf="${myconf} --enable-kqueue"
+ if use pf-transparent; then
+ myconf="${myconf} --enable-pf-transparent"
+ elif use ipf-transparent; then
+ myconf="${myconf} --enable-ipf-transparent"
+ fi
+ fi
+
+ export CC=$(tc-getCC)
+
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --exec-prefix=/usr \
+ --sbindir=/usr/sbin \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/squid \
+ --libexecdir=/usr/lib/squid \
+ --datadir=/usr/share/squid \
+ --enable-auth="basic,digest,ntlm" \
+ --enable-removal-policies="lru,heap" \
+ --enable-digest-auth-helpers="password" \
+ --enable-basic-auth-helpers="${basic_modules}" \
+ --enable-external-acl-helpers="${ext_helpers}" \
+ --enable-ntlm-auth-helpers="SMB,fakeauth" \
+ --enable-ident-lookups \
+ --enable-useragent-log \
+ --enable-cache-digests \
+ --enable-delay-pools \
+ --enable-referer-log \
+ --enable-arp-acl \
+ --with-pthreads \
+ --with-large-files \
+ --enable-htcp \
+ --enable-carp \
+ --enable-follow-x-forwarded-for \
+ $(use_enable snmp) \
+ $(use_enable ssl) \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ sed -i -e "s:^#define SQUID_MAXFD.*:#define SQUID_MAXFD 8192:" \
+ include/autoconf.h
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ #need suid root for looking into /etc/shadow
+ fowners root:squid /usr/lib/squid/ncsa_auth
+ fowners root:squid /usr/lib/squid/pam_auth
+ fperms 4750 /usr/lib/squid/ncsa_auth
+ fperms 4750 /usr/lib/squid/pam_auth
+
+ #some clean ups
+ rm -f "${D}"/usr/bin/Run*
+
+ dodoc CONTRIBUTORS CREDITS ChangeLog QUICKSTART SPONSORS doc/*.txt \
+ helpers/ntlm_auth/no_check/README.no_check_ntlm_auth
+ newdoc helpers/basic_auth/SMB/README README.auth_smb
+ dohtml helpers/basic_auth/MSNT/README.html RELEASENOTES.html
+ newdoc helpers/basic_auth/LDAP/README README.auth_ldap
+ doman helpers/basic_auth/LDAP/*.8
+ dodoc helpers/basic_auth/SASL/squid_sasl_auth*
+
+ newpamd "${FILESDIR}/squid.pam" squid
+ newconfd "${FILESDIR}/squid.confd" squid
+ if use logrotate; then
+ newinitd "${FILESDIR}/squid.initd-logrotate" squid
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/squid.logrotate" squid
+ else
+ newinitd "${FILESDIR}/squid.initd" squid
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}/squid.cron" squid.cron
+ fi
+
+ rm -rf "${D}"/var
+ diropts -m0755 -o squid -g squid
+ keepdir /var/cache/squid /var/log/squid
+}
+
+pkg_preinst() {
+ enewgroup squid 31
+ enewuser squid 31 -1 /var/cache/squid squid
+
+ #Remove this after all versions prior to 2.6.4 has been removed from the tree
+ if [[ -L "${ROOT}/etc/squid/errors" ]]; then
+ rm "${ROOT}/etc/squid/errors"
+ fi
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Squid authentication helpers have been installed suid root."
+ ewarn "This allows shadow based authentication (see bug #52977 for more)."
+ echo
+ ewarn "Be careful what type of cache_dir you select!"
+ ewarn " 'diskd' is optimized for high levels of traffic, but it might seem slow"
+ ewarn "when there isn't sufficient traffic to keep squid reasonably busy."
+ ewarn " If your traffic level is low to moderate, use 'aufs' or 'ufs'."
+ echo
+ ewarn "/etc/squid/errors symlink has been removed from your system."
+ ewarn "Error templates can be customized through ${HILITE}error_directory${NORMAL} directive."
+ echo
+ ewarn "Squid can be configured to run in transparent mode like this:"
+ ewarn " ${HILITE}http_port internal-addr:3128 transparent${NORMAL}"
+}