summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2004-05-21 00:45:32 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2004-05-21 00:45:32 +0000
commitf8ddef207ae9aab2bcc8585f39437797535a5215 (patch)
treea92b8cebbca49a0d444485eb00506af5cd611677 /net-www/epiphany
parentfix deps, mark 0.9.2 x86 (diff)
downloadhistorical-f8ddef207ae9aab2bcc8585f39437797535a5215.tar.gz
historical-f8ddef207ae9aab2bcc8585f39437797535a5215.tar.bz2
historical-f8ddef207ae9aab2bcc8585f39437797535a5215.zip
Added patch to fix compilation with gcc-2. Removing old, unnecessary patches
Diffstat (limited to 'net-www/epiphany')
-rw-r--r--net-www/epiphany/ChangeLog6
-rw-r--r--net-www/epiphany/Manifest13
-rw-r--r--net-www/epiphany/epiphany-1.2.5.ebuild12
-rw-r--r--net-www/epiphany/files/epiphany-1.0-disable_Werror.patch16
-rw-r--r--net-www/epiphany/files/epiphany-1.0.1-session_get_windows-session.patch13
-rw-r--r--net-www/epiphany/files/epiphany-1.2.5-gcc2_fix.patch15
6 files changed, 36 insertions, 39 deletions
diff --git a/net-www/epiphany/ChangeLog b/net-www/epiphany/ChangeLog
index 680562294be4..0c9112670651 100644
--- a/net-www/epiphany/ChangeLog
+++ b/net-www/epiphany/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/epiphany
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/epiphany/ChangeLog,v 1.51 2004/05/04 12:09:15 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/epiphany/ChangeLog,v 1.52 2004/05/21 00:45:32 leonardop Exp $
+
+ 20 May 2004; L. Boshell <leonardop@gentoo.org> epiphany-1.2.5.ebuild,
+ files/epiphany-1.2.5-gcc2_fix.patch:
+ Added patch to fix compilation under gcc-2.
*epiphany-1.2.5 (04 May 2004)
diff --git a/net-www/epiphany/Manifest b/net-www/epiphany/Manifest
index ad523a347a4f..694225bd74ef 100644
--- a/net-www/epiphany/Manifest
+++ b/net-www/epiphany/Manifest
@@ -1,12 +1,11 @@
-MD5 ed1d809b26e100f0dcaff31d9fcea474 epiphany-1.0.7.ebuild 1229
-MD5 60d6b65c1944981a192242ad30f5a2fe epiphany-1.2.3.ebuild 1330
-MD5 2cc22853fd1800b00be1e23d1ed83c08 epiphany-1.2.5.ebuild 1330
+MD5 3498c4e2bfb7a94464fd79fd579845d3 ChangeLog 6861
MD5 3ea19642b57c52e99a14203fae2b6f95 epiphany-1.2.2.ebuild 1329
-MD5 3852b039d6359533f1c7f6c53708398b ChangeLog 6699
+MD5 60d6b65c1944981a192242ad30f5a2fe epiphany-1.2.3.ebuild 1330
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
-MD5 654a860f4c48d5a11c8fda09d91c6bf6 files/epiphany-1.0.1-session_get_windows-session.patch 528
-MD5 dd22fe99981a9507d5ad6db00f67eb17 files/epiphany-1.0-disable_Werror.patch 597
-MD5 5edb401fcdae44c283b7d8b7fbdeba84 files/digest-epiphany-1.0.7 68
+MD5 ef6a9a223ad312064b8c90780c578a89 epiphany-1.2.5.ebuild 1468
+MD5 ed1d809b26e100f0dcaff31d9fcea474 epiphany-1.0.7.ebuild 1229
MD5 a3d36d0b5e57c13bc93e3c3e0cedb08a files/digest-epiphany-1.2.2 68
MD5 1651ad3aab0f207db7e39a5601a5fa3e files/digest-epiphany-1.2.3 68
MD5 44b01636ae8eda75498104ec559c14bf files/digest-epiphany-1.2.5 68
+MD5 5edb401fcdae44c283b7d8b7fbdeba84 files/digest-epiphany-1.0.7 68
+MD5 771a6412c25bf38ed285c69e27f7cdcd files/epiphany-1.2.5-gcc2_fix.patch 539
diff --git a/net-www/epiphany/epiphany-1.2.5.ebuild b/net-www/epiphany/epiphany-1.2.5.ebuild
index cc4f50020c76..0cf67c6bbb72 100644
--- a/net-www/epiphany/epiphany-1.2.5.ebuild
+++ b/net-www/epiphany/epiphany-1.2.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/epiphany/epiphany-1.2.5.ebuild,v 1.1 2004/05/04 12:09:16 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/epiphany/epiphany-1.2.5.ebuild,v 1.2 2004/05/21 00:45:32 leonardop Exp $
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
HOMEPAGE="http://www.gnome.org/projects/epiphany/"
@@ -48,3 +48,11 @@ pkg_setup () {
fi
}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix C sources, so it compiles using gcc-2.
+ epatch ${FILESDIR}/${P}-gcc2_fix.patch
+}
diff --git a/net-www/epiphany/files/epiphany-1.0-disable_Werror.patch b/net-www/epiphany/files/epiphany-1.0-disable_Werror.patch
deleted file mode 100644
index d195ef437668..000000000000
--- a/net-www/epiphany/files/epiphany-1.0-disable_Werror.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -NurB epiphany-1.0-orig/configure epiphany-1.0/configure
---- epiphany-1.0-orig/configure 2003-10-04 11:16:56.000000000 -0500
-+++ epiphany-1.0/configure 2003-10-05 00:22:23.000000000 -0500
-@@ -20222,9 +20222,9 @@
- unset SAVE_CFLAGS
- done
- unset option
-- if test "$enable_compile_warnings" = "error" ; then
-- warning_flags="$warning_flags -Werror"
-- fi
-+# if test "$enable_compile_warnings" = "error" ; then
-+# warning_flags="$warning_flags -Werror"
-+# fi
- ;;
- *)
- { { echo "$as_me:$LINENO: error: Unknown argument '$enable_compile_warnings' to --enable-compile-warnings" >&5
diff --git a/net-www/epiphany/files/epiphany-1.0.1-session_get_windows-session.patch b/net-www/epiphany/files/epiphany-1.0.1-session_get_windows-session.patch
deleted file mode 100644
index b2230dec1767..000000000000
--- a/net-www/epiphany/files/epiphany-1.0.1-session_get_windows-session.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -u -p -r1.9.2.1 ephy-automation.c
---- src/ephy-automation.c 24 Sep 2003 20:39:52 -0000 1.9.2.1
-+++ src/ephy-automation.c 7 Oct 2003 18:50:41 -0000
-@@ -98,7 +98,8 @@ impl_ephy_automation_loadurl (PortableSe
- session = SESSION (ephy_shell_get_session (ephy_shell));
-
- /* no window open, let's try to autoresume */
-- if (session_get_windows (session) == NULL)
-+ if (session_get_windows (session) == NULL
-+ && ephy_shell_get_server_mode (ephy_shell) == FALSE)
- {
- gboolean res;
- res = session_autoresume (session);
diff --git a/net-www/epiphany/files/epiphany-1.2.5-gcc2_fix.patch b/net-www/epiphany/files/epiphany-1.2.5-gcc2_fix.patch
new file mode 100644
index 000000000000..41d237473214
--- /dev/null
+++ b/net-www/epiphany/files/epiphany-1.2.5-gcc2_fix.patch
@@ -0,0 +1,15 @@
+diff -NurdB epiphany-1.2.5-orig/lib/ephy-dialog.c epiphany-1.2.5/lib/ephy-dialog.c
+--- epiphany-1.2.5-orig/lib/ephy-dialog.c 2004-05-20 18:46:19.000000000 -0500
++++ epiphany-1.2.5/lib/ephy-dialog.c 2004-05-20 18:47:12.000000000 -0500
+@@ -584,9 +584,10 @@
+ }
+ else
+ {
++ char *v;
+ gtk_combo_box_set_active (GTK_COMBO_BOX (info->widget), -1);
+
+- char *v = g_strdup_value_contents (value);
++ v = g_strdup_value_contents (value);
+ g_warning ("Value '%s' not found in model for combo %s\n", v, info->id);
+ g_free (v);
+ }