summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-07-27 11:23:54 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-07-27 11:23:54 +0000
commit56d2153d542ba987dd26ab930c16ba53359377d0 (patch)
tree4210be188aa16c110081fd036903825df430950e /net-www/jetty
parentFix user/group additions re #58526. (diff)
downloadhistorical-56d2153d542ba987dd26ab930c16ba53359377d0.tar.gz
historical-56d2153d542ba987dd26ab930c16ba53359377d0.tar.bz2
historical-56d2153d542ba987dd26ab930c16ba53359377d0.zip
fix group/user add, add IUSE
Diffstat (limited to 'net-www/jetty')
-rw-r--r--net-www/jetty/ChangeLog5
-rw-r--r--net-www/jetty/Manifest14
-rw-r--r--net-www/jetty/jetty-4.2.19.ebuild26
3 files changed, 26 insertions, 19 deletions
diff --git a/net-www/jetty/ChangeLog b/net-www/jetty/ChangeLog
index 73f215e1245a..11f9ff28d89c 100644
--- a/net-www/jetty/ChangeLog
+++ b/net-www/jetty/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/jetty
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/jetty/ChangeLog,v 1.3 2004/06/25 00:56:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/jetty/ChangeLog,v 1.4 2004/07/27 11:23:54 axxo Exp $
+
+ 27 Jul 2004; Thomas Matthijs <axxo@gentoo.org> jetty-4.2.19.ebuild:
+ fix group/user add, add IUSE
*jetty-4.2.19 (31 Mar 2004)
diff --git a/net-www/jetty/Manifest b/net-www/jetty/Manifest
index 1eea3b852e89..5c3d2dc1f231 100644
--- a/net-www/jetty/Manifest
+++ b/net-www/jetty/Manifest
@@ -1,8 +1,18 @@
-MD5 def37ff374d0646d9ad8837bc78e8ed5 jetty-4.2.19.ebuild 3066
-MD5 435752924c9ad1f28406a83a52383f6e ChangeLog 784
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 0165aa0d9bdc5a681e58455c84a6074d jetty-4.2.19.ebuild 2693
+MD5 c18dfc0edbf583c91dc39a6c0395f208 ChangeLog 882
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 0395650cdf6ad11208dcddb344d31e7b files/digest-jetty-4.2.19 70
MD5 c06bb0261951f980b4c2609682d49972 files/4.2.19/21jetty 52
MD5 a381ae9ba82a2b10ea75e22acfafeedc files/4.2.19/jetty 948
MD5 0ab3a07453141d8fab987dcd1f0cfd9e files/4.2.19/jetty.conf 41
MD5 5c60daab6efd3ff566ca07e68c8f6556 files/4.2.19/jetty.init 1110
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.4 (GNU/Linux)
+
+iD8DBQFBBjuu/rLF9B432nYRAmHuAKDO9UZaA9udhje8twh82cunOp4F3wCdHvMR
+eKwrUoyl0zEXeY6l+btqUIw=
+=DvCU
+-----END PGP SIGNATURE-----
diff --git a/net-www/jetty/jetty-4.2.19.ebuild b/net-www/jetty/jetty-4.2.19.ebuild
index c1c9aea549bc..43dbebd5a034 100644
--- a/net-www/jetty/jetty-4.2.19.ebuild
+++ b/net-www/jetty/jetty-4.2.19.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/jetty/jetty-4.2.19.ebuild,v 1.2 2004/06/25 00:56:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/jetty/jetty-4.2.19.ebuild,v 1.3 2004/07/27 11:23:54 axxo Exp $
+
+inherit eutils
DESCRIPTION="A Lightweight Servlet Engine"
SRC_URI="http://dl.sourceforge.net/sourceforge/jetty/${PN/j/J}-${PV}-all.tar.gz"
@@ -10,22 +12,20 @@ LICENSE="Apache-1.1"
SLOT="0"
DEPEND=">=virtual/jdk-1.2
dev-java/ant"
+IUSE=""
S=${WORKDIR}/Jetty-${PV}
-pkg_setup() {
- if ! groupmod jetty ; then
- groupadd -g 365 jetty || die "problem adding group jetty, gid 365"
- fi
- if ! id jetty; then
- useradd -u 365 -g jetty -s /bin/bash -d /opt/jetty -c "Jetty Web Application Container" jetty || die "problem adding user jetty, uid 365"
- fi
+pkg_preinst() {
+ enewgroup jetty
+ enewuser jetty -1 /bin/bash /opt/jetty jetty
+ chown -R jetty:jetty ${D}
}
src_install() {
JETTY_HOME="/opt/jetty"
INSTALLING="yes"
- DIROPTIONS="--mode=0750 --owner=jetty --group=jetty"
+ diropts -m0750
# Create directories
dodir ${JETTY_HOME}
@@ -35,8 +35,6 @@ src_install() {
touch ${D}/var/log/${PN}/jetty.log
keepdir /var/log/${PN}
- cd ${S}
-
# INIT SCRIPTS AND ENV
insinto /etc/init.d
insopts -m0750
@@ -58,8 +56,6 @@ src_install() {
dohtml *.html
chmod u+x ${S}/bin/jetty.sh
- chown -R jetty:jetty ${S}
- DIROPTIONS="--mode=0750 --owner=jetty --group=jetty"
ant
cp -Rdp * ${D}/${JETTY_HOME}
@@ -92,7 +88,7 @@ pkg_postinst() {
einfo " "
einfo " NETWORK CONFIGURATION:"
einfo " By default, Jetty runs on port 8080. You can change this"
- einfo " value by setting ${JETTY_PORT} in /etc/conf.d/jetty ."
+ einfo " value by setting JETTY_PORT in /etc/conf.d/jetty ."
einfo " "
einfo " To test Jetty while it's running, point your web browser to:"
einfo " http://localhost:8080/"
@@ -101,6 +97,4 @@ pkg_postinst() {
einfo " Please file any bugs at http://bugs.gentoo.org/ or else it"
einfo " may not get seen. Thank you!"
einfo
- echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1 ; echo -ne "\a" ; sleep 1
- sleep 10
}