summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2005-01-08 23:21:48 +0000
committerBenedikt Boehm <hollow@gentoo.org>2005-01-08 23:21:48 +0000
commitf5e588a5d0074cc11b2d9fa2a3d0ee1bd35f843b (patch)
treec42acb52fb5c8a9f7f9e416086e591ae9752a543 /net-www/lingerd
parentStable on amd64. (diff)
downloadhistorical-f5e588a5d0074cc11b2d9fa2a3d0ee1bd35f843b.tar.gz
historical-f5e588a5d0074cc11b2d9fa2a3d0ee1bd35f843b.tar.bz2
historical-f5e588a5d0074cc11b2d9fa2a3d0ee1bd35f843b.zip
Initial import of lingerd
Diffstat (limited to 'net-www/lingerd')
-rw-r--r--net-www/lingerd/ChangeLog10
-rw-r--r--net-www/lingerd/Manifest15
-rw-r--r--net-www/lingerd/files/digest-lingerd-0.941
-rwxr-xr-xnet-www/lingerd/files/lingerd.rc28
-rw-r--r--net-www/lingerd/lingerd-0.94.ebuild31
-rw-r--r--net-www/lingerd/metadata.xml13
6 files changed, 98 insertions, 0 deletions
diff --git a/net-www/lingerd/ChangeLog b/net-www/lingerd/ChangeLog
new file mode 100644
index 000000000000..12bfb863faef
--- /dev/null
+++ b/net-www/lingerd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-www/lingerd
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/lingerd/ChangeLog,v 1.1 2005/01/08 23:21:48 hollow Exp $
+
+*lingerd-0.94 (09 Jan 2005)
+
+ 09 Jan 2005; Benedikt Boehm <hollow@gentoo.org> +metadata.xml,
+ +files/lingerd.rc, +lingerd-0.94.ebuild:
+ Initail import of lingerd
+
diff --git a/net-www/lingerd/Manifest b/net-www/lingerd/Manifest
new file mode 100644
index 000000000000..4977015ede41
--- /dev/null
+++ b/net-www/lingerd/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 a3b81b8b909e989133d67c69b4b4624e lingerd-0.94.ebuild 1036
+MD5 0455f43eb00baba59d88914dde12edb9 metadata.xml 443
+MD5 083073216ed3fe0ad3ae8b6c46ed4b5d ChangeLog 369
+MD5 e6acfa29750c53c7c2191ffa4c0047b8 files/lingerd.rc 610
+MD5 78caf28086b76c0e6708c31bbad10ade files/digest-lingerd-0.94 63
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFB4GsWmPFBzbX68WERAr93AJ44hrjmf1M8Y3P5RplWqEXhfoCjtwCcCyGY
+X+/r5EHzXXv7xP2jylSVf74=
+=/s1G
+-----END PGP SIGNATURE-----
diff --git a/net-www/lingerd/files/digest-lingerd-0.94 b/net-www/lingerd/files/digest-lingerd-0.94
new file mode 100644
index 000000000000..5fe61759284a
--- /dev/null
+++ b/net-www/lingerd/files/digest-lingerd-0.94
@@ -0,0 +1 @@
+MD5 6401015bafad4f44fdf8a9a1795d9258 lingerd-0.94.tar.gz 33938
diff --git a/net-www/lingerd/files/lingerd.rc b/net-www/lingerd/files/lingerd.rc
new file mode 100755
index 000000000000..f8bbb32114d0
--- /dev/null
+++ b/net-www/lingerd/files/lingerd.rc
@@ -0,0 +1,28 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/lingerd/files/lingerd.rc,v 1.1 2005/01/08 23:21:48 hollow Exp $
+
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting lingerd"
+ /sbin/start-stop-daemon -c apache -o --quiet --start --startas /usr/bin/lingerd --pidfile /var/run/lingerd/lingerd.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping lingerd"
+ start-stop-daemon -o --quiet --stop --pidfile /var/run/lingerd/lingerd.pid
+ eend $?
+}
+
+restart() {
+ ebegin "restarting"
+ svc_stop
+ svc_start
+
+}
diff --git a/net-www/lingerd/lingerd-0.94.ebuild b/net-www/lingerd/lingerd-0.94.ebuild
new file mode 100644
index 000000000000..8bc9431d7f85
--- /dev/null
+++ b/net-www/lingerd/lingerd-0.94.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/lingerd/lingerd-0.94.ebuild,v 1.1 2005/01/08 23:21:48 hollow Exp $
+
+inherit eutils
+
+DESCRIPTION="Lingerd is a daemon designed to take over the job of properly closing network connections from an http server"
+HOMEPAGE="http://www.iagora.com/about/software/lingerd/"
+SRC_URI="http://images.iagora.com/media/software/lingerd/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=sys-apps/sed-4"
+RDEPEND=""
+
+src_compile() {
+ sed -i -e "s/\(CFLAGS = -Wall \).*/\1 ${CFLAGS}/g" Makefile || die "Makefile fixing failed."
+ emake || die "Emake failed."
+}
+
+src_install() {
+ enewuser lingerd
+ exeinto ${D}/usr/bin/ ; doexe lingerd || die "Installation failed."
+ exeinto /etc/init.d ; newexe ${FILESDIR}/lingerd.rc lingerd
+ dodoc ChangeLog LICENSE README TUNING INSTALL TODO extra/lingerd.rc
+}
+
+pkg_postinst() {
+ install -m0770 -o lingerd -g apache -d ${ROOT}/var/run/lingerd/
+}
diff --git a/net-www/lingerd/metadata.xml b/net-www/lingerd/metadata.xml
new file mode 100644
index 000000000000..a3997de050a0
--- /dev/null
+++ b/net-www/lingerd/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>apache</herd>
+ <maintainer>
+ <email>hollow@gentoo.org</email>
+ <name>Benedikt Boehm</name>
+ </maintainer>
+ <longdescription>
+ Lingerd is a daemon (service) designed to take over the job of properly
+ closing network connections from an http server like Apache.
+ </longdescription>
+</pkgmetadata>