summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-25 08:42:51 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-25 08:42:51 +0000
commitdf276f1e85d0750d19bb4027f95a0b544a57ce8f (patch)
tree6374e6fe2517467f8ad2bd9d166ff924136cc700 /net-www/mod_ssl
parentSecurity update (diff)
downloadhistorical-df276f1e85d0750d19bb4027f95a0b544a57ce8f.tar.gz
historical-df276f1e85d0750d19bb4027f95a0b544a57ce8f.tar.bz2
historical-df276f1e85d0750d19bb4027f95a0b544a57ce8f.zip
Security update
Diffstat (limited to 'net-www/mod_ssl')
-rw-r--r--net-www/mod_ssl/ChangeLog7
-rw-r--r--net-www/mod_ssl/files/digest-mod_ssl-2.8.141
-rw-r--r--net-www/mod_ssl/mod_ssl-2.8.14.ebuild75
3 files changed, 82 insertions, 1 deletions
diff --git a/net-www/mod_ssl/ChangeLog b/net-www/mod_ssl/ChangeLog
index 695416c7efff..2fd029ecd860 100644
--- a/net-www/mod_ssl/ChangeLog
+++ b/net-www/mod_ssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mod_ssl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.13 2003/03/11 09:54:37 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.14 2003/03/25 08:42:51 aliz Exp $
+
+*mod_ssl-2.8.14 (25 Mar 2003)
+
+ 25 Mar 2003; Daniel Ahlberg <aliz@gentoo.org> mod_ssl-2.8.14.ebuild :
+ Security update.
*mod_ssl-2.8.12-r1 (21 Feb 2003)
diff --git a/net-www/mod_ssl/files/digest-mod_ssl-2.8.14 b/net-www/mod_ssl/files/digest-mod_ssl-2.8.14
new file mode 100644
index 000000000000..16d27c842461
--- /dev/null
+++ b/net-www/mod_ssl/files/digest-mod_ssl-2.8.14
@@ -0,0 +1 @@
+MD5 8ba44e6ad3701f445b0f86f17f24ff1c mod_ssl-2.8.14-1.3.27.tar.gz 754179
diff --git a/net-www/mod_ssl/mod_ssl-2.8.14.ebuild b/net-www/mod_ssl/mod_ssl-2.8.14.ebuild
new file mode 100644
index 000000000000..7bd601a3b6a3
--- /dev/null
+++ b/net-www/mod_ssl/mod_ssl-2.8.14.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.14.ebuild,v 1.1 2003/03/25 08:42:51 aliz Exp $
+
+MY_P=${P}-1.3.27
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An SSL module for the Apache Web server"
+SRC_URI="http://www.modssl.org/source/${MY_P}.tar.gz"
+HOMEPAGE="http://www.modssl.org/"
+
+KEYWORDS="x86 ppc sparc"
+LICENSE="as-is"
+SLOT="0"
+
+DEPEND="=net-www/apache-1.3.27*
+ >=dev-libs/openssl-0.9.6i"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ # proper path to openssl
+ cp pkg.contrib/cca.sh pkg.contrib/cca.sh.orig
+ sed -e 's%^\(openssl=\).*%\1"/usr/bin/openssl"%' \
+ pkg.contrib/cca.sh.orig > pkg.contrib/cca.sh
+}
+
+src_compile() {
+ SSL_BASE=SYSTEM \
+ ./configure \
+ --with-apxs=/usr/sbin/apxs || die "bad ./configure"
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe pkg.sslmod/libssl.so
+
+ exeinto /usr/lib/ssl/mod_ssl
+ doexe pkg.contrib/*.sh ${FILESDIR}/gentestcrt.sh
+
+ dodoc ANNOUNCE CHANGES CREDITS LICENSE NEWS README*
+ dodir /usr/share/doc/${PF}/html
+ cp -a pkg.ssldoc/* ${D}/usr/share/doc/${PF}/html
+
+ insinto /etc/apache/conf/vhosts
+ doins ${FILESDIR}/ssl.default-vhost.conf
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_ssl.conf
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}/etc/apache/conf/ssl
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+
+ cd ${ROOT}/etc/apache/conf/ssl
+ einfo "Generating self-signed test certificate in /etc/apache/conf/ssl..."
+ einfo "(Ignore any message from the yes command below)"
+ yes "" | ${ROOT}/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libssl.so mod_ssl.c ssl_module \
+ define=SSL addconf=conf/addon-modules/mod_ssl.conf
+
+ echo "Include conf/vhosts/ssl.default-vhost.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}