summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-07-28 06:58:38 +0000
committerTravis Tilley <lv@gentoo.org>2004-07-28 06:58:38 +0000
commit8e73f09981a6ed14a73d6fc5e4331bd276b1e419 (patch)
tree5da87e1b6383bcf7a29093cfa4624de221353993 /net-www/mozilla-firefox
parentversion bump. 0.4.0 - x86 stable. Removed old version. (diff)
downloadhistorical-8e73f09981a6ed14a73d6fc5e4331bd276b1e419.tar.gz
historical-8e73f09981a6ed14a73d6fc5e4331bd276b1e419.tar.bz2
historical-8e73f09981a6ed14a73d6fc5e4331bd276b1e419.zip
added a patch that fixes a 64bit specific autocomplete crash
Diffstat (limited to 'net-www/mozilla-firefox')
-rw-r--r--net-www/mozilla-firefox/ChangeLog7
-rw-r--r--net-www/mozilla-firefox/Manifest5
-rw-r--r--net-www/mozilla-firefox/files/firefox-0.9-nsFormHistory-crash-fix.patch47
-rw-r--r--net-www/mozilla-firefox/mozilla-firefox-0.9.1.ebuild6
4 files changed, 61 insertions, 4 deletions
diff --git a/net-www/mozilla-firefox/ChangeLog b/net-www/mozilla-firefox/ChangeLog
index 2c1757544028..097b79d20a19 100644
--- a/net-www/mozilla-firefox/ChangeLog
+++ b/net-www/mozilla-firefox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mozilla-firefox
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/ChangeLog,v 1.51 2004/07/20 01:39:33 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/ChangeLog,v 1.52 2004/07/28 06:58:38 lv Exp $
+
+ 28 Jul 2004; Travis Tilley <lv@gentoo.org>
+ +files/firefox-0.9-nsFormHistory-crash-fix.patch,
+ mozilla-firefox-0.9.1.ebuild:
+ added a patch that fixes a 64bit specific autocomplete crash
19 Jul 2004; Travis Tilley <lv@gentoo.org> mozilla-firefox-0.9.1.ebuild:
stable on amd64
diff --git a/net-www/mozilla-firefox/Manifest b/net-www/mozilla-firefox/Manifest
index 0f57258dae90..88941b6565ea 100644
--- a/net-www/mozilla-firefox/Manifest
+++ b/net-www/mozilla-firefox/Manifest
@@ -1,10 +1,10 @@
MD5 11a0a5bb21851599257dc48c0f75317a mozilla-firefox-0.8-r2.ebuild 7677
MD5 0d0bdb8c4e8c6d313d1339df8b0fa470 mozilla-firefox-0.8.ebuild 7612
MD5 6fe90dc338e4ce020ff74f8e8fe4d6d6 mozilla-firefox-0.9-r1.ebuild 8329
-MD5 458043abad748e2e5cc9745e15a5c760 mozilla-firefox-0.9.1.ebuild 8280
+MD5 541045c35a0600f8a5a0c17717922548 mozilla-firefox-0.9.1.ebuild 8435
MD5 8ca554fa1450efa9320081ac5c262ca6 mozilla-firefox-0.8-r1.ebuild 7586
MD5 c6223762b8c3591c36a7ecc3c08e77e4 mozilla-firefox-0.8-r3.ebuild 8512
-MD5 89c2958ac9f2663113aaeaaf4f58ce21 ChangeLog 8741
+MD5 c8adde20106e6cb1947120cf144e8dc8 ChangeLog 8934
MD5 ce23390351fe8020387d93ee29e09a3d metadata.xml 160
MD5 507a3d1338e85acc8828cec7c91d22df files/digest-mozilla-firefox-0.8 73
MD5 91fb197b04b4e0d536270123dbd5ae04 files/digest-mozilla-firefox-0.9.1 75
@@ -19,5 +19,6 @@ MD5 507a3d1338e85acc8828cec7c91d22df files/digest-mozilla-firefox-0.8-r3 73
MD5 1616bcd357c0cbe601722dd6279bd21f files/digest-mozilla-firefox-0.9-r1 73
MD5 3ad7410bd680964096c84eee3fa21abf files/firefox-0.8-gcc-3.4.patch 460
MD5 f0e9adeb0454377ce019e8969e644efb files/mozilla-firebird-amd64.patch 35052
+MD5 c6308c086c87ed2e1e4f3d136efdd770 files/firefox-0.9-nsFormHistory-crash-fix.patch 1755
MD5 2cdd03eb2752bc01ba07ad837e926f39 files/icon/mozillafirefox.desktop 168
MD5 bff260036c5dcca45da3218517fb33d8 files/icon/firefox-icon.png 3979
diff --git a/net-www/mozilla-firefox/files/firefox-0.9-nsFormHistory-crash-fix.patch b/net-www/mozilla-firefox/files/firefox-0.9-nsFormHistory-crash-fix.patch
new file mode 100644
index 000000000000..afd4e1691689
--- /dev/null
+++ b/net-www/mozilla-firefox/files/firefox-0.9-nsFormHistory-crash-fix.patch
@@ -0,0 +1,47 @@
+Index: toolkit/components/satchel/src/nsFormHistory.cpp
+===================================================================
+RCS file: /cvsroot/mozilla/toolkit/components/satchel/src/nsFormHistory.cpp,v
+retrieving revision 1.13
+diff -u -9 -p -w -r1.13 nsFormHistory.cpp
+--- toolkit/components/satchel/src/nsFormHistory.cpp 17 Jun 2004 00:13:16 -0000 1.13
++++ toolkit/components/satchel/src/nsFormHistory.cpp 24 Jun 2004 06:56:29 -0000
+@@ -734,35 +734,38 @@ nsFormHistory::AutoCompleteSearch(const
+ if (RowMatch(row, aInputName, aInputValue, &value)) {
+ matchingRows.AppendElement(row);
+ matchingValues.AppendElement(value);
+ }
+ } while (row);
+
+ // Turn auto array into flat array for quick sort, now that we
+ // know how many items there are
+ PRUint32 count = matchingRows.Count();
++
++ if (count > 0) {
+ PRUint32* items = new PRUint32[count];
+ PRUint32 i;
+ for (i = 0; i < count; ++i)
+ items[i] = i;
+
+- NS_QuickSort(items, count, sizeof(nsIMdbRow*),
++ NS_QuickSort(items, count, sizeof(PRUint32),
+ SortComparison, &matchingValues);
+
+ for (i = 0; i < count; ++i) {
+ // Place the sorted result into the autocomplete result
+ result->AddRow((nsIMdbRow *)matchingRows[items[i]]);
+
+ // Free up these strings we owned.
+ delete (PRUnichar *) matchingValues[i];
+ }
+
+ delete[] items;
++ }
+
+ PRUint32 matchCount;
+ result->GetMatchCount(&matchCount);
+ if (matchCount > 0) {
+ result->SetSearchResult(nsIAutoCompleteResult::RESULT_SUCCESS);
+ result->SetDefaultIndex(0);
+ } else {
+ result->SetSearchResult(nsIAutoCompleteResult::RESULT_NOMATCH);
+ result->SetDefaultIndex(-1);
diff --git a/net-www/mozilla-firefox/mozilla-firefox-0.9.1.ebuild b/net-www/mozilla-firefox/mozilla-firefox-0.9.1.ebuild
index 5374ca1d38bf..64cc46f2ed22 100644
--- a/net-www/mozilla-firefox/mozilla-firefox-0.9.1.ebuild
+++ b/net-www/mozilla-firefox/mozilla-firefox-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/mozilla-firefox-0.9.1.ebuild,v 1.5 2004/07/20 01:39:33 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/mozilla-firefox-0.9.1.ebuild,v 1.6 2004/07/28 06:58:38 lv Exp $
inherit makeedit flag-o-matic gcc nsplugins eutils mozilla-launcher
@@ -51,6 +51,10 @@ src_unpack() {
# alpha stubs patch from lfs project.
# <taviso@gentoo.org> (26 Jun 2003)
use alpha && epatch ${FILESDIR}/mozilla-1.3-alpha-stubs.patch
+
+ # this patch fixes upstream bug 248442 "Crash in form autocomplete
+ # (64-bit arch only)".
+ epatch ${FILESDIR}/firefox-0.9-nsFormHistory-crash-fix.patch
}
src_compile() {