summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-02-16 16:53:51 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-02-16 16:53:51 +0000
commit9cb9dba059f3fe242754d4857de6d6d5c98e5ece (patch)
tree059e22b3ac4fb4a5e31ed1bcee5e2f77cfee0392 /net-www/mplayerplug-in
parentAdded mips to keywords (diff)
downloadhistorical-9cb9dba059f3fe242754d4857de6d6d5c98e5ece.tar.gz
historical-9cb9dba059f3fe242754d4857de6d6d5c98e5ece.tar.bz2
historical-9cb9dba059f3fe242754d4857de6d6d5c98e5ece.zip
new package
Diffstat (limited to 'net-www/mplayerplug-in')
-rw-r--r--net-www/mplayerplug-in/ChangeLog10
-rw-r--r--net-www/mplayerplug-in/files/digest-mplayerplug-in-0.402
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-0.40.ebuild53
3 files changed, 65 insertions, 0 deletions
diff --git a/net-www/mplayerplug-in/ChangeLog b/net-www/mplayerplug-in/ChangeLog
new file mode 100644
index 000000000000..f4a0e4ad38ca
--- /dev/null
+++ b/net-www/mplayerplug-in/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-www/mplayerplug-in
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.1 2003/02/16 16:53:51 azarah Exp $
+
+*mplayerplug-in-0.40 (16 Feb 2003)
+
+ 16 Feb 2003; Martin Schlemmer <azarah@gentoo.org> mplayerplug-in-0.40.ebuild :
+ Initial ebuild, thanks to Bret Towe <btowe@gbis.com> and
+ Alastair Tse <liquidx@gentoo.org>, bug #14954.
+
diff --git a/net-www/mplayerplug-in/files/digest-mplayerplug-in-0.40 b/net-www/mplayerplug-in/files/digest-mplayerplug-in-0.40
new file mode 100644
index 000000000000..5923695eedf6
--- /dev/null
+++ b/net-www/mplayerplug-in/files/digest-mplayerplug-in-0.40
@@ -0,0 +1,2 @@
+MD5 45378ac240c9aff7aec25ad30f49ae60 mplayerplug-in_v0.40.tar.gz 33276
+MD5 88ffb4b41928f5b063800bab46be1545 mini.tar.bz2 5775
diff --git a/net-www/mplayerplug-in/mplayerplug-in-0.40.ebuild b/net-www/mplayerplug-in/mplayerplug-in-0.40.ebuild
new file mode 100644
index 000000000000..3d565af220ae
--- /dev/null
+++ b/net-www/mplayerplug-in/mplayerplug-in-0.40.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-0.40.ebuild,v 1.1 2003/02/16 16:53:51 azarah Exp $
+
+IUSE=""
+
+inherit nsplugins
+
+S="${WORKDIR}/mplayerplug-in"
+HOMEPAGE="http://mplayerplug-in.sourceforge.net/"
+DESCRIPTION="mplayer plug-in for Mozilla"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_v${PV}.tar.gz
+ mirror://sourceforge/${PN}/mini.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=media-video/mplayer-0.90_rc4"
+
+src_compile() {
+ emake CC="${CC}" OPTIMIZER="${CFLAGS}" || die
+}
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe mplayerplug-in.so
+
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.so
+
+ insinto /usr/share/mplayer/Skin/mini
+ doins ${WORKDIR}/mini/*
+
+ dodir /etc
+ # For some reason this does not work yet for mplayer options, and
+ # setting 'vo' cause it for 'mozilla file:///space/movies/foo.avi'
+ # at least to not work...
+ cat > ${D}/etc/mplayerplug-in.conf <<END
+# Should it handle embedded movies ?
+noembed=0
+
+# Set to 'mini' if you want the seek bar
+use-gui=no
+
+# Normal mplayer style config options
+#vo=x11
+fs=no
+zoom=yes
+END
+
+ dodoc TODO ChangeLog INSTALL README
+}
+