summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Maitin-Shepard <jbms@gentoo.org>2004-07-22 01:33:02 +0000
committerJeremy Maitin-Shepard <jbms@gentoo.org>2004-07-22 01:33:02 +0000
commite5c9c98aa05001feecddfdb845ba8327c6d9447a (patch)
tree1574e71aea3e4a8c01efa752a0d0c2b1b4baf87a /net-www/mplayerplug-in
parentMarked stable on x86. (diff)
downloadhistorical-e5c9c98aa05001feecddfdb845ba8327c6d9447a.tar.gz
historical-e5c9c98aa05001feecddfdb845ba8327c6d9447a.tar.bz2
historical-e5c9c98aa05001feecddfdb845ba8327c6d9447a.zip
Adding GTK1 support
Diffstat (limited to 'net-www/mplayerplug-in')
-rw-r--r--net-www/mplayerplug-in/ChangeLog7
-rw-r--r--net-www/mplayerplug-in/Manifest4
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-2.66.ebuild23
3 files changed, 27 insertions, 7 deletions
diff --git a/net-www/mplayerplug-in/ChangeLog b/net-www/mplayerplug-in/ChangeLog
index 844614924fd1..efc8a715db96 100644
--- a/net-www/mplayerplug-in/ChangeLog
+++ b/net-www/mplayerplug-in/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mplayerplug-in
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.25 2004/06/25 01:06:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.26 2004/07/22 01:33:02 jbms Exp $
+
+ 18 Jul 2004; Jeremy Maitin-Shepard <jbms@gentoo.org>
+ mplayerplug-in-2.66.ebuild:
+ Added support for GTK1, so that the plugin works with mozilla browsers built
+ against GTK1
*mplayerplug-in-2.66 (20 Jun 2004)
diff --git a/net-www/mplayerplug-in/Manifest b/net-www/mplayerplug-in/Manifest
index b2355df59cf9..cd2f67b76967 100644
--- a/net-www/mplayerplug-in/Manifest
+++ b/net-www/mplayerplug-in/Manifest
@@ -1,4 +1,4 @@
-MD5 692cf4b4f2f341e628eca30c3b81d900 mplayerplug-in-2.66.ebuild 1037
+MD5 2f65845b955bd57fb4c1462c43fd2096 mplayerplug-in-2.66.ebuild 1386
MD5 a62d53b7787e09dfee7c0ea35ef42747 mplayerplug-in-1.0_pre2.ebuild 1419
MD5 bfbcd77d675f2db1d480573f28368578 mplayerplug-in-1.0.ebuild 1368
MD5 75f86d3f31f1ec856017b6f167d4c0d4 mplayerplug-in-2.11.ebuild 1368
@@ -6,7 +6,7 @@ MD5 8f08ca195218dcbe5f71b5b3b23f2c37 mplayerplug-in-0.91.ebuild 1362
MD5 5b06333343f3765e144bfbc7f2125be1 mplayerplug-in-1.2.ebuild 1388
MD5 9bcd076a04560d24fe626c8dc38a0dbd mplayerplug-in-2.60.ebuild 1037
MD5 1e40d68e8d680e5a2ab097e9d653695d mplayerplug-in-0.95.ebuild 1383
-MD5 9ed28451ff379d664e054e0bfe6562cc ChangeLog 4266
+MD5 f9c8c5e51cd631ea60385bb2d72b895e ChangeLog 4442
MD5 febfcafa02fda49df53d2748a7c792ef metadata.xml 223
MD5 b754add73c488595bc984c5af2ef035a files/digest-mplayerplug-in-0.91 125
MD5 efaa2a17874e95270fe36e6ed5177084 files/digest-mplayerplug-in-0.95 125
diff --git a/net-www/mplayerplug-in/mplayerplug-in-2.66.ebuild b/net-www/mplayerplug-in/mplayerplug-in-2.66.ebuild
index ebb599f2d0cb..ae6b561496bf 100644
--- a/net-www/mplayerplug-in/mplayerplug-in-2.66.ebuild
+++ b/net-www/mplayerplug-in/mplayerplug-in-2.66.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-2.66.ebuild,v 1.2 2004/06/25 01:06:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-2.66.ebuild,v 1.3 2004/07/22 01:33:02 jbms Exp $
inherit nsplugins
@@ -15,13 +15,28 @@ HOMEPAGE="http://mplayerplug-in.sourceforge.net/"
KEYWORDS="~x86 ~amd64 ~ia64 ~ppc ~sparc ~alpha ~hppa ~mips"
SLOT="0"
LICENSE="GPL-2"
-IUSE=""
-
-DEPEND=">=media-video/mplayer-0.92"
+IUSE="gtk2"
+
+DEPEND=">=media-video/mplayer-0.92
+ gtk2? (
+ >=x11-libs/gtk+-2.2.0
+ dev-libs/atk
+ >=dev-libs/glib-2.2.0
+ >=x11-libs/pango-1.2.1 )
+ !gtk2? (
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2* )"
src_compile() {
local myconf
use x86 && myconf="${myconf} --with-gecko-sdk=${WORKDIR}/gecko-sdk"
+ if use gtk2; then
+ einfo Configuring to build using gtk2
+ myconf="${myconf} --enable-gtk2"
+ else
+ einfo Configuring to build using gtk1
+ myconf="${myconf} --disable-gtk2 --enable-gtk1"
+ fi
econf ${myconf} || die
emake || die
}