summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-04-23 16:50:38 +0000
committerStuart Herbert <stuart@gentoo.org>2004-04-23 16:50:38 +0000
commit717d2ff8e9835bf360629c935f2be00c719a7001 (patch)
tree4973a71183f34d9b298de91d1615d6ef0ae2885a /net-www/pound
parentStable x86. (diff)
downloadhistorical-717d2ff8e9835bf360629c935f2be00c719a7001.tar.gz
historical-717d2ff8e9835bf360629c935f2be00c719a7001.tar.bz2
historical-717d2ff8e9835bf360629c935f2be00c719a7001.zip
Version bump
Diffstat (limited to 'net-www/pound')
-rw-r--r--net-www/pound/ChangeLog7
-rw-r--r--net-www/pound/Manifest16
-rw-r--r--net-www/pound/files/digest-pound-1.71
-rw-r--r--net-www/pound/pound-1.7.ebuild48
4 files changed, 64 insertions, 8 deletions
diff --git a/net-www/pound/ChangeLog b/net-www/pound/ChangeLog
index 3b7d7f6be644..ee8e462cdbad 100644
--- a/net-www/pound/ChangeLog
+++ b/net-www/pound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/pound
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/pound/ChangeLog,v 1.4 2004/01/27 19:12:41 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/pound/ChangeLog,v 1.5 2004/04/23 16:50:38 stuart Exp $
+
+*pound-1.7 (23 Apr 2004)
+
+ 23 Apr 2004; Stuart Herbert <stuart@gentoo.org> pound-1.7.ebuild:
+ Version bump; added 'msdav' and 'unsafe' local USE flags; see bug #45615
*pound-1.6 (27 Jan 2004)
diff --git a/net-www/pound/Manifest b/net-www/pound/Manifest
index df9651ba5417..f35864a71462 100644
--- a/net-www/pound/Manifest
+++ b/net-www/pound/Manifest
@@ -1,10 +1,12 @@
+MD5 c2dc68d0ddb56dd61ff66697d50df3f4 pound-1.5.ebuild 1372
+MD5 4ae3fa54844e91ce95b6e63c7792a547 pound-1.4.ebuild 1372
+MD5 82f56f90a2669fb79b3828e1be44e521 ChangeLog 851
+MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
+MD5 d2c22a9c0f6b7aef3bf430ea71cbafef pound-1.6.ebuild 1373
+MD5 26ec4db0be2f5b23f384303a0e2d2dc9 pound-1.7.ebuild 1156
+MD5 eb402b9c286514bc8e89e6d1b8dda8a4 files/pound.init 622
MD5 ea7096804d2dc2e498de690fa440821d files/digest-pound-1.4 58
MD5 bc58884d636c60affb0267730438d6d9 files/digest-pound-1.5 58
-MD5 4c7b6277bb33061b615ac9059c74cf62 files/pound.cfg 830
-MD5 eb402b9c286514bc8e89e6d1b8dda8a4 files/pound.init 622
MD5 0b2e14a1793d6e6393cf13f015c58a7e files/digest-pound-1.6 58
-MD5 ed1c79ea1cdf7c1eb9d99a3d776b8ab7 ChangeLog 682
-MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
-MD5 4ae3fa54844e91ce95b6e63c7792a547 pound-1.4.ebuild 1372
-MD5 c2dc68d0ddb56dd61ff66697d50df3f4 pound-1.5.ebuild 1372
-MD5 d2c22a9c0f6b7aef3bf430ea71cbafef pound-1.6.ebuild 1373
+MD5 4c7b6277bb33061b615ac9059c74cf62 files/pound.cfg 830
+MD5 a5bfd8880ab9b367f5333083252548db files/digest-pound-1.7 58
diff --git a/net-www/pound/files/digest-pound-1.7 b/net-www/pound/files/digest-pound-1.7
new file mode 100644
index 000000000000..3f77eb1bdeda
--- /dev/null
+++ b/net-www/pound/files/digest-pound-1.7
@@ -0,0 +1 @@
+MD5 ebd15a0ff4a1920a857239630c33e8f5 Pound-1.7.tgz 132879
diff --git a/net-www/pound/pound-1.7.ebuild b/net-www/pound/pound-1.7.ebuild
new file mode 100644
index 000000000000..10e606419a9b
--- /dev/null
+++ b/net-www/pound/pound-1.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/pound/pound-1.7.ebuild,v 1.1 2004/04/23 16:50:38 stuart Exp $
+
+MY_P=${P/p/P}
+
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+HOMEPAGE="http://www.apsis.ch/pound/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+IUSE="ssl msdav unsafe"
+
+DEPEND="virtual/glibc
+ ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf
+
+ ## check for ssl-support:
+ myconf="${myconf} `use_with ssl` `use_enable msdav` `use_enable unsafe`"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ dosbin pound
+ doman pound.8
+
+ dodoc README
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pound.init pound
+
+ insinto /etc
+ doins ${FILESDIR}/pound.cfg
+}
+
+pkg_postinst() {
+ einfo "No demo-/sample-configfile is included in the distribution -- read the man-page"
+ einfo "for more info."
+ einfo "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+}