summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-12-14 18:46:28 +0000
committerDan Armak <danarmak@gentoo.org>2002-12-14 18:46:28 +0000
commit43aac399f5ecca57b17edd05e5fac910b1252220 (patch)
tree42e386604cf9e17ab598eef7efd9a4d207b3c66b /net-www/wwwoffle
parentVersion bump, major security fix. (diff)
downloadhistorical-43aac399f5ecca57b17edd05e5fac910b1252220.tar.gz
historical-43aac399f5ecca57b17edd05e5fac910b1252220.tar.bz2
historical-43aac399f5ecca57b17edd05e5fac910b1252220.zip
new version
Diffstat (limited to 'net-www/wwwoffle')
-rw-r--r--net-www/wwwoffle/ChangeLog10
-rw-r--r--net-www/wwwoffle/files/digest-wwwoffle-2.7g1
-rw-r--r--net-www/wwwoffle/wwwoffle-2.7g.ebuild72
3 files changed, 81 insertions, 2 deletions
diff --git a/net-www/wwwoffle/ChangeLog b/net-www/wwwoffle/ChangeLog
index 81b4021df646..629e63487c96 100644
--- a/net-www/wwwoffle/ChangeLog
+++ b/net-www/wwwoffle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/wwwoffle
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/wwwoffle/ChangeLog,v 1.9 2002/12/13 11:00:28 blizzy Exp $
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/wwwoffle/ChangeLog,v 1.10 2002/12/14 18:46:28 danarmak Exp $
+
+*wwwoffle-2.7g (14 Dec 2002)
+
+ 14 Dec 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ New upstream vesrion.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-www/wwwoffle/files/digest-wwwoffle-2.7g b/net-www/wwwoffle/files/digest-wwwoffle-2.7g
new file mode 100644
index 000000000000..e6df953ccfd0
--- /dev/null
+++ b/net-www/wwwoffle/files/digest-wwwoffle-2.7g
@@ -0,0 +1 @@
+MD5 94e4d0afb06635b7b25449b0c1957c58 wwwoffle-2.7g.tgz 888577
diff --git a/net-www/wwwoffle/wwwoffle-2.7g.ebuild b/net-www/wwwoffle/wwwoffle-2.7g.ebuild
new file mode 100644
index 000000000000..e63fcd2e890d
--- /dev/null
+++ b/net-www/wwwoffle/wwwoffle-2.7g.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/wwwoffle/wwwoffle-2.7g.ebuild,v 1.1 2002/12/14 18:46:28 danarmak Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="wwwoffle = WWW Offline Explorer, an adv. caching proxy especially suitable for nonpermanent (e.g. dialup) Internet connections"
+
+SRC_URI="ftp://ftp.demon.co.uk/pub/unix/httpd/${P}.tgz
+ ftp://metalab.unc.edu/pub/Linux/apps/www/servers/${P}.tgz"
+
+HOMEPAGE="http://www.gedanken.demon.co.uk/"
+KEYWORDS="x86 ~sparc "
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/flex
+ sys-libs/zlib
+ sys-devel/gcc
+ virtual/glibc"
+
+
+src_compile() {
+
+ local myconf
+ use ipv6 && myconf="$myconf --with-ipv6" || myconf="$myconf --without-ipv6"
+ ./configure $myconf --prefix=/usr --with-confdir=/etc || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ # Install the files
+ make prefix=${D}/usr SPOOLDIR=${D}/var/spool/wwwoffle CONFDIR=${D}/etc install || die
+
+ cd ${D}/etc
+ mv wwwoffle.conf 1
+ sed -e "s:${D}::" 1 > wwwoffle.conf
+ rm 1
+
+ # Install the wwwoffled init script
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/{wwwoffled-online,wwwoffled}
+
+ # someday i'll make it use the file in /etc. for now we at least get
+ # config file protection this way.
+ dosym /etc/wwwoffle.conf /var/spool/wwwoffle/wwwoffle.conf
+
+}
+
+pkg_preinst() {
+
+ source /etc/init.d/functions.sh
+ if [ -L ${svcdir}/started/wwwoffled ]; then
+ einfo "The wwwoffled init script is running. I'll stop it, merge the new files and
+restart the script."
+ /etc/init.d/wwwoffled stop
+ touch ${T}/restart
+ fi
+
+}
+
+pkg_postinst() {
+
+ if [ -f "${T}/restart" ]; then
+ einfo "Starting the wwwoffled initscript again..."
+ /etc/init.d/wwwoffled start
+ rm ${T}/restart
+ fi
+}