summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-12 18:25:26 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-12 18:25:26 +0000
commit89903b5d32c8f89d5c694fffc420907bfc690bb1 (patch)
treef66ec24c6f9d1a53d04f03543cda482c449c8948 /net-zope/extensionclass
parentUse mirror://gnu in SRC_URI (diff)
downloadhistorical-89903b5d32c8f89d5c694fffc420907bfc690bb1.tar.gz
historical-89903b5d32c8f89d5c694fffc420907bfc690bb1.tar.bz2
historical-89903b5d32c8f89d5c694fffc420907bfc690bb1.zip
Version bump.
Package-Manager: portage-15821-svn/cvs/Linux x86_64
Diffstat (limited to 'net-zope/extensionclass')
-rw-r--r--net-zope/extensionclass/ChangeLog8
-rw-r--r--net-zope/extensionclass/extensionclass-2.13.0.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/net-zope/extensionclass/ChangeLog b/net-zope/extensionclass/ChangeLog
index 93f9e36933f3..f34179ceff41 100644
--- a/net-zope/extensionclass/ChangeLog
+++ b/net-zope/extensionclass/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/extensionclass
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/extensionclass/ChangeLog,v 1.6 2010/02/22 11:12:50 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/extensionclass/ChangeLog,v 1.7 2010/03/12 18:16:36 arfrever Exp $
+
+*extensionclass-2.13.0 (12 Mar 2010)
+
+ 12 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -extensionclass-2.12.0.ebuild, +extensionclass-2.13.0.ebuild:
+ Version bump.
*extensionclass-2.12.0 (22 Feb 2010)
diff --git a/net-zope/extensionclass/extensionclass-2.13.0.ebuild b/net-zope/extensionclass/extensionclass-2.13.0.ebuild
new file mode 100644
index 000000000000..eba2fbd20963
--- /dev/null
+++ b/net-zope/extensionclass/extensionclass-2.13.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/extensionclass/extensionclass-2.13.0.ebuild,v 1.1 2010/03/12 18:16:36 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="ExtensionClass"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Metaclass for subclassable extension types"
+HOMEPAGE="http://pypi.python.org/pypi/ExtensionClass"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+DEPEND="app-arch/unzip
+ test? ( net-zope/zope-testing )"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="ComputedAttribute ExtensionClass MethodObject"
+DOCS="CHANGES.txt README.txt"
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in ComputedAttribute ExtensionClass MethodObject; do
+ ln -fs "../../$(ls -d build-${PYTHON_ABI}/lib.*)/${module}/_${module}.so" "src/${module}/_${module}.so" || die "Symlinking ${module}/_${module}.so failed with Python ${PYTHON_ABI}"
+ done
+}
+
+src_install() {
+ distutils_src_install
+
+ # Don't install C sources.
+ find "${D}"usr/$(get_libdir)/python*/site-packages -name "*.c" -o -name "*.h" | xargs rm -f
+}