summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-23 22:12:12 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-23 22:12:12 +0000
commit98882ecfbe2c083ca15349f19f6abd6062ab7414 (patch)
tree6ded0b7c0620be2e4a7c53cdfe34d0b5e3eaa405 /sci-biology/bioperl-pipeline
parentMoving to sci-biology/bioperl-pipeline (diff)
downloadhistorical-98882ecfbe2c083ca15349f19f6abd6062ab7414.tar.gz
historical-98882ecfbe2c083ca15349f19f6abd6062ab7414.tar.bz2
historical-98882ecfbe2c083ca15349f19f6abd6062ab7414.zip
Moved from app-sci/bioperl-pipeline to sci-biology/bioperl-pipeline.
Diffstat (limited to 'sci-biology/bioperl-pipeline')
-rw-r--r--sci-biology/bioperl-pipeline/ChangeLog27
-rw-r--r--sci-biology/bioperl-pipeline/Manifest4
-rw-r--r--sci-biology/bioperl-pipeline/bioperl-pipeline-0.1.ebuild73
-rw-r--r--sci-biology/bioperl-pipeline/files/digest-bioperl-pipeline-0.11
-rw-r--r--sci-biology/bioperl-pipeline/metadata.xml6
5 files changed, 111 insertions, 0 deletions
diff --git a/sci-biology/bioperl-pipeline/ChangeLog b/sci-biology/bioperl-pipeline/ChangeLog
new file mode 100644
index 000000000000..081f68f43344
--- /dev/null
+++ b/sci-biology/bioperl-pipeline/ChangeLog
@@ -0,0 +1,27 @@
+# ChangeLog for app-sci/bioperl-pipeline
+# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioperl-pipeline/ChangeLog,v 1.1 2004/12/23 22:12:12 ribosome Exp $
+
+*bioperl-pipeline-0.1 (23 Dec 2004)
+
+ 23 Dec 2004; Olivier Fisette <ribosome@gentoo.org> +metadata.xml,
+ +bioperl-pipeline-0.1.ebuild:
+ Moved from app-sci/bioperl-pipeline to sci-biology/bioperl-pipeline.
+
+ 03 Aug 2004; David Holm <dholm@gentoo.org> bioperl-pipeline-0.1.ebuild:
+ Added to ~ppc.
+
+ 22 Mar 2004; Patrick Kursawe <phosphan@gentoo.org>
+ bioperl-pipeline-0.1.ebuild:
+ Removing DEPEND="${RDEPEND}"
+
+ 15 Dec 2003; Stephen Diener <sediener@gentoo.org>
+ bioperl-pipeline-0.1.ebuild:
+ Added missing dependency ncbi-tools
+
+*bioperl-pipeline-0.1 (15 Dec 2003)
+
+ 15 Dec 2003; Stephen Diener <sediener@gentoo.org>
+ bioperl-pipeline-0.1.ebuild:
+ New ebuild -- initial release
+
diff --git a/sci-biology/bioperl-pipeline/Manifest b/sci-biology/bioperl-pipeline/Manifest
new file mode 100644
index 000000000000..7dfd7b17d39c
--- /dev/null
+++ b/sci-biology/bioperl-pipeline/Manifest
@@ -0,0 +1,4 @@
+MD5 affc5f5c241ac93e24743dcb4a204eed bioperl-pipeline-0.1.ebuild 1962
+MD5 bda4eecce29fd270dedec6fd130d2d49 ChangeLog 703
+MD5 e8b4df3df76800c376905734d8043cfa metadata.xml 216
+MD5 cea8881ae00a651493915c7732732233 files/digest-bioperl-pipeline-0.1 72
diff --git a/sci-biology/bioperl-pipeline/bioperl-pipeline-0.1.ebuild b/sci-biology/bioperl-pipeline/bioperl-pipeline-0.1.ebuild
new file mode 100644
index 000000000000..0c06ca6033ad
--- /dev/null
+++ b/sci-biology/bioperl-pipeline/bioperl-pipeline-0.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bioperl-pipeline/bioperl-pipeline-0.1.ebuild,v 1.1 2004/12/23 22:12:12 ribosome Exp $
+
+inherit perl-module
+CATEGORY="app-sci"
+
+DESCRIPTION="Collection of tools for bioinformatics, genomics and life science research : Biopipe "
+HOMEPAGE="http://www.biopipe.org/"
+SRC_URI="mirror://gentoo/$P.tar.gz"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="
+ dev-db/mysql
+ >=sci-biology/ncbi-tools-20031103
+ >=sci-biology/bioperl-1.2.3
+ >=sci-biology/bioperl-run-1.2.2
+ dev-perl/XML-SimpleObject
+ dev-perl/XML-Parser
+ dev-perl/Data-ShowTable"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ # there's a test to run for BioGFFDB if using mysql
+ perl-module_src_compile || die "compile failed"
+ # make test
+ ## perl-module_src_test || die "src test failed"
+ ewarn " "
+ ewarn "Tests skipped since they will fail unless"
+ ewarn "mysql root user has no password"
+ ewarn " "
+}
+
+src_install() {
+ mydoc="AUTHORS README LICENSE INSTALL FAQ database_schema.doc database_tables.txt"
+ perl-module_src_install
+
+ # bioperl scripts and examples
+ einfo "Adding bioperl-pipeline scripts, sql and xml directories to /usr/share/${PF}..."
+ dodir /usr/share/${PF}/scripts
+ cd ${S}/scripts/
+ tar cf - ./ | ( cd ${D}/usr/share/${PF}/scripts; tar xf -)
+ dodir /usr/share/${PF}/sql
+ cd ${S}/sql/
+ tar cf - ./ | ( cd ${D}/usr/share/${PF}/sql; tar xf -)
+ dodir /usr/share/${PF}/xml
+ cd ${S}/xml/
+ tar cf - ./ | ( cd ${D}/usr/share/${PF}/xml; tar xf -)
+ dodir /usr/share/doc/${PF}/
+ cd ${S}/doc/
+ tar cf - ./ | ( cd ${D}/usr/share/doc/${PF}; tar xf -)
+ cd ${S}
+
+}
+
+pkg_postinst() {
+ einfo " "
+ einfo "You will need to modify Bio/Pipeline/PipeConf.pm "
+ einfo "with mysql user and batch job software information"
+ einfo "Read the docs in /usr/share/docs/${PF} "
+ einfo "for more information"
+ einfo " "
+}
diff --git a/sci-biology/bioperl-pipeline/files/digest-bioperl-pipeline-0.1 b/sci-biology/bioperl-pipeline/files/digest-bioperl-pipeline-0.1
new file mode 100644
index 000000000000..a489d75fab99
--- /dev/null
+++ b/sci-biology/bioperl-pipeline/files/digest-bioperl-pipeline-0.1
@@ -0,0 +1 @@
+MD5 91cd12769a4e22889a2c508c290a8965 bioperl-pipeline-0.1.tar.gz 633893
diff --git a/sci-biology/bioperl-pipeline/metadata.xml b/sci-biology/bioperl-pipeline/metadata.xml
new file mode 100644
index 000000000000..8a4bcd47220d
--- /dev/null
+++ b/sci-biology/bioperl-pipeline/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer><email>sediener@gentoo.org</email></maintainer>
+</pkgmetadata>