summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-23 19:13:38 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-23 19:13:38 +0000
commit7f1b7870d404f6f0233d8379f0322bba525edce7 (patch)
tree17dce6977e766beb7fe3c91ab4b61aa5ea4bd6ed /sci-biology/primer3/primer3-1.0.0.ebuild
parentMoving to sci-biology/primer3 (diff)
downloadhistorical-7f1b7870d404f6f0233d8379f0322bba525edce7.tar.gz
historical-7f1b7870d404f6f0233d8379f0322bba525edce7.tar.bz2
historical-7f1b7870d404f6f0233d8379f0322bba525edce7.zip
Moved from app-sci/primer3 to sci-biology/primer3.
Diffstat (limited to 'sci-biology/primer3/primer3-1.0.0.ebuild')
-rw-r--r--sci-biology/primer3/primer3-1.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-biology/primer3/primer3-1.0.0.ebuild b/sci-biology/primer3/primer3-1.0.0.ebuild
new file mode 100644
index 000000000000..072ff0107e69
--- /dev/null
+++ b/sci-biology/primer3/primer3-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/primer3/primer3-1.0.0.ebuild,v 1.1 2004/12/23 19:13:38 ribosome Exp $
+
+DESCRIPTION="Design primers for PCR reactions."
+HOMEPAGE="http://frodo.wi.mit.edu/primer3/primer3_code.html"
+SRC_URI="http://frodo.wi.mit.edu/${PN}/${PN}_${PV}.tar.gz"
+LICENSE="whitehead"
+
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+
+RDEPEND=""
+
+DEPEND="dev-lang/perl"
+
+S=${WORKDIR}/${PN}_${PV}/src
+
+src_compile() {
+ emake -e || die
+}
+
+src_test () {
+ cd ../test
+ perl primer_test.pl primer3_core || die
+}
+
+src_install () {
+ dobin primer3_core
+ dodoc release_notes ../README ../example
+}