summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-13 18:35:29 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-13 18:35:29 +0000
commit39a35ffb7e1064e5cf0fc278fe5e787e6a4e0d2b (patch)
tree52c8cabebd47e61f3ff149e651db5cb5a33a8e6c /sci-chemistry/avogadro/files
parentversion bump (diff)
downloadhistorical-39a35ffb7e1064e5cf0fc278fe5e787e6a4e0d2b.tar.gz
historical-39a35ffb7e1064e5cf0fc278fe5e787e6a4e0d2b.tar.bz2
historical-39a35ffb7e1064e5cf0fc278fe5e787e6a4e0d2b.zip
sci-chemistry/avogadro: add another missing fPIC, #446548; thanks Oldrich Jedlicka and Todd Goodman for the patch
Package-Manager: portage-2.2.0_alpha162/cvs/Linux x86_64 Manifest-Sign-Key: 0x8009D6F070EB7916
Diffstat (limited to 'sci-chemistry/avogadro/files')
-rw-r--r--sci-chemistry/avogadro/files/avogadro-1.1.0-textrel.patch16
1 files changed, 15 insertions, 1 deletions
diff --git a/sci-chemistry/avogadro/files/avogadro-1.1.0-textrel.patch b/sci-chemistry/avogadro/files/avogadro-1.1.0-textrel.patch
index 5b5cf0e4dc17..2a9b2e14a2a8 100644
--- a/sci-chemistry/avogadro/files/avogadro-1.1.0-textrel.patch
+++ b/sci-chemistry/avogadro/files/avogadro-1.1.0-textrel.patch
@@ -1,5 +1,6 @@
libavogadro/src/extensions/crystallography/spglib/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
+ libavogadro/src/extensions/swcntbuilder/tubegen/CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/libavogadro/src/extensions/crystallography/spglib/CMakeLists.txt b/libavogadro/src/extensions/crystallography/spglib/CMakeLists.txt
index fb88316..2ddcfdf 100644
@@ -13,3 +14,16 @@ index fb88316..2ddcfdf 100644
+if("${CMAKE_SYSTEM_PROCESSOR}" MATCHES "^(i.86|x86|x86_64)$")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC" )
endif()
+diff --git a/libavogadro/src/extensions/swcntbuilder/tubegen/CMakeLists.txt b/libavogadro/src/extensions/swcntbuilder/tubegen/CMakeLists.txt
+index 0cd0c3e..9e89daf 100644
+--- a/libavogadro/src/extensions/swcntbuilder/tubegen/CMakeLists.txt
++++ b/libavogadro/src/extensions/swcntbuilder/tubegen/CMakeLists.txt
+@@ -19,7 +19,7 @@ add_library(tubegen STATIC ${tubegen_SRCS})
+ set_target_properties(tubegen PROPERTIES COMPILE_FLAGS "-w")
+
+ # Set -fPIC on x86_64
+-if("${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64")
++if("${CMAKE_SYSTEM_PROCESSOR}" MATCHES "^(i.86|x86|x86_64)$")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC" )
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC" )
+ endif()