summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-02-23 15:39:44 +0000
committerJustin Lecher <jlec@gentoo.org>2011-02-23 15:39:44 +0000
commit884838e20fd454a7edf669c210ab6018bcc7ed15 (patch)
tree3a85e39ad5c36536570f4f0d1553af89dc4c9503 /sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild
parentStable for HPPA (bug #355927). (diff)
downloadhistorical-884838e20fd454a7edf669c210ab6018bcc7ed15.tar.gz
historical-884838e20fd454a7edf669c210ab6018bcc7ed15.tar.bz2
historical-884838e20fd454a7edf669c210ab6018bcc7ed15.zip
QA: Double // and missing die
Package-Manager: portage-2.2.0_alpha25/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild')
-rw-r--r--sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild b/sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild
index f84233650680..211a8770cbc6 100644
--- a/sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild
+++ b/sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild,v 1.1 2010/02/02 22:23:45 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild,v 1.2 2011/02/23 15:39:44 jlec Exp $
EAPI="3"
@@ -8,8 +8,9 @@ inherit eutils
DESCRIPTION="Automated crystallographic structure solution for MIR, SAD, and MAD"
HOMEPAGE="http://www.solve.lanl.gov/index.html"
-SRC_URI="x86? ( http://solve.lanl.gov/pub/solve/${PV}/solve-${PV}-linux.tar.gz )
- amd64? ( http://solve.lanl.gov/pub/solve/${PV}/solve-${PV}-linux-64.tar.gz )"
+SRC_URI="
+ x86? ( http://solve.lanl.gov/pub/solve/${PV}/solve-${PV}-linux.tar.gz )
+ amd64? ( http://solve.lanl.gov/pub/solve/${PV}/solve-${PV}-linux-64.tar.gz )"
SLOT="0"
LICENSE="solve"
@@ -26,7 +27,7 @@ IN_PATH="/opt/solve-resolve/"
src_install(){
exeinto ${IN_PATH}bin/
- doexe bin/*
+ doexe bin/* || die
insinto ${IN_PATH}lib/
doins -r lib/{*sym,sym*,hist*,*dat,segments,patterns} || die
@@ -49,12 +50,12 @@ src_install(){
PATH="${EPREFIX}/${IN_PATH}bin"
EOF
- doenvd "${T}"/20solve-resolve
+ doenvd "${T}"/20solve-resolve || die
}
pkg_postinst(){
einfo "Get a valid license key from"
einfo "http://solve.lanl.gov/license.html"
einfo "and place it in"
- einfo "${EPREFIX}/${IN_PATH}lib/"
+ einfo "${EPREFIX}${IN_PATH}lib/"
}