summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-07-02 08:56:56 +0000
committerJustin Lecher <jlec@gentoo.org>2011-07-02 08:56:56 +0000
commit0f2782b18fbfc216b6bb2fb24a7d2709a9b21559 (patch)
treef5bd465a257e614c4576b0d140440167d914ba43 /sci-chemistry
parentVersion bump thanks to Justin Lecher (bug #373737). (diff)
downloadhistorical-0f2782b18fbfc216b6bb2fb24a7d2709a9b21559.tar.gz
historical-0f2782b18fbfc216b6bb2fb24a7d2709a9b21559.tar.bz2
historical-0f2782b18fbfc216b6bb2fb24a7d2709a9b21559.zip
Use pkg-config to detect mmdb and lapack libs
Package-Manager: portage-2.2.0_alpha43/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/apbs/ChangeLog6
-rw-r--r--sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild6
-rw-r--r--sci-chemistry/apbs/apbs-1.3-r1.ebuild6
-rw-r--r--sci-chemistry/apbs/apbs-1.3.ebuild6
-rw-r--r--sci-chemistry/apbs/metadata.xml18
-rw-r--r--sci-chemistry/molrep/ChangeLog6
-rw-r--r--sci-chemistry/molrep/metadata.xml8
-rw-r--r--sci-chemistry/molrep/molrep-11.0.02.ebuild4
8 files changed, 34 insertions, 26 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index b81d48ff05fc..eba59b3182cd 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.48 2011/06/21 16:07:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.49 2011/07/02 08:56:56 jlec Exp $
+
+ 02 Jul 2011; Justin Lecher <jlec@gentoo.org> apbs-1.2.1b-r4.ebuild,
+ apbs-1.3.ebuild, apbs-1.3-r1.ebuild, metadata.xml:
+ Use pkg-config to detect mmdb and lapack libs
21 Jun 2011; Justin Lecher <jlec@gentoo.org> apbs-1.2.1b-r4.ebuild,
apbs-1.3.ebuild, apbs-1.3-r1.ebuild:
diff --git a/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild b/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
index 57f1b2f70d94..00f87514ed85 100644
--- a/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
+++ b/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild,v 1.11 2011/06/21 16:07:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild,v 1.12 2011/07/02 08:56:56 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
+inherit autotools eutils flag-o-matic fortran-2 python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -80,7 +80,7 @@ src_configure() {
econf \
--disable-maloc-rebuild \
--enable-shared \
- --with-blas=-lblas \
+ --with-blas="$(pkg-config --libs blas)" \
$(use_enable openmp) \
$(use_enable python) \
$(use_enable tools) \
diff --git a/sci-chemistry/apbs/apbs-1.3-r1.ebuild b/sci-chemistry/apbs/apbs-1.3-r1.ebuild
index b686e745cd1a..894cf101e429 100644
--- a/sci-chemistry/apbs/apbs-1.3-r1.ebuild
+++ b/sci-chemistry/apbs/apbs-1.3-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3-r1.ebuild,v 1.5 2011/06/21 16:07:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3-r1.ebuild,v 1.6 2011/07/02 08:56:56 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
+inherit autotools eutils flag-o-matic fortran-2 python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -108,7 +108,7 @@ src_configure() {
econf \
--disable-maloc-rebuild \
--enable-shared \
- --with-blas=-lblas \
+ --with-blas="$(pkg-config --libs blas)" \
$(use_enable openmp) \
$(use_enable python) \
$(use_enable tools) \
diff --git a/sci-chemistry/apbs/apbs-1.3.ebuild b/sci-chemistry/apbs/apbs-1.3.ebuild
index a35ae022f15d..5939b16a69f2 100644
--- a/sci-chemistry/apbs/apbs-1.3.ebuild
+++ b/sci-chemistry/apbs/apbs-1.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3.ebuild,v 1.7 2011/06/21 16:07:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3.ebuild,v 1.8 2011/07/02 08:56:56 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
+inherit autotools eutils flag-o-matic fortran-2 python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -105,7 +105,7 @@ src_configure() {
econf \
--disable-maloc-rebuild \
--enable-shared \
- --with-blas=-lblas \
+ --with-blas="$(pkg-config --libs blas)" \
$(use_enable openmp) \
$(use_enable python) \
$(use_enable tools) \
diff --git a/sci-chemistry/apbs/metadata.xml b/sci-chemistry/apbs/metadata.xml
index 8a1c32e03b3d..568638098427 100644
--- a/sci-chemistry/apbs/metadata.xml
+++ b/sci-chemistry/apbs/metadata.xml
@@ -2,21 +2,21 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci-chemistry</herd>
- <maintainer>
- <email>markusle@gentoo.org</email>
- <name>Markus Dittrich</name>
- </maintainer>
+ <maintainer>
+ <email>markusle@gentoo.org</email>
+ <name>Markus Dittrich</name>
+ </maintainer>
<maintainer>
<email>jlec@gentoo.org</email>
<name>Justin Lecher</name>
<description>Ebuild Crasher</description>
- </maintainer>
+ </maintainer>
<use>
- <flag name='arpack'>Include support for arpack libs</flag>
- <flag name='fetk'>Include support for FeTK</flag>
- <flag name='tools'>Install optional tools</flag>
+ <flag name="arpack">Include support for arpack libs</flag>
+ <flag name="fetk">Include support for FeTK</flag>
+ <flag name="tools">Install optional tools</flag>
</use>
-<longdescription>
+ <longdescription>
APBS is a software package for modeling biomolecular solvation through solution
of the Poisson-Boltzmann equation (PBE), one of the most popular continuum
models for describing electrostatic interactions between molecular solutes in
diff --git a/sci-chemistry/molrep/ChangeLog b/sci-chemistry/molrep/ChangeLog
index 8649ee40d740..6edd0f6248f4 100644
--- a/sci-chemistry/molrep/ChangeLog
+++ b/sci-chemistry/molrep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/molrep
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/ChangeLog,v 1.17 2011/06/28 19:49:30 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/ChangeLog,v 1.18 2011/07/02 08:55:01 jlec Exp $
+
+ 02 Jul 2011; Justin Lecher <jlec@gentoo.org> molrep-11.0.02.ebuild,
+ metadata.xml:
+ Use pkg-config to detect mmdb and lapack libs
28 Jun 2011; Brent Baude <ranger@gentoo.org> molrep-11.0.02.ebuild:
Marking molrep-11.0.02 ppc for bug 352065
diff --git a/sci-chemistry/molrep/metadata.xml b/sci-chemistry/molrep/metadata.xml
index dde7ca88a50f..1837bbc07a6e 100644
--- a/sci-chemistry/molrep/metadata.xml
+++ b/sci-chemistry/molrep/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/sci-chemistry/molrep/molrep-11.0.02.ebuild b/sci-chemistry/molrep/molrep-11.0.02.ebuild
index 5f66539eda95..237be9858c53 100644
--- a/sci-chemistry/molrep/molrep-11.0.02.ebuild
+++ b/sci-chemistry/molrep/molrep-11.0.02.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/molrep-11.0.02.ebuild,v 1.7 2011/06/28 19:49:30 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/molrep-11.0.02.ebuild,v 1.8 2011/07/02 08:55:01 jlec Exp $
EAPI="3"
@@ -37,7 +37,7 @@ src_compile() {
MR_FORT="$(tc-getFC) ${FFLAGS}" \
FFLAGS="${FFLAGS}" \
LDFLAGS="${LDFLAGS}" \
- MR_LIBRARY="-L${EPREFIX}/usr/$(get_libdir) -lccp4f -lccp4c -lmmdb -lccif -llapack -lstdc++ -lm" \
+ MR_LIBRARY="-L${EPREFIX}/usr/$(get_libdir) -lccp4f -lccp4c $(pkg-config --libs mmdb lapack) -lccif -lstdc++ -lm" \
|| die
}