summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-03-31 14:53:53 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-03-31 14:53:53 +0000
commitbe3f0ced10c61aff2883e549329d17d79a77d3f6 (patch)
tree4ba49283a1058d74498a3f6ece950e51ed028b05 /sci-libs/acml/acml-3.6.0-r1.ebuild
parentUpdated SRC_URI to use rubyforge mirrors (diff)
downloadhistorical-be3f0ced10c61aff2883e549329d17d79a77d3f6.tar.gz
historical-be3f0ced10c61aff2883e549329d17d79a77d3f6.tar.bz2
historical-be3f0ced10c61aff2883e549329d17d79a77d3f6.zip
Forced -Wl,--no-as-needed in the pkg-config files. Now blas and lapack pkg-config point to the static acml directory instead of the dynamic libblas and liblapack
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'sci-libs/acml/acml-3.6.0-r1.ebuild')
-rw-r--r--sci-libs/acml/acml-3.6.0-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sci-libs/acml/acml-3.6.0-r1.ebuild b/sci-libs/acml/acml-3.6.0-r1.ebuild
index 7d0349efe685..0138f36c2468 100644
--- a/sci-libs/acml/acml-3.6.0-r1.ebuild
+++ b/sci-libs/acml/acml-3.6.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.6.0-r1.ebuild,v 1.7 2008/01/08 09:46:17 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.6.0-r1.ebuild,v 1.8 2008/03/31 14:53:52 bicatali Exp $
inherit eutils toolchain-funcs fortran
@@ -95,6 +95,7 @@ src_install() {
# install profiles
ESELECT_PROF=acml-${FORTRANC}
local acmldir=${instdir}/${fort}
+ local acmllibs="-lacml -lacml_mv"
local libname=${acmldir}/lib/libacml
local extlibs
local extflags
@@ -102,6 +103,7 @@ src_install() {
if [[ ${fort} =~ _mp ]]; then
ESELECT_PROF=${ESELECT_PROF}-openmp
extlibs="${extlibs} -lpthread"
+ acmllibs="-lacml_mp -lacml_mv"
libname=${libname}_mp
extflags="${extflags} -openmp"
fi
@@ -110,6 +112,7 @@ src_install() {
sed -e "s:@LIBDIR@:$(get_libdir):" \
-e "s:@PV@:${PV}:" \
-e "s:@ACMLDIR@:${acmldir}:g" \
+ -e "s:@ACMLLIBS@:${acmllibs}:g" \
-e "s:@EXTLIBS@:${extlibs}:g" \
-e "s:@EXTFLAGS@:${extflags}:g" \
"${FILESDIR}"/${l}.pc.in > ${l}.pc \