summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-03-26 00:32:45 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-03-26 00:32:45 +0000
commit5a60dcdac2b1d4d3c32c57cd87126525f02aa580 (patch)
tree7079ca8d5f433a5974c990bb111bdced059db5fb /sci-libs/libgeda/libgeda-20050313.ebuild
parentStable on ppc. (diff)
downloadhistorical-5a60dcdac2b1d4d3c32c57cd87126525f02aa580.tar.gz
historical-5a60dcdac2b1d4d3c32c57cd87126525f02aa580.tar.bz2
historical-5a60dcdac2b1d4d3c32c57cd87126525f02aa580.zip
Version bump.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sci-libs/libgeda/libgeda-20050313.ebuild')
-rw-r--r--sci-libs/libgeda/libgeda-20050313.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-libs/libgeda/libgeda-20050313.ebuild b/sci-libs/libgeda/libgeda-20050313.ebuild
new file mode 100644
index 000000000000..7185a0e6a153
--- /dev/null
+++ b/sci-libs/libgeda/libgeda-20050313.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-20050313.ebuild,v 1.1 2005/03/26 00:32:45 plasmaroo Exp $
+
+HOMEPAGE="http://www.geda.seul.org"
+DESCRIPTION="libgeda - this library provides functions needed for a working gEDA/gaf system"
+SRC_URI="http://www.geda.seul.org/devel/${PV}/libgeda-${PV}.tar.gz"
+
+IUSE="png static"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+
+DEPEND=">=dev-libs/glib-2.4.8
+ >=x11-libs/gtk+-2.2
+ virtual/x11
+
+ >=dev-util/guile-1.6.3
+ >=dev-util/pkgconfig-0.15.0
+ png? ( >=sci-libs/libgdgeda-2.0.15 )"
+
+src_compile () {
+ local myconf
+
+ use png || myconf='--disable-gdgeda'
+ use static && myconf="${myconf} --enable-static --disable-shared"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ einstall || die
+ dodoc AUTHORS COPYING ChangeLog README
+}