summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-04-19 22:38:31 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-04-19 22:38:31 +0000
commit6cf37d3ff100986b19b4ad6ff83ce5887bc12a5e (patch)
treeaad249c1482558d2f4216aa81fc12eb2148a1e59 /sci-libs/libnc-dap
parentVersion bump. (diff)
downloadhistorical-6cf37d3ff100986b19b4ad6ff83ce5887bc12a5e.tar.gz
historical-6cf37d3ff100986b19b4ad6ff83ce5887bc12a5e.tar.bz2
historical-6cf37d3ff100986b19b4ad6ff83ce5887bc12a5e.zip
New ebuild for OPeNDAP NetCDF library, a required dependency for ferret.
Package-Manager: portage-2.2_rc30/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/libnc-dap')
-rw-r--r--sci-libs/libnc-dap/ChangeLog11
-rw-r--r--sci-libs/libnc-dap/Manifest5
-rw-r--r--sci-libs/libnc-dap/files/libnc-dap-3.7.3_template-fix.patch11
-rw-r--r--sci-libs/libnc-dap/libnc-dap-3.7.3.ebuild99
-rw-r--r--sci-libs/libnc-dap/metadata.xml16
5 files changed, 142 insertions, 0 deletions
diff --git a/sci-libs/libnc-dap/ChangeLog b/sci-libs/libnc-dap/ChangeLog
new file mode 100644
index 000000000000..df4901d23eca
--- /dev/null
+++ b/sci-libs/libnc-dap/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/libnc-dap
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnc-dap/ChangeLog,v 1.1 2009/04/19 22:38:31 nerdboy Exp $
+
+*libnc-dap-3.7.3 (19 Apr 2009)
+
+ 19 Apr 2009; Steve Arnold <nerdboy@gentoo.org>
+ +files/libnc-dap-3.7.3_template-fix.patch, +metadata.xml,
+ +libnc-dap-3.7.3.ebuild:
+ New ebuild for OPeNDAP NetCDF library, a required dependency for ferret.
+
diff --git a/sci-libs/libnc-dap/Manifest b/sci-libs/libnc-dap/Manifest
new file mode 100644
index 000000000000..9dcc22fe8347
--- /dev/null
+++ b/sci-libs/libnc-dap/Manifest
@@ -0,0 +1,5 @@
+AUX libnc-dap-3.7.3_template-fix.patch 273 RMD160 6abafea1b044bc976efe1b93f0699fbe9cc37c52 SHA1 491d73a1af4c20abccd8f9f30461207b8616eb6c SHA256 324fcde3f2a14fc73264860b24cc3490ed250c884e387230cf6391674c6d88cf
+DIST libnc-dap-3.7.3.tar.gz 799282 RMD160 d99025ad66a54d7676fe44a6a29d93c272a2e582 SHA1 785726c7920daeb11de8989753da44e166ebd8e5 SHA256 38847e04ecb385e78241c31c327bfe8abebaef49cdc0fa1ad0c1f0b172ea0a3a
+EBUILD libnc-dap-3.7.3.ebuild 2865 RMD160 b204cdeeaab41f4ba57ff436a28b48d03f4c710e SHA1 19265cfb5461bafe62a81031cbfe4399e948666d SHA256 5210fd59c2cd98af5ac565e60b309fdc3b5b80647d1af053e2d971bd75ca0b6a
+MISC ChangeLog 454 RMD160 7d02062680becb2103234fd2985362efc868c96b SHA1 cb968b39c014ee09dbb6444cb1dcd1446435ab0a SHA256 557eb2ec5353290099e77aea46f896158a348a26585be408fff640f8546837f9
+MISC metadata.xml 574 RMD160 f91856d6db33ab75ad7294ae979fac1bd9ce7120 SHA1 e98d2bb82144a176204b2fac54c8b79695e7a303 SHA256 5679ce3e7ca782571f94dcb77c77ab9e1cd1ceeb6753783b4b53e210c6336231
diff --git a/sci-libs/libnc-dap/files/libnc-dap-3.7.3_template-fix.patch b/sci-libs/libnc-dap/files/libnc-dap-3.7.3_template-fix.patch
new file mode 100644
index 000000000000..ac903f0c6022
--- /dev/null
+++ b/sci-libs/libnc-dap/files/libnc-dap-3.7.3_template-fix.patch
@@ -0,0 +1,11 @@
+--- Dnc.cc.orig 2009-04-18 22:52:49.799577635 -0700
++++ Dnc.cc 2009-04-18 22:54:06.001575924 -0700
+@@ -81,6 +81,8 @@
+
+ int rcode;
+
++template NCConnect* & Connections<NCConnect *>::operator[](int i);
++
+ Connections < NCConnect * >*conns = 0;
+
+ static void delete_conns()
diff --git a/sci-libs/libnc-dap/libnc-dap-3.7.3.ebuild b/sci-libs/libnc-dap/libnc-dap-3.7.3.ebuild
new file mode 100644
index 000000000000..26d33910fdcd
--- /dev/null
+++ b/sci-libs/libnc-dap/libnc-dap-3.7.3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnc-dap/libnc-dap-3.7.3.ebuild,v 1.1 2009/04/19 22:38:31 nerdboy Exp $
+
+inherit eutils flag-o-matic fortran
+
+DESCRIPTION="An OPeNDAP-enabled version of the NetCDF 3.6 API that replaces the standard NetCDF library."
+HOMEPAGE="http://opendap.org/index.html"
+SRC_URI="http://opendap.org/pub/source/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug fortran full-test"
+
+RDEPEND="dev-util/cppunit
+ full-test? ( dev-util/dejagnu )"
+
+DEPEND="${RDEPEND}
+ sys-libs/zlib
+ >=dev-libs/libxml2-2.5.7
+ >=net-misc/curl-7.10.6
+ <=sci-libs/libdap-3.8.2
+ !sci-libs/netcdf"
+
+pkg_setup() {
+ if use full-test; then
+ if [ -n "${DAP_TEST_OPTS}" ]; then
+ elog "User-specified test URL is ${DAP_TEST_OPTS}."
+ else
+ elog "User-specified test URL is not set; if needed, set"
+ elog "DAP_TEST_OPTS to a URL of your choice and rebuild."
+ fi
+ elog
+ elog "The full regression test does two passes, the second one with"
+ elog "remote data queries. The latter part can take several hours,"
+ elog "so hit Ctl-C now and set USE=-full-test if you'd rather not."
+ epause 10
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # increase the number of open netcdf files
+ sed -i -e "s:MAX_NC_OPEN 32:MAX_NC_OPEN 128:g" \
+ lnetcdf/{lnetcdf.h,netcdf.h} \
+ || die "sed headers failed"
+ # missing definition causes unknown symbol errors
+ epatch "${FILESDIR}"/${P}_template-fix.patch
+}
+
+src_compile() {
+ local test_conf="${DAP_TEST_OPTS}"
+ local myconf="--disable-dependency-tracking --enable-largefile"
+
+ # debug can be set to 2 for extra verbosity
+ use debug && myconf="${myconf} --enable-debug=1"
+ econf ${myconf} ${test_conf} || die "econf failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_test() {
+ if use full-test; then
+ cd "${S}"/nc_test
+ # These tests should all pass, but the non-local pass can take
+ # several hours to complete.
+ make check || die "Regression tests failed!"
+ cd "${S}"
+ # This test has unexpected failures
+ make check
+ else
+ # unit tests only
+ cd "${S}"/unit-tests
+ ln -sf ../ncdump/testsuite testsuite
+ # These tests should also pass
+ make check || die "Unit tests failed!"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README NEWS README.translation
+}
+
+pkg_postinst() {
+ elog
+ elog "If you want to run the regression tests with a custom URL and"
+ elog "dataset then you can pass it via the following option:"
+ elog
+ elog "DAP_TEST_OPTS=--with-data-url=<your URL> emerge libnc-dap"
+ elog
+ elog "for example, http://test.opendap.org/opendap/nph-dods/data/nc/test.nc"
+ elog "Just make sure you have test enabled in your FEATURES and"
+ elog "an active Internet connection."
+ elog
+}
diff --git a/sci-libs/libnc-dap/metadata.xml b/sci-libs/libnc-dap/metadata.xml
new file mode 100644
index 000000000000..4f9cdd40f035
--- /dev/null
+++ b/sci-libs/libnc-dap/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-geosciences</herd>
+<maintainer>
+ <email>nerdboy@gentoo.org</email>
+</maintainer>
+<longdescription>
+libnc-dap is the NetCDF interface for OPeNDAP (based on the standard netcdf
+3.6 API), and adds the capability to dereference OPeNDAP URLs.
+DAP is a NASA community standard: http://www.esdswg.org/spg/rfc/ese-rfc-004
+</longdescription>
+<use>
+ <flag name='full-test'>Enables full set of regression tests (long).</flag>
+</use>
+</pkgmetadata>